05-09-2011 09:55 AM - edited 03-06-2019 04:58 PM
Hi!
My ISP provides me with a public ip address which I have connected to the port g1/0/24 of my Catalyst 3750.
I have this configuration which allows me to ping any external address from my switch, but when I try ping to an external address (google.com) from my laptop (g1/0/1 2) I doesn't get out, even when I try to ping the gateway which the ISP gave me it times out.
...
hostname Switch
!
enable secret 5 $1$93L9$GrhoWTsXbRbXK3rwl90GC/
!
no aaa new-model
clock timezone UTC 1
switch 1 provision ws-c3750g-24ts-1u
system mtu routing 1500
vtp domain [myName]
vtp mode transparent
ip subnet-zero
ip routing
!
!
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
vlan 2,10
!
interface GigabitEthernet1/0/1
description User
switchport access vlan 2
switchport mode access
!
interface GigabitEthernet1/0/2
!
interface GigabitEthernet1/0/3
!
interface GigabitEthernet1/0/4
!
interface GigabitEthernet1/0/5
switchport access vlan 10
switchport trunk native vlan 10
!
interface GigabitEthernet1/0/6
!
interface GigabitEthernet1/0/7
!
interface GigabitEthernet1/0/8
!
interface GigabitEthernet1/0/9
!
interface GigabitEthernet1/0/10
!
interface GigabitEthernet1/0/11
!
interface GigabitEthernet1/0/12
!
interface GigabitEthernet1/0/13
!
interface GigabitEthernet1/0/14
!
interface GigabitEthernet1/0/15
!
interface GigabitEthernet1/0/16
!
interface GigabitEthernet1/0/17
!
interface GigabitEthernet1/0/18
!
interface GigabitEthernet1/0/19
!
interface GigabitEthernet1/0/20
!
interface GigabitEthernet1/0/21
!
interface GigabitEthernet1/0/22
!
interface GigabitEthernet1/0/23
!
interface GigabitEthernet1/0/24
no switchport
ip address 196.202.255.33 255.255.255.0
!
interface GigabitEthernet1/0/25
switchport access vlan 10
switchport trunk native vlan 10
!
interface GigabitEthernet1/0/26
switchport access vlan 10
switchport trunk native vlan 10
!
interface GigabitEthernet1/0/27
switchport access vlan 10
switchport trunk native vlan 10
!
interface GigabitEthernet1/0/28
!
interface Vlan1
no ip address
shutdown
!
interface Vlan2
description User
ip address 10.128.2.1 255.255.255.0
!
interface Vlan10
description Management
ip address 10.128.1.1 255.255.255.0
!
ip default-gateway 196.202.255.254
ip classless
ip route 0.0.0.0 0.0.0.0 196.202.255.254
ip http server
!
....
05-09-2011 10:08 AM
You don't have any NAT configuration. You need NAT. But NAT is not supported on Catalyst switches such as 3750. The only Catalyst switch that supports NAT is 6500. You will need a router, something like Cisco 1841 or 1941
05-09-2011 10:58 AM
Roman is correct. Your internal addresses are not routed on the internet so you will need to implement NAT so that your traffic is viewed as a routable ip by the internet. A router will be required for this.
05-09-2011 12:34 PM
Thanks a lot guys
05-09-2011 03:33 PM
I guess that the switches 3750 are layer 3
can you type the: ip routing command on your switch?
You can configure a PAT and the 3750 accepts any kind of NAT....... BUT if you have a correct IOS.
Good luck.
05-09-2011 05:44 PM
3750 doesn't support NAT or PAT with any IOS
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide