Showing results for 
Search instead for 
Did you mean: 
Join Customer Connection to register!
paul dungey

Cannot access web interface on cisco switch


I have the following cisco switch models

4 x Cisco Switch 2950 IOS 12.1

2 x Cisco Switch 2960 IOS 12.2

1 x cisco switch 3750 IOS  12.2

Each switch has a password for Enable, console, VTY

Each switch has default vlan1 set to a static IP issued form my Zytel 100 usg firewall

I've enabled the command on "configuration terminal" ip http server, on one of my switches the cisco 2950 as above, saved the running config

went over to an other  machine and typed the static Ip in got page cannot be displayed

does the IOS version 12.1 and IOS 12.2 support web interface or am i doing something wrong.

Thank you



It's quite possible they had been configured with "no ip http server" and "no ip http secure server" - this is a common practice to secure cisco switches.


Ive set two diffirent switches up and configured the switch to allow "ip http server" and a different switch the same but added the extra commnd ip http secure-server, saved the configuration.

I also need to mention that the switches will not have internet access and i've not enable static ip for default gateway, if this helps with the problem, rather than set up the switched through the console port i need to be able to manage the switches through web interface this is the compnay requirements. even though i've set up the IP on one of my switches inder defalt vlan1 would this make any diffrence  as o why i cannot access the switchs web interface ?

Are you doing everything in VLAN1?

Can you ping or telnet to the address (i.e. is it reachable)?  Are you trying to reach the switches from a port on the switch, or within the same vlan?

Is the port that switch uses to connect to the other switches - is it up/live (green port light on, blinking occasionally)?

Every switch is in VLAN1 cannot ping IP

Ive just set up a different switch and reset backt to factory defaults

set VLAN1 to set configured to allow http  ip http server on config t

set port to no shut  saved configuration connected a laptop to port 43 got a blinking green light, was able to ping the vlan address, openned a web page and typed logon box came up

tried the following combination od user name and password but still not able to access web itnerface

Admin  cisco

admin password

password password

Isn't the interface vlan 1 "shut" by default?

try to create a new user I don't think there is a default user for web-interface.

Btw. i don't know why you want to use the web-interface. It horrible!