cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3297
Views
5
Helpful
19
Replies

Cannot successfully setup static routes so devices can ping each other

jahedhussein
Level 1
Level 1

In my diagram on packet tracer, I have 3 routers. I have connected all 3 routers together so I now need to setup static routes so that a PC on one of the subnets can successfully ping another PC from a different subnet. 

 

For example, PC1 in subnet A has:

Screenshot_8.png

AND I want it to ping PC2 in subnet B which has:

Screenshot_7.png

however, I cannot do this as I am struggling to setup the static routes.

 

I managed to connect the routers to one another but I cannot get my head around the static routes. Any help would be appreciate as I need to have it completed very very soon.

 

1 Accepted Solution

Accepted Solutions

Hello,

 

I have added an IP address to FastEthernet0/0 on the Glasgow router, and changed the subnet mask on the LAN interface of the Edinburg router. All PCs have been set to DHCP.

 

Attached the revised file.

View solution in original post

19 Replies 19

Hello,

 

post the zipped Packet Tracer project (.pkt) file.

There, hope the IP's aren't cleared

Hello
Basic example of static routing
PC A = 133.221.192.16/25
PC B = 133.221.193.16/25

R1
int x/x
description connecting to pc A
ip address 133.221.192.99 255.255.255.128

int x/x
description connecting to R2
ip address 10.1.12.1 255.255.255.252

ip route 133.221.193.0 255.255.255.128 10.1.12.2

 

R2
int x/x
description connecting to R1
ip address 10.1.12.2 255.255.255.252

int x/x
description connecting to R3
ip address 10.1.23.2 255.255.255.252


ip route 133.221.192.0 255.255.255.128 10.1.12.1
ip route 133.221.193.0 255.255.255.128 10.1.23.1


R3
int x/x
description connecting to pc B
ip address 133.221.193.99 255.255.255.128

int x/x
description connecting to R2
ip address 10.1.23.1 255.255.255.252

ip route 133.221.192.0 255.255.255.128 10.1.23.2


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Thank you for your response Paul, I appreciate it. 

 

I was told to stay away from the CLI for now but I think I get it.

 

So if I wanted PC1 from subnet A to communicate with PC2 from subnet B from subnet A router my static route would look like this 

 

Screenshot_11.png

Hello,

 

the LAN IP addresses in subnet A and subnet B are overlapping, they share the same address space. What are the requirements of your project ? Are you supposed to use NAT ? What addressing are you supposed to use ?

I was told to develop a suitable fixed-length subnet mask IP addressing scheme and assign subnet and host addresses for the PC's.

 

The three subnets would need to be connected via point-to-point WAN links. I should make my IP design on the domain IP address 133.221.192.0.

Screenshot_12.png

 

Hello.

 

I changed the LAN IP address of the Aberdeen router, and added all static routes to all routers. Just make sure that the subnets on either side of the network don't overlap.

 

Attached the revised file (you need Packet Tracer version 8.1 in order to be able to open the file).

Hi Georg. 

 

I can't open the file as I have the 8.0.1 version as my institution has not updated our versions. Is there any other way I can open it?

 

Edit: I updated

Hello,

 

can you open the file ?

Hi Georg.

 

Thank you for the revision. Yes, I can open the file but I cannot seem to figure out how to get the PC's to ping each other.

 

Hello,

 

try and ping PC0 in the 'Workgroups' LAN from PC1 in the 'Building1' group.

 

133.221.192.16 to 133.221.192.194

 

Does that work ?

Hello Georg, 

 

No it does not seem to work. I am getting "Request timed out".

Odd, as I have the same file opened that I sent to you, and I can ping successfully. Make sure all PCs are set to DHCP (not static IP addressing), as I have configured the Edinburgh and Aberdeen routers to function as DHCP server.

 

Here are the router configs, just in case they were not saved correctly.

 

EDINBURGH_WAN_ROUTER#sh run
Building configuration...

Current configuration : 932 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname EDINBURGH_WAN_ROUTER
!
ip dhcp pool LAN
network 133.221.192.0 255.255.255.128
default-router 133.221.192.99
!
ip cef
no ipv6 cef
!
interface FastEthernet0/0
ip address 133.221.192.99 255.255.255.128
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
shutdown
!
interface Serial2/0
ip address 133.221.192.129 255.255.255.252
clock rate 2000000
!
interface Serial3/0
no ip address
clock rate 2000000
shutdown
!
interface FastEthernet4/0
no ip address
shutdown
!
interface FastEthernet5/0
no ip address
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 133.221.192.130
!
ip flow-export version 9
!
no cdp run
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end

 

GLASGOW_WAN_ROUTER#sh run
Building configuration...

Current configuration : 886 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname GLASGOW_WAN_ROUTER
!
ip cef
no ipv6 cef
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
shutdown
!
interface Serial2/0
ip address 133.221.192.225 255.255.255.252
clock rate 2000000
!
interface Serial3/0
ip address 133.221.192.130 255.255.255.252
!
interface FastEthernet4/0
no ip address
shutdown
!
interface FastEthernet5/0
no ip address
shutdown
!
ip classless
ip route 133.221.192.0 255.255.255.128 133.221.192.129
ip route 133.221.192.192 255.255.255.224 133.221.192.226
!
ip flow-export version 9
!
no cdp run
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end

 

ABERDEEN_WAN_ROUTER#sh run
Building configuration...

Current configuration : 956 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname ABERDEEN_WAN_ROUTER
!
ip dhcp excluded-address 133.221.192.193
!
ip dhcp pool LAN
network 133.221.192.192 255.255.255.224
default-router 133.221.192.193
!
ip cef
no ipv6 cef
!
interface FastEthernet0/0
ip address 133.221.192.193 255.255.255.224
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
shutdown
!
interface Serial2/0
ip address 133.221.192.226 255.255.255.252
!
interface Serial3/0
no ip address
clock rate 2000000
shutdown
!
interface FastEthernet4/0
no ip address
shutdown
!
interface FastEthernet5/0
no ip address
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 133.221.192.225
!
ip flow-export version 9
!
no cdp run
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end

I am not sure why I cannot ping the other PCs from the other subnets. I put PC1 on DHCP but I still cannot ping the other PC from Aberdeen or Glasgow

 

Edit: I reloaded it, and it finally pings!  Could I ask why you changed the IP configuration to DHCP?

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card