12-16-2023 04:14 AM
I am a beginner when it comes to vlans and this is hurting my brain. I am trying to access a server that I created a vlan for. When the port GigabitEthernet 1/0/3 is set to an access port on vlan 200, which is the vlan that I designated for my homelab, I can access the server. I also am trying to set up proxmox to allow vlan tagging in my VMs. To my understanding, I need to change the access port to a trunk port. When I do this, I am no longer able to connect to the server at 192.168.200.5 from my default VLAN. I also have a Unifi device that VLAN 200 is configured on as well as that is my router at the current moment. I will post my running-config and any other configs that are necessary to resolve. Thank you.
Current configuration : 2466 bytes
!
! Last configuration change at 00:26:17 UTC Mon Jan 2 2006
!
version 15.0
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Switch
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
switch 1 provision ws-c2960s-48ts-l
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
!
!
!
!
!
!
vlan internal allocation policy ascending
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0
no ip address
shutdown
!
interface GigabitEthernet1/0/1 - This is the Unifi connection coming into the switch.
switchport trunk native vlan 200
switchport mode trunk
!
interface GigabitEthernet1/0/2
!
interface GigabitEthernet1/0/3 - This is the port in which the Proxmox server is connected.
switchport mode trunk
!
interface GigabitEthernet1/0/4
!
interface GigabitEthernet1/0/5
!
interface GigabitEthernet1/0/6
!
interface GigabitEthernet1/0/7
!
interface GigabitEthernet1/0/8
!
interface GigabitEthernet1/0/9
!
interface GigabitEthernet1/0/10
!
interface GigabitEthernet1/0/11
!
interface GigabitEthernet1/0/12
!
interface GigabitEthernet1/0/13
!
interface GigabitEthernet1/0/14
!
interface GigabitEthernet1/0/15
!
interface GigabitEthernet1/0/16
!
interface GigabitEthernet1/0/17
!
interface GigabitEthernet1/0/18
!
interface GigabitEthernet1/0/19
!
interface GigabitEthernet1/0/20
!
interface GigabitEthernet1/0/21
!
interface GigabitEthernet1/0/22
!
interface GigabitEthernet1/0/23
!
interface GigabitEthernet1/0/24
!
interface GigabitEthernet1/0/25
!
interface GigabitEthernet1/0/26
!
interface GigabitEthernet1/0/27
!
interface GigabitEthernet1/0/28
!
interface GigabitEthernet1/0/29
!
interface GigabitEthernet1/0/30
!
interface GigabitEthernet1/0/31
!
interface GigabitEthernet1/0/32
!
interface GigabitEthernet1/0/33
!
interface GigabitEthernet1/0/34
!
interface GigabitEthernet1/0/35
!
interface GigabitEthernet1/0/36
!
interface GigabitEthernet1/0/37
!
interface GigabitEthernet1/0/38
!
interface GigabitEthernet1/0/39
!
interface GigabitEthernet1/0/40
!
interface GigabitEthernet1/0/41
!
interface GigabitEthernet1/0/42
!
interface GigabitEthernet1/0/43
!
interface GigabitEthernet1/0/44
!
interface GigabitEthernet1/0/45
!
interface GigabitEthernet1/0/46
!
interface GigabitEthernet1/0/47
!
interface GigabitEthernet1/0/48
!
interface GigabitEthernet1/0/49
!
interface GigabitEthernet1/0/50
!
interface GigabitEthernet1/0/51
!
interface GigabitEthernet1/0/52
!
interface Vlan1
ip address dhcp
!
ip http server
ip http secure-server
!
!
!
vstack
!
line con 0
line vty 5 15
!
end
Switch#
Solved! Go to Solution.
12-16-2023 04:28 AM
Hello @Thomassimmons1987
Do you check within Proxmox, that the VMs are configured to use VLAN tagging if required.
Ensure that the VMs have the correct VLAN ID configured in their network settings.
12-16-2023 04:22 AM
Can i see show interface trunk
MHM
12-16-2023 04:24 AM
Switch#show interface trunk
Port Mode Encapsulation Status Native vlan
Gi1/0/1 on 802.1q trunking 200
Gi1/0/3 on 802.1q trunking 1
Port Vlans allowed on trunk
Gi1/0/1 1-4094
Gi1/0/3 1-4094
Port Vlans allowed and active in management domain
Gi1/0/1 1,200
Gi1/0/3 1,200
Port Vlans in spanning tree forwarding state and not pruned
Gi1/0/1 1,200
Gi1/0/3 1,200
Switch#
12-16-2023 04:27 AM - edited 12-16-2023 04:27 AM
Switch#show interface trunk
Port Mode Encapsulation Status Native vlan
Gi1/0/1 on 802.1q trunking 200
Gi1/0/3 on 802.1q trunking 1
Can SW have two native vlan?
Sure NO' you need to match native vlan in all your network' in this SW and all other SW otherwise you will face same issue as you have
So change native vlan for trunk connect to server to be 1.
MHM
12-16-2023 04:31 AM
Switch#show interface trunk
Port Mode Encapsulation Status Native vlan
Gi1/0/1 on 802.1q trunking 200
Gi1/0/3 on 802.1q trunking 200
Port Vlans allowed on trunk
Gi1/0/1 1-4094
Gi1/0/3 1-4094
Port Vlans allowed and active in management domain
Gi1/0/1 1,200
Gi1/0/3 1,200
Port Vlans in spanning tree forwarding state and not pruned
Gi1/0/1 1,200
Gi1/0/3 1,200
I am still unable to access the server from default vlan with this.
This is the ping results...
ping 192.168.200.5
Pinging 192.168.200.5 with 32 bytes of data:
Reply from 192.168.10.1: Destination host unreachable.
Reply from 192.168.10.1: Destination host unreachable.
Reply from 192.168.10.1: Destination host unreachable.
Reply from 192.168.10.1: Destination host unreachable.
Ping statistics for 192.168.200.5:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
12-16-2023 04:49 AM - edited 12-16-2023 04:50 AM
Friends changed defualt both trunk native vlan to 1
(200 was typo I correct it)
MHM
12-16-2023 04:53 AM
Changed both native vlans to 1 and still am unable to ping the server.
ping 192.168.200.5
Pinging 192.168.200.5 with 32 bytes of data:
Reply from 192.168.10.1: Destination host unreachable.
Reply from 192.168.10.1: Destination host unreachable.
Reply from 192.168.10.1: Destination host unreachable.
Reply from 192.168.10.1: Destination host unreachable.
Ping statistics for 192.168.200.5:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss)
#show interface trunk
Port Mode Encapsulation Status Native vlan
Gi1/0/1 on 802.1q trunking 1
Gi1/0/3 on 802.1q trunking 1
Port Vlans allowed on trunk
Gi1/0/1 1-4094
Gi1/0/3 1-4094
Port Vlans allowed and active in management domain
Gi1/0/1 1,200
Gi1/0/3 1,200
Port Vlans in spanning tree forwarding state and not pruned
Gi1/0/1 1,200
Gi1/0/3 1,200
Switch#show vlan br
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Gi1/0/2, Gi1/0/4, Gi1/0/5
Gi1/0/6, Gi1/0/7, Gi1/0/8
Gi1/0/9, Gi1/0/10, Gi1/0/11
Gi1/0/12, Gi1/0/13, Gi1/0/14
Gi1/0/15, Gi1/0/16, Gi1/0/17
Gi1/0/18, Gi1/0/19, Gi1/0/20
Gi1/0/21, Gi1/0/22, Gi1/0/23
Gi1/0/24, Gi1/0/25, Gi1/0/26
Gi1/0/27, Gi1/0/28, Gi1/0/29
Gi1/0/30, Gi1/0/31, Gi1/0/32
Gi1/0/33, Gi1/0/34, Gi1/0/35
Gi1/0/36, Gi1/0/37, Gi1/0/38
Gi1/0/39, Gi1/0/40, Gi1/0/41
Gi1/0/42, Gi1/0/43, Gi1/0/44
Gi1/0/45, Gi1/0/46, Gi1/0/47
Gi1/0/48, Gi1/0/49, Gi1/0/50
Gi1/0/51, Gi1/0/52
200 Unifi active
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1004 fddinet-default act/unsup
1005 trnet-default act/unsup
Switch#
12-16-2023 04:59 AM
You try ping server
192.168.200.5 using which IP? Which SVI?
12-16-2023 05:10 AM
This is the IP address I am pinging from. 192.168.10.15
When I set the SVI to 192.168.200.1, I am receiving a duplicate IP address error.
12-16-2023 05:16 AM
Connect PC to any free interface
Config this interfaces with
Interface fx/x
Switchport access vlan 200
No shut
Use IP in PC 192.168.200.100
Try ping now.
Why the previous ping failed, because the there is inter-vlan issues, I think you use different SW for inter-vlan?
MHM
12-16-2023 05:20 AM
Pinging 192.168.200.5 with 32 bytes of data:
Reply from 192.168.200.100: Destination host unreachable.
Reply from 192.168.200.100: Destination host unreachable.
Reply from 192.168.200.100: Destination host unreachable.
Reply from 192.168.200.100: Destination host unreachable.
Ping statistics for 192.168.200.5:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss)
Even pings fail within the same VLAN.
12-16-2023 05:26 AM
this via PC with IP 192.168.200.100 ?
12-16-2023 05:30 AM
12-16-2023 05:21 AM - edited 12-16-2023 05:22 AM
On Unifi router you have an SVI 200 ? From this ip do you succeed to ping your VM ?
12-16-2023 04:28 AM
Hello @Thomassimmons1987
Do you check within Proxmox, that the VMs are configured to use VLAN tagging if required.
Ensure that the VMs have the correct VLAN ID configured in their network settings.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide