i have 2 subnets that i would like to use different ISP connections using a catalyst 3560 running c3560-ipservices-mz.122-25.SEE2.bin. isp1 is a point to point link, and connection to isp2 is through an ASA firewall using vlan 1. i enabled the sdm template and shows that resources have been allocated to PBR. i have the following config
interface FastEthernet0/47
description WiMax link to Utande
no switchport
ip address 192.168.20.254 255.255.255.0
!
interface FastEthernet0/48
description link to isp1
no switchport
ip address 41.218.x.x 255.255.255.252
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface GigabitEthernet0/3
!
interface GigabitEthernet0/4
!
interface Vlan1
ip address 192.168.1.3 255.255.255.0
!
interface Vlan2
ip address 192.168.30.254 255.255.255.0
!
interface Vlan3
description hq vlan interface
ip address 192.168.10.254 255.255.255.0
ip policy route-map isp1
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.1
ip route 192.168.0.0 255.255.255.0 192.168.1.4
ip http server
!
!
access-list 10 permit 192.168.1.0 0.0.0.255
access-list 20 permit 192.168.10.0 0.0.0.255
access-list 30 permit 192.168.30.0 0.0.0.255
route-map isp1 permit 20
match ip address 20
set ip next-hop 41.218.x.x
!
route-map isp2 permit 10
match ip address 10
set ip next-hop 192.168.1.1
!
my problem is that when i apply the policy route-map to vlan3 where my laptop is connected, i loose network access. any assistance would be greatly appreciated.
ronnie