cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
700
Views
0
Helpful
6
Replies

Catalyst 2960 - SFP issue (WS-C2960-24TC-L with GLC-FE-100FX)

thiborba
Level 1
Level 1

Hi Team,

I am trying to connect between 2 switches on Fiber.

Switch 1 - WS-C2960-24TC-L

 

thiborba_2-1674845624883.jpeg

 

Switch 2 - WS-C2955C-12

thiborba_0-1674845492276.png

On 2955 side I have the fiber with MT-RJ Connector and LC connector on 2960 side.

For 2960 side I have two models of SFP (GLC-FE-100FX and GLC-SX-MM), I intend to use the GLC-FE-100FX, but even before connecting the fiber, I'm just installing the SFP, and the port is err disabling.

Can use one of these SFPs to connect these switches?

First, I just want to make SFP works on 2960 side...after connect the Fiber already connected on 2955 side.

 

on 2955 side fiber port config are:

interface FastEthernet0/13
description 100FX
switchport mode access
service-policy input gigcst
storm-control broadcast level 1.00 0.90
storm-control action trap

on 2960 side I put these configurations:

interface GigabitEthernet0/1
description 100FX
switchport mode access
storm-control broadcast level 1.00 0.90
storm-control action trap
service-policy input gigcst

 

Need your input please.

regards

Thiago

6 Replies 6

balaji.bandi
Hall of Fame
Hall of Fame

Looks like a compatible issue with 2955 check the matrix EXCEL attached both.

I believe 2960 should work - can you post the complete log of the message and show interface gig0/1 (output)

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Leo Laohoo
Hall of Fame
Hall of Fame

@thiborba wrote:
I'm just installing the SFP, and the port is err disabling.

When the port goes into error-disable, post the complete output to the command "sh interface status err".

SWITCH_Y3_A#sh interface status err

Port Name Status Reason
Gi0/1 100FX err-disabled gbic-invalid

 

According to compatibility matrix, everything os ok

thiborba_0-1675441807987.png

thiborba_1-1675441881193.jpeg

I have two GLC-SX-MM and two GLC-FE-100FX

I need to communicate with a MT-RJ 100FX port of a cisco 2955 , thought that GLC-FE-100FX could fit. Could I set speed of GLC-SX-MM to 100 FX? 


@thiborba wrote:
Could I set speed of GLC-SX-MM to 100 FX? 

Not possible.  GLC-SX-MM(D) will only operate in 1 Gbps, full duplex (and nothing else).  GLC-FE-100FX can only operate in 100 Mbps, full duplex and nothing else. 

I'll use the GLC-FE-100FX, according to compatibility matrix, everything os ok

thiborba_0-1675631235463.png

 

thiborba_1-1675631235849.jpeg

I made a test using two WS-C2960-24TC-L, each one with a GLC-FE-100FX on SFP port gigabitethernet0/1 

Both were disabling the port until I ran two commands:

no errdisable detect cause gbic-invalid
service unsupported-transceiver

Ports maintain active buth with no link using optical cable LC MM tested on other port with the GLC-SX-MM and linking OK;

What I still don't understand is the fact that GLC-FE-100FX it is in listed the compatibility matrix and when putting disable (gbic-invalid)

Reza Sharifi
Hall of Fame
Hall of Fame

Hi,

On this switch, can you change the speed and duplex to 100Mb and test again?

BTW, if this is a fiber port, the speed can't be changed.

interface GigabitEthernet0/1
description 100FX
switchport mode access
storm-control broadcast level 1.00 0.90
storm-control action trap
service-policy input gigcst

 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card