cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
38333
Views
45
Helpful
21
Replies
Highlighted
Enthusiast

Catalyst 2960S Software Recovery

Thanks Peter.  No, it doesn't fix the problem but it is educational.  I suspected something along those lines.

-Jeff

Highlighted
Collaborator

Catalyst 2960S Software Recovery

Hi,

Nice to see this thread is still generating useful discussions.

One really useful tip about using USB drives in Cisco routers and switches was posted by Brian Hurley in a previous thread which is quoted below:

I have recently came across this issue and I can bet that the main cause of this is the 2960S casing.  It leaves the USB slot slightly deeper than most other Cisco device casings that have USB, which means that the USB flash drive does not get fully inserted with the way most flash drives are manufactured to have protective and/or cosmetic plastic covers around the drives.  In my case I had a flash drive that would not be recognized, except I had previously broken the flash drive so that the internal hard disk and USB could be removed from the outer casing.  Once I did that and tried again it inserted properly and was recognized, so I tried putting the flash drive casing back on while it was still inserted into the 2960S and sure enough it was off my just a few millimeters or less.

So look for smaller skinnier flash drives when using 2960S in order to fully insert them into the USB slot.

I found this advice to be accurate - I tried a Sandisk Cruzer Blade 2GB - see below - which would not work in a 2960S or 2901

http://www.sandisk.co.uk/assets/product/usb-sdcz50-002g.jpg

In contrast the Kingston DataTraveller 8GB drive worked just fine (under IOS - did not try rommon) on a 2901 (have not had the chance to test with a 2960S yet)

http://img.ebyrcdn.net/52145-367431-290.jpg

From the images above the Sandisk plastic casing restricts how far it can be pushed into the USB slot whereas the Kingston has not such limitations.

Another observation of interest is that the Kingston was supplied formatted as FAT32 and the 2901 was able to read and write to it without reformatting.

Cheers

James

Highlighted
Enthusiast

Catalyst 2960S Software Recovery

So a colleague gave me a couple of HP V125W 2GB flash drives and they work fine in the 2960S formatted as FAT.  Both ROMMON and IOS read it.  IOS sees all 2GB not sure about ROMMON.

Switch#dir usbflash0:      

Directory of usbflash0:/

    1  -rw-    19322880  Jul 30 2013 11:27:08 +00:00  c2960s-universalk9-tar.150

-2.SE4.tar

    2  -rw-    14828032  Aug 13 2013 09:06:42 +00:00  c2960s-universalk9-mz.150-

2.SE4.bin

2004582400 bytes total (1970405376 bytes free)

-Jeff

Re: Catalyst 2960S Software Recovery

When using diskpart on Windows 10, you need to change the create partition command to:

create partition primary size=1

where the size is in GB not MB anymore

Highlighted
Beginner

Hi I am a newby here.Could

Hi I am a newby here.

Could you kindly assit with the tftp option. I am familiar with the tftp, but when configuring the IP/Mask/DG as per above instruction, I then connect my laptop via a cat5 cable to the switch as I always would and give my laptop an IP.

Problem is the port lights do not come on when connecting to the switch.

Any additional suggestions?

 

Highlighted
Collaborator

HiHave you connected to the

Hi

Have you connected to the 10/100 Management port or just a normal port?

Highlighted
Beginner

My case is slightly diffirent

My case is slightly diffirent in the sense that I dont have the same model as your description, so I dont have the mgmt port on the back. I have a WS C2960 TC-L. So yes I am connecting to any of the 48 Lan Ports...

Do I follow the same commands? Cant imagine the mgmt command will apply if it doesnt have a mgmt port...

CreatePlease to create content
Content for Community-Ad