04-03-2015 12:56 AM - edited 03-07-2019 11:23 PM
Gentlemen
Good morning and many thanks for your help.
In my lab:
One Cisco Catalyst ws-c3550-48-emi
Version C3550 Software (C3550-IPSERVICES-M), Version 12.2(44)SE6, RELEASE SOFTWARE (fc1)
One PC-Host
One Ip Camera unicast and multicast stream capable
My purpose:
The Pc-Host is the Vlan 2; the IP-Camera in the Vlan 3; and using VLC I want to see the IP-Camera video using a multicast stream.
On the switch:
write erase....starting with a new config
Creating two Vlan:
Interface Vlan2 Host-PC
Ip add 10.0.0.254/24
Interface Vlan3 IP-Camera
Ip add 172.17.14.254/24
Interface fa 0/2
Access vlan 2
Interface fa 0/3
Access vlan 3
Assign to Host Pc IP:
10.0.0.10/24
DG 10.0.0.254
Assign to IP-Camera IP:
172.17.14.205
DG 172.17.14.254
224.16.32.2
Plug the Pc and the TLC in the correct interface fa0/2-3...
Ping OK L3 connection OK
From the PC client using VLC and the correct string I can open the unicast stream of the TLC.
From the PC client using VLC and the correct string I CAN'T open the MULTICAST stream of the TLC.
Try to put Ip-Camera and TLC into the same Vlan (changing IP) OK I can see the multicast stream using the string for the multicast stream.
Putting PC-Host and the TLC in different Vlan I'm not able to see the multicast streem.
I Have try different config
Enabling only
ip multicast routing
ip pim sparse-mode
on the vlan2 & vlan3 interface
But nothing multicast only unicast...
Enabling ip sap listen on the vlan interface but nothing...
Creating loopback0 interface with pim and ip pim rp-address on it....nothing
Enabling ip pim rp-address on the vlan Interface...nothing...
I can always see the multicast only if the source and the destination are into the same Vlan (changing the host IP or TLC IP)
At any config change the switch was restarted !
Config 1
L2 Multicast Ok
L3 Multicast NO
Switch#show running-config
Building configuration...
Current configuration : 4374 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Switch
!
!
no aaa new-model
ip subnet-zero
ip routing
no ip domain-lookup
!
ip multicast-routing
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface FastEthernet0/2
description *** PC-Client-10.0.0.10 ***
switchport access vlan 2
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/3
description *** TLC-172.17.14.205 ***
switchport access vlan 3
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/4
switchport mode dynamic desirable
!
interface FastEthernet0/5
description *** Test4L2Multicast***
switchport access vlan 3
switchport mode access
spanning-tree portfast
!
!
interface Vlan1
no ip address
shutdown
!
interface Vlan2
description *** Gateway-PC ***
ip address 10.0.0.254 255.255.255.0
ip pim sparse-mode
!
interface Vlan3
description *** Gateway-TLC ***
ip address 172.17.14.254 255.255.255.0
ip pim sparse-mode
!
***********************************************************************
Config 2
L2 Multicast Ok
L3 Multicast NO
Switch#show running-config
Building configuration...
Current configuration : 4374 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Switch
!
!
no aaa new-model
ip subnet-zero
ip routing
no ip domain-lookup
!
ip multicast-routing
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface Loopback0
ip address 10.10.10.10 255.255.255.255
ip pim sparse-mode
!
interface FastEthernet0/2
description *** PC-Client-10.0.0.10 ***
switchport access vlan 2
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/3
description *** TLC-172.17.14.205 ***
switchport access vlan 3
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/4
switchport mode dynamic desirable
!
interface FastEthernet0/5
description *** Test4L2Multicast***
switchport access vlan 3
switchport mode access
spanning-tree portfast
!
!
interface Vlan1
no ip address
shutdown
!
interface Vlan2
description *** Gateway-PC ***
ip address 10.0.0.254 255.255.255.0
ip pim sparse-mode
!
interface Vlan3
description *** Gateway-TLC ***
ip address 172.17.14.254 255.255.255.0
ip pim sparse-mode
!
ip classless
ip http server
!
ip pim rp-address 10.10.10.10
!
********************************************************************************
Config 3
L2 Multicast Ok
L3 Multicast NO
Switch#show running-config
Building configuration...
Current configuration : 4374 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Switch
!
!
no aaa new-model
ip subnet-zero
ip routing
no ip domain-lookup
!
ip multicast-routing
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface Loopback0
ip address 10.10.10.10 255.255.255.255
ip pim sparse-mode
ip sap listen
!
interface FastEthernet0/2
description *** PC-Client-10.0.0.10 ***
switchport access vlan 2
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/3
description *** TLC-172.17.14.205 ***
switchport access vlan 3
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/4
switchport mode dynamic desirable
!
interface FastEthernet0/5
description *** Test4L2Multicast***
switchport access vlan 3
switchport mode access
spanning-tree portfast
!
!
interface Vlan1
no ip address
shutdown
!
interface Vlan2
description *** Gateway-PC ***
ip address 10.0.0.254 255.255.255.0
ip pim sparse-mode
ip sap listen
!
interface Vlan3
description *** Gateway-TLC ***
ip address 172.17.14.254 255.255.255.0
ip pim sparse-mode
ip sap listen
!
ip classless
ip http server
!
ip pim rp-address 10.10.10.10
*******************************************************************************
Config 4
L2 Multicast Ok
L3 Multicast NO
Switch#show running-config
Building configuration...
Current configuration : 4374 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Switch
!
!
no aaa new-model
ip subnet-zero
ip routing
no ip domain-lookup
!
ip multicast-routing
ip multicast multipath
ip igmp snooping querier
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface Loopback0
ip address 10.10.10.10 255.255.255.255
ip pim sparse-mode
ip sap listen
!
interface FastEthernet0/2
description *** PC-Client-10.0.0.10 ***
switchport access vlan 2
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/3
description *** TLC-172.17.14.205 ***
switchport access vlan 3
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/4
switchport mode dynamic desirable
!
interface FastEthernet0/5
description *** Test4L2Multicast***
switchport access vlan 3
switchport mode access
spanning-tree portfast
!
!
interface Vlan1
no ip address
shutdown
!
interface Vlan2
description *** Gateway-PC ***
ip address 10.0.0.254 255.255.255.0
ip pim sparse-mode
ip sap listen
!
interface Vlan3
description *** Gateway-TLC ***
ip address 172.17.14.254 255.255.255.0
ip pim sparse-mode
ip sap listen
!
ip classless
ip http server
!
ip pim rp-address 10.0.0.254
!
Solved! Go to Solution.
04-03-2015 05:05 AM
Check the TTL in your packet captures.
I have never come across it but I believe there is a bug in some versions of the VLC GUI where even if you set a higher TTL it still sends it as TTL = 1.
If that's the case you can use VLC from the command line and set the TTL there.
Your TTL needs to be > 1.
Jon
04-03-2015 05:05 AM
Check the TTL in your packet captures.
I have never come across it but I believe there is a bug in some versions of the VLC GUI where even if you set a higher TTL it still sends it as TTL = 1.
If that's the case you can use VLC from the command line and set the TTL there.
Your TTL needs to be > 1.
Jon
04-07-2015 08:08 AM
Thank you very much Jon Marshall.
The problem was the TTL!
Not in the VLC setting but in the IP-Camera !
After checking the TTL of the Ip Camera I have notice that it doesn't change.
Changing the TTL value from web menù of the IP-Camera it doesn't change in the packet capture still remain at "1"; it is a firmware bug.
Updating the IP-Camera firmware I can change the TTL with a higher than 1 value and it solved the problem.
If someone use VLC to stream a video into multicast will have the same problem.
Must change the TTL setting adding ",TTL=xx" before the last } via command line.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide