cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1371
Views
0
Helpful
17
Replies
bigred1022
Beginner

Catalyst 4506 image file error

Good Morning, I'm hoping someone can help me with this issue I'm having.  I have been trying to boot my switch using the .bin file shown in the picture below.  But as you can see, it starts to load and then throws up the following error.  I have another .bin file that is older but boots fine when selected.  Am I missing a step?  I go into global config, type the following command: #boot system flash:cat4500-ipbasek9-mz.122-54.SG1.bin and hit Enter.  Then I reboot the switch using the reload command.  Thanks in advance-

 

Bootflash Error.jpg

1 ACCEPTED SOLUTION

Accepted Solutions
Leo Laohoo
VIP Community Legend

Ok, as I suspected.  The current system is running ROMmon version 12.2(31r)SG2.  According to Release Notes (Table 8), the minimum recommended ROMmon version is 12.2(31r)SGA4.  

ROMmon version 12.2(31r)SGA4 can be found HERE

Release Notes can be found HERE.

Instruction(s) on how to upgrade the ROMmon can be found HERE.

Hope this helps.

View solution in original post

17 REPLIES 17
Mark Malone
Mentor

hi

if the other image is working sounds as if switch is ok , my next step would be verify the image you loaded up did not get corrupted by checking its MD5 and matching it against where it was downloaded on Cisco website  ,if it got corrupted it wont boot right. Or download fresh copy and try again

 

Out of interest what's the image name that's working fine

 

https://www.cisco.com/c/en/us/about/security-center/ios-image-verification.html

and

http://www.winmd5.com/

that image is nearly 7 years old to might want to pick something newer , the alert looks to be some underlying Linux alert when I check it online

Thanks for the reply Mark,

 

The MD5 check came back with a good match.  I just downloaded the image file fresh yesterday from Cisco to replace what we thought was a corrupt version already.  The image file that does boot is:

 cat4500-ipbase-mz.122-31.SGA9.bin

 

I know these are very old images but the hardware itself is old as well.

I just downloaded the latest compatible version from the Cisco site.  I have transferred it to the bootflash: of the switch.  Unfortunately I won't be able to test this out until 4pm EST today.  I appreciate your help though.  I will update this afternoon.

Ok that's good the MD5 matches but then you may have a bigger issue if the Linux section is throwing alerts and failing somehow to load any new images , it could be something more sinister , honestly I'm not sure on next steps for that , if it was me I would TAC it but that may be out of support as its old hardware

Yes reply back what exactly you see the whole boot process if you have it when doing the latest image, other users may be able to identify the problem if they have seen it before , more info better chance of fixing it

Tried booting the latest image and although it added a line of text about completing decompression, the same error happened.  Screenshot below.  

Cisco 15 error.png

Leo Laohoo
VIP Community Legend

What is the Supervisor card? 

What other line cards do you have in your chassis which require this specific train?

If the supervisor card is booting into ROMmon, post the complete value to the command "dir bootflash:"  I want to see what other file(s) are in the bootflash:. 

 

Hey Leo,

The supervisor card is V.  When I reload the switch it tries the newest image that I uploaded today.  When it falls I cancel the autoboot which does take me to ROMmon where I just type boot to get the older image up and running as quickly as possible to prevent downtime.  I can't post an image of the for bootflash but the only 2 are the one in my latest attachment and the really old one I mentioned earlier in this post.  The boot variable only contains the new image file.  As for the line cards, we have 1 card that is not used at all cause the ports are just 100mb ports. 3 others (all 48 port) are gig ports.  And 1 final one that is for fiber connections.  I'm sorry I'm not at work nor near a computer to check further currently.  But I appreciate the help.

Leo Laohoo
VIP Community Legend