cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
696
Views
0
Helpful
5
Replies

Changing a port from a vlan to another

waguilar71
Level 1
Level 1

Hi everyone,

I have a 3560 switch with the following ports config

interface FastEthernet0/43
description : Link to PC + ShoreTel IP Phone
switchport access vlan 120
switchport trunk encapsulation dot1q
switchport trunk native vlan 120
switchport mode access
service-policy input VOICE

interface FastEthernet0/25
description : Link to PC + ShoreTel IP Phone
switchport trunk encapsulation dot1q
switchport mode trunk
service-policy input VOICE

interface FastEthernet0/28
description : Link to PC + ShoreTel IP Phone
switchport trunk encapsulation dot1q
switchport mode access
service-policy input VOICE

interface FastEthernet0/46
description : Link to PC + ShoreTel IP Phone
switchport trunk encapsulation dot1q
switchport mode trunk
service-policy input VOICE

I would like to use theses ports on a different vlan to connect 4 pc's to them. Can I just remove them from the vlan, remove the trunk switchport and set up on the vlan i want them on with no trunking?

Thanks

Wilfredo

2 Accepted Solutions

Accepted Solutions

glen.grant
VIP Alumni
VIP Alumni

  Quick answer is yes.  Just do the following for each port

conf t

default interface Fx/x

interf fx/x

switchport

switchport access vlan X

switchport host

View solution in original post

burleyman
Level 8
Level 8

Here is how I do it when I re-provision ports

This part sets the interfaces to default config.

config t

default int fa0/43

default int fa0/25

default int fa0/28

default int fa0/46

Now you can configure the ports

interface faX/X  <---- substitute the X/X with the port number

description PC

switchport

switchport mode access

switchport access vlan XXX  <------ substitute the XXX with the Vlan you want to assign

spanning-tree portfast

no shut

then save the configuration by issuing the command     write mem

Hope this helps.

Mike

View solution in original post

5 Replies 5

glen.grant
VIP Alumni
VIP Alumni

  Quick answer is yes.  Just do the following for each port

conf t

default interface Fx/x

interf fx/x

switchport

switchport access vlan X

switchport host

Thanks for your reply Grant, what do you mean by default interface

Default interface fx/x will set that port back to factory defaults without having to do a "no" command for each line in the port config.

burleyman
Level 8
Level 8

Here is how I do it when I re-provision ports

This part sets the interfaces to default config.

config t

default int fa0/43

default int fa0/25

default int fa0/28

default int fa0/46

Now you can configure the ports

interface faX/X  <---- substitute the X/X with the port number

description PC

switchport

switchport mode access

switchport access vlan XXX  <------ substitute the XXX with the Vlan you want to assign

spanning-tree portfast

no shut

then save the configuration by issuing the command     write mem

Hope this helps.

Mike

waguilar71
Level 1
Level 1

Thanks guys,

The instructions worked that both of you provided. One more detailed than the other but they worked. I did use the command

spanning-tree host and it setup the port at portfast by default. I will be making the connections tonight of the pc's and all should be well.

Wilfredo

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: