cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

Cisco 1941 Auto Failover with load balancing

Hello,

One of our customer has  3 ISP Line, out of which Two are Broadband and One is Leased Line.   All 3 ISP interfaces are Etherent.

Now, they want Auto Failover with Load balancing among these 3 ISP lines.

Can we do same implementation in Cisco 1941 Router??  What licenses required in router for same?

Is there any other option?

Thanks

Sandeep

1 REPLY 1

Abzal
Rising star
Rising star

Hi,

1. You need to create ACL that will match internal LAN subnet.

2. Configure 3 default static route pointing ISPs IP address.

3. Create route-maps that will match ACL above.

And Cisco CEF will take care of load-balancinf between these links.

example:

ip cef

interface FastEthernet0/0

Description Primary link ISP1

ip address 12.x.x.x 255.255.255.240

ip nat outside

interface FastEthernet1/0

Description Secondary link ISP2

ip address 76.x.x.x. 255.255.255.252

ip nat outside

interface FastEthernet0/1

Description link ISP3

ip address 96.x.x.x. 255.255.255.252

ip nat outside

interface FastEthernet1/1

Description Inside LAN segment

ip address 172.16.20.1 255.255.255.0

ip nat inside

access-list 100 permit ip 172.16.20.0 0.0.0.255 any

route-map isp1 permit 10

match ip address 100

match interface FastEthernet0/0

route-map isp2 permit 10

match ip address 100

match interface FastEthernet1/0

route-map isp3 permit 10

match ip address 100

match interface FastEthernet0/1

ip nat inside source route-map isp1 interface FastEthernet0/0 overload

ip nat inside source route-map isp2 interface FastEthernet1/0 overload

ip nat inside source route-map isp3 interface FastEthernet0/1 overload

ip route 0.0.0.0 0.0.0.0 12.y.y.y track 1

ip route 0.0.0.0 0.0.0.0 76.y.y.y track 2

ip route 0.0.0.0 0.0.0.0 96.y.y.y track 3

Also you could add IP SLA to monitor those links. In case of failure one of the links it will be removed from routing table.

ip sla 1

icmp-echo 4.4.4.4 source-interface FastEthernet0/0

timeout 1000

ip sla schedule 1 life forever start-time now

ip sla 2

icmp-echo 4.4.4.4 source-interface FastEthernet1/0

timeout 1000

ip sla schedule 2 life forever start-time now

ip sla 3

icmp-echo 4.4.4.4 source-interface FastEthernet0/1

timeout 1000

ip sla schedule 3 life forever start-time now

track 1 ip sla 1 reachability

track 2 ip sla 2 reachability

track 3 ip sla 3 reachability

http://www.firewall.cx/cisco-technical-knowledgebase/cisco-routers/813-cisco-router-ipsla-basic.html

Hope it will help.

Best regards,
Abzal

Best regards,
Abzal
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: