Cisco 2800 Router Physical and sub interface

- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
10-26-2012 06:00 AM - edited 03-07-2019 09:41 AM
Hello All,
I have a pair of router Cisco 2800 running in HSRP, now I want to configure one sub interface with another subnet, Will my current IP on physical interface work or do I need to create two Sub interfaces for each network. Do i must need encapsulation on sub interface
Cureent Config:-
Router 1:-
interface FastEthernet0/1
description Connect to LAN_SW1 Gi1/0/1
ip address 192.168.1.13 255.255.255.0
no ip redirects
duplex auto
speed auto
standby 1 ip 192.168.1.1
standby 1 priority 90
standby 1 preempt
Router 2:-
interface FastEthernet0/1
description Connect to LAN_SW2 Gi1/0/1
ip address 192.168.1.3 255.255.255.0
no ip redirects
duplex auto
speed auto
standby 1 ip 192.168.1.1
standby 1 priority 110
standby 1 preempt
____________________________
For second network I do not require HSRP
Router 1:-
interface FastEthernet0/0
description Connect to LAN_SW1 Gi1/0/1
no ip address
duplex full
speed 100
interface FastEthernet0/0.100
description **VLAN1**
encapsulation dot1Q 100
ip address 192.168.1.13 255.255.255.0
no ip redirects
standby 1 ip 192.168.1.1
standby 1 priority 90
standby 1 preempt
!
interface FastEthernet0/0.200
description **VLAN2**
encapsulation dot1Q 200
ip address 172.16.1.13 255.255.255.0
no ip redirects
Router 2:-
interface FastEthernet0/0
description Connect to LAN_SW2 Gi1/0/1
no ip address
duplex full
speed 100
interface FastEthernet0/0.100
description **VLAN1**
encapsulation dot1Q 100
ip address 192.168.1.3 255.255.255.0
no ip redirects
standby 1 ip 192.168.1.1
standby 1 priority 90
standby 1 preempt
!
interface FastEthernet0/0.200
description **VLAN2**
encapsulation dot1Q 200
ip address 172.16.1.3 255.255.255.0
no ip redirects
- Labels:
-
Other Switching

- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
10-26-2012 06:09 AM
Creating Sub-Interfaces will be the correct way to go here also make sure you create you VLANs on the switch and tag the appropriate ports, You will also want delay the preempt on the master for the best results. Might also want to look into tuning the HSRP timers for optimal failover times.
http://ccie-or-null.net/2012/05/24/lets-configure-hsrp-hot-standby-routing-protocol/
--
CCNP, CCIP, CCDP, CCNA: Security/Wireless
Blog: http://ccie-or-null.net/
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
10-26-2012 06:17 AM
Can't i go like below config:-
Router 1:-
interface FastEthernet0/1
description Connect to LAN_SW1 Gi1/0/1
ip address 192.168.1.13 255.255.255.0
no ip redirects
duplex auto
speed auto
standby 1 ip 192.168.1.1
standby 1 priority 90
standby 1 preempt
interface FastEthernet0/0.200
description **VLAN2**
ip address 172.16.1.13 255.255.255.0
no ip redirects
Router 2:-
interface FastEthernet0/1
description Connect to LAN_SW2 Gi1/0/1
ip address 192.168.1.3 255.255.255.0
no ip redirects
duplex auto
speed auto
standby 1 ip 192.168.1.1
standby 1 priority 110
standby 1 preempt
interface FastEthernet0/0.200
description **VLAN2**
ip address 172.16.1.3 255.255.255.0
no ip redirects
Thanks
Jagdev
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
10-26-2012 06:49 AM
You could, but you can also improve that deisgn, by tuning timers and delaying the preempt action.
--
CCNP, CCIP, CCDP, CCNA: Security/Wireless
Blog: http://ccie-or-null.net/
