cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
5321
Views
10
Helpful
4
Replies
Highlighted
Beginner

Cisco 3560 with Ubiquiti Router setup

 I have setup an Ubiquiti USG with 3 networks. Lan 1 (untagged) is 192.168.1.0/24. vlan 10 is 172.16.0.0/24, and vlan 50 is 192.168.0.0/24. I am trying to put a raspberry pi 3 with a static on the "lan" network so it is on same network as the router. Coming out of interface lan port 1 from the USG router is connected to port fa0/2 on the Cisco switch. I have set port fa0/1 as unconfigured and plugged the raspberry pi 3 with static IP 192.168.1.2 but it is unable to connect to the network. If I unplug it from fa0/1 set the pi to DHCP on port fa0/3 I get an IP from vlan 10 and can get a route to the USG router IP of 192.168.1.1. The goal is to use the LAN network as a management network and want to set a management IP for the switch itself on to the management LAN.

Why can't I get connectivity to the router if setting the static IP to the LAN network. Attached is the switch config

3 ACCEPTED SOLUTIONS

Accepted Solutions
Highlighted
Rising star

It looks like you don't have VLAN 1 enabled on Fa0/2. If you don't allow the VLAN onto the trunk, only control traffic will be permitted, which will block your Pi from reaching the Ubiquiti.

Try this: 

interface fa0/2
 switchport trunk allowed vlan 1,10,50

View solution in original post

Highlighted

Did that fix things up for you? If so, please accept the configuration change as a solution so it shows up for anyone else who might be looking. If not, let me know what results you're getting now and we'll look into it further.

View solution in original post

Highlighted

Yes sir!! It did fix it. On switch 1. I integrated your recommendation and updated my config as shown:

 

interface FastEthernet0/1
description Device on Management
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/2
description Connection to Router
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,10,50
switchport mode trunk

View solution in original post

4 REPLIES 4
Highlighted
Rising star

It looks like you don't have VLAN 1 enabled on Fa0/2. If you don't allow the VLAN onto the trunk, only control traffic will be permitted, which will block your Pi from reaching the Ubiquiti.

Try this: 

interface fa0/2
 switchport trunk allowed vlan 1,10,50

View solution in original post

Highlighted

Did that fix things up for you? If so, please accept the configuration change as a solution so it shows up for anyone else who might be looking. If not, let me know what results you're getting now and we'll look into it further.

View solution in original post

Highlighted

I have not had a chance to test it but I believe you are spot on.

Thank you for the quick reply. I will test this out as soon as I get back and in front of that switch.

Highlighted

Yes sir!! It did fix it. On switch 1. I integrated your recommendation and updated my config as shown:

 

interface FastEthernet0/1
description Device on Management
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/2
description Connection to Router
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,10,50
switchport mode trunk

View solution in original post

Content for Community-Ad