cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
718
Views
5
Helpful
3
Replies

Cisco 3750 MSTP configuration

AndreK
Beginner
Beginner

Hi, guys. I can not understand. On the Level 2 switch, for instance 0 root is indicated correctly, but for the rest instances the Level 2 switch points to itself.

 

Why is that? Is this correct?

 

My configuration

Cisco WS-C3750X-48P iOS 12.2(55)SE13

switch Level 1

 

spanning-tree mode mst
spanning-tree logging
spanning-tree extend system-id
spanning-tree pathcost method long
!
spanning-tree mst configuration
 name MSTP-R01
 revision 1
 instance 1 vlan 700
 instance 2 vlan 101, 1210, 1220-1223, 1230, 1240, 1250
 instance 3 vlan 1300, 1310, 1320, 1330, 1399
 instance 4 vlan 100
 instance 5 vlan 1010, 1030, 1040
 instance 6 vlan 2020
 instance 7 vlan 500
 instance 8 vlan 600
 instance 9 vlan 1110, 1120
 instance 10 vlan 10, 310, 320, 330, 340
!
spanning-tree mst 0-10 priority 28672

Cisco  WS-C3750-48P 12.2(55)SE10

Level 2

spanning-tree mode mst
spanning-tree logging
spanning-tree extend system-id
spanning-tree pathcost method long
!
spanning-tree mst configuration
 name MSTP-R01
 revision 1
 instance 1 vlan 700
 instance 2 vlan 101, 1210, 1220-1223, 1230, 1240, 1250
 instance 3 vlan 1300, 1310, 1320, 1330
 instance 4 vlan 100
 instance 5 vlan 1010, 1030, 1040
 instance 6 vlan 2020
 instance 7 vlan 500
 instance 8 vlan 600
 instance 9 vlan 1110, 1120
 instance 10 vlan 10, 310, 320, 330, 340
!
spanning-tree mst 0-10 priority 61440

Level 2 show spanning-tree

sw-kv-net-as43#sho spanning-tree mst 0

##### MST0    vlans mapped:   1-9,11-99,102-309,311-319,321-329,331-339
                               341-499,501-599,601-699,701-1009,1011-1029
                               1031-1039,1041-1109,1111-1119,1121-1209
                               1211-1219,1224-1229,1231-1239,1241-1249
                               1251-1299,1301-1309,1311-1319,1321-1329
                               1331-2019,2021-4094
Bridge        address 0015.c6dc.cc80  priority      61440 (61440 sysid 0)
Root          address 44d3.ca5b.e600  priority      28672 (28672 sysid 0)
              port    Gi1/0/1         path cost     20000
Regional Root this switch
Operational   hello time 2 , forward delay 15, max age 20, txholdcount 6
Configured    hello time 2 , forward delay 15, max age 20, max hops    20

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi1/0/1          Root FWD 20000     128.1    P2p Bound(RSTP)
Gi1/0/3          Desg FWD 20000     128.27   P2p
Fa1/0/43         Desg FWD 200000    128.47   P2p Edge
Fa1/0/44         Desg FWD 200000    128.48   P2p Edge
Fa1/0/45         Desg FWD 200000    128.49   P2p Edge
Fa1/0/46         Desg FWD 200000    128.50   P2p Edge
Fa1/0/47         Desg FWD 200000    128.51   P2p Edge
Fa1/0/48         Desg FWD 200000    128.52   P2p Edge

sw-kv-net-as43#sho spanning-tree mst 1

##### MST1    vlans mapped:   700
Bridge        address 0015.c6dc.cc80  priority      61441 (61440 sysid 1)
Root          this switch for MST1

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi1/0/1          Mstr FWD 20000     128.1    P2p Bound(RSTP)

sw-kv-net-as43#sho spanning-tree mst 2

##### MST2    vlans mapped:   101,1210,1220-1223,1230,1240,1250
Bridge        address 0015.c6dc.cc80  priority      61442 (61440 sysid 2)
Root          this switch for MST2

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi1/0/1          Mstr FWD 20000     128.1    P2p Bound(RSTP)
3 Replies 3

balaji.bandi
VIP Community Legend VIP Community Legend
VIP Community Legend

If you looking at VLAN 700, they are not allowed in the port-channel so they become locally root bridge?

 

is this what you looking for, sorry if i miss understood your question here?

 

also, post Level 1 spanning-tree output to understand better

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Sorry for my english.  Why are 1, 2, 3 instances has different root at Level 2 switch?

 

Level 1 sho spanning-tree mst 0,1,2 

sw-kv04-net-cr03#
sw-kv04-net-cr03#terminal length 0
sw-kv04-net-cr03#terminal width 132
sw-kv04-net-cr03#sho spanning-tree mst 0,1,2

##### MST0    vlans mapped:   1-9,11-99,102-309,311-319,321-329,331-339
                               341-499,501-599,601-699,701-1009,1011-1029
                               1031-1039,1041-1109,1111-1119,1121-1209
                               1211-1219,1224-1229,1231-1239,1241-1249
                               1251-1299,1301-1309,1311-1319,1321-1329
                               1331-1398,1400-2019,2021-4094
Bridge        address 44d3.ca5b.e600  priority      28672 (28672 sysid 0)
Root          this switch for the CIST
Operational   hello time 2 , forward delay 15, max age 20, txholdcount 6 
Configured    hello time 2 , forward delay 15, max age 20, max hops    20

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi1/0/1          Desg FWD 20000     128.1    P2p 
Gi1/0/2          Desg FWD 20000     128.2    P2p Pre-STD 
Gi1/0/3          Desg FWD 20000     128.3    P2p Pre-STD 
Gi1/0/4          Desg FWD 20000     128.4    P2p Pre-STD 
Gi1/0/5          Desg FWD 20000     128.5    P2p Pre-STD 
Gi1/0/6          Desg FWD 20000     128.6    P2p Pre-STD 
Gi1/0/7          Desg FWD 20000     128.7    P2p Pre-STD 
Gi1/0/8          Desg FWD 20000     128.8    P2p Pre-STD 
Gi1/0/9          Desg FWD 20000     128.9    P2p Pre-STD 
Gi1/0/13         Desg FWD 20000     128.13   P2p Pre-STD 
Gi1/0/14         Desg FWD 20000     128.14   P2p Pre-STD 
Gi1/0/15         Desg FWD 20000     128.15   P2p Pre-STD 
Gi1/0/16         Desg FWD 20000     128.16   P2p Pre-STD 
Gi1/0/17         Desg FWD 20000     128.17   P2p Pre-STD 
Gi1/0/18         Desg FWD 20000     128.18   P2p Pre-STD 
Gi1/0/19         Desg FWD 20000     128.19   P2p Pre-STD 
Gi1/0/20         Desg FWD 20000     128.20   P2p Pre-STD 
Gi1/0/21         Desg FWD 20000     128.21   P2p Pre-STD 
Gi1/0/22         Desg FWD 20000     128.22   P2p Pre-STD 
Gi1/0/23         Desg FWD 20000     128.23   P2p Pre-STD 
Gi1/0/29         Desg FWD 20000     128.29   P2p Pre-STD 
Gi1/0/32         Desg FWD 20000     128.32   P2p Pre-STD-Cf 
Gi1/0/33         Desg FWD 20000     128.33   P2p Edge Pre-STD-Cf 
Gi1/0/36         Desg FWD 20000     128.36   P2p 
Gi1/0/38         Desg FWD 20000     128.38   P2p Pre-STD-Cf 
Gi1/0/42         Desg FWD 20000     128.42   P2p Pre-STD-Cf 
Te1/1/1          Desg FWD 2000      128.53   P2p 
Gi2/0/1          Desg FWD 20000     128.55   P2p 
Gi2/0/2          Desg FWD 20000     128.56   P2p Pre-STD 
Gi2/0/3          Desg FWD 20000     128.57   P2p Pre-STD 
Gi2/0/4          Desg FWD 20000     128.58   P2p Pre-STD 
Gi2/0/5          Desg FWD 20000     128.59   P2p Pre-STD 
Gi2/0/6          Desg FWD 20000     128.60   P2p Pre-STD 
Gi2/0/7          Desg FWD 20000     128.61   P2p Pre-STD 
Gi2/0/8          Desg FWD 20000     128.62   P2p Pre-STD 
Gi2/0/9          Desg FWD 20000     128.63   P2p Pre-STD 
Gi2/0/13         Desg FWD 20000     128.67   P2p Pre-STD 
Gi2/0/14         Desg FWD 20000     128.68   P2p Pre-STD 
Gi2/0/15         Desg FWD 20000     128.69   P2p Pre-STD 
Gi2/0/16         Desg FWD 20000     128.70   P2p Pre-STD 
Gi2/0/18         Desg FWD 20000     128.72   P2p Pre-STD 
Gi2/0/19         Desg FWD 20000     128.73   P2p Pre-STD 
Gi2/0/20         Desg FWD 20000     128.74   P2p Pre-STD 
Gi2/0/21         Desg FWD 20000     128.75   P2p Pre-STD 
Gi2/0/22         Desg FWD 20000     128.76   P2p Pre-STD 
Gi2/0/23         Desg FWD 20000     128.77   P2p Pre-STD 
Gi2/0/24         Desg FWD 20000     128.78   P2p Pre-STD 
Gi2/0/25         Desg FWD 20000     128.79   P2p Pre-STD 
Gi2/0/31         Desg FWD 200000    128.85   P2p Pre-STD-Cf 
Gi2/0/39         Desg FWD 200000    128.93   P2p Pre-STD-Cf 
Gi2/1/1          Desg FWD 20000     128.103  P2p 

##### MST1    vlans mapped:   700
Bridge        address 44d3.ca5b.e600  priority      24577 (24576 sysid 1)
Root          this switch for MST1

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi1/0/1          Desg FWD 20000     128.1    P2p 
Gi1/0/2          Desg FWD 20000     128.2    P2p Pre-STD 
Gi1/0/3          Desg FWD 20000     128.3    P2p Pre-STD 
Gi1/0/4          Desg FWD 20000     128.4    P2p Pre-STD 
Gi1/0/5          Desg FWD 20000     128.5    P2p Pre-STD 
Gi1/0/6          Desg FWD 20000     128.6    P2p Pre-STD 
Gi1/0/7          Desg FWD 20000     128.7    P2p Pre-STD 
Gi1/0/8          Desg FWD 20000     128.8    P2p Pre-STD 
Gi1/0/9          Desg FWD 20000     128.9    P2p Pre-STD 
Gi1/0/13         Desg FWD 20000     128.13   P2p Pre-STD 
Gi1/0/14         Desg FWD 20000     128.14   P2p Pre-STD 
Gi1/0/15         Desg FWD 20000     128.15   P2p Pre-STD 
Gi1/0/16         Desg FWD 20000     128.16   P2p Pre-STD 
Gi1/0/17         Desg FWD 20000     128.17   P2p Pre-STD 
Gi1/0/18         Desg FWD 20000     128.18   P2p Pre-STD 
Gi1/0/19         Desg FWD 20000     128.19   P2p Pre-STD 
Gi1/0/20         Desg FWD 20000     128.20   P2p Pre-STD 
Gi1/0/21         Desg FWD 20000     128.21   P2p Pre-STD 
Gi1/0/22         Desg FWD 20000     128.22   P2p Pre-STD 
Gi1/0/23         Desg FWD 20000     128.23   P2p Pre-STD 
Gi1/0/29         Desg FWD 20000     128.29   P2p Pre-STD 
Gi1/0/32         Desg FWD 20000     128.32   P2p Pre-STD-Cf 
Gi1/0/33         Desg FWD 20000     128.33   P2p Edge Pre-STD-Cf 
Gi1/0/36         Desg FWD 20000     128.36   P2p 
Gi1/0/38         Desg FWD 20000     128.38   P2p Pre-STD-Cf 
Te1/1/1          Desg FWD 2000      128.53   P2p 
Gi2/0/1          Desg FWD 20000     128.55   P2p 
Gi2/0/2          Desg FWD 20000     128.56   P2p Pre-STD 
Gi2/0/3          Desg FWD 20000     128.57   P2p Pre-STD 
Gi2/0/4          Desg FWD 20000     128.58   P2p Pre-STD 
Gi2/0/5          Desg FWD 20000     128.59   P2p Pre-STD 
Gi2/0/6          Desg FWD 20000     128.60   P2p Pre-STD 
Gi2/0/7          Desg FWD 20000     128.61   P2p Pre-STD 
Gi2/0/8          Desg FWD 20000     128.62   P2p Pre-STD 
Gi2/0/9          Desg FWD 20000     128.63   P2p Pre-STD 
Gi2/0/13         Desg FWD 20000     128.67   P2p Pre-STD 
Gi2/0/14         Desg FWD 20000     128.68   P2p Pre-STD 
Gi2/0/15         Desg FWD 20000     128.69   P2p Pre-STD 
Gi2/0/16         Desg FWD 20000     128.70   P2p Pre-STD 
Gi2/0/18         Desg FWD 20000     128.72   P2p Pre-STD 
Gi2/0/19         Desg FWD 20000     128.73   P2p Pre-STD 
Gi2/0/20         Desg FWD 20000     128.74   P2p Pre-STD 
Gi2/0/21         Desg FWD 20000     128.75   P2p Pre-STD 
Gi2/0/22         Desg FWD 20000     128.76   P2p Pre-STD 
Gi2/0/23         Desg FWD 20000     128.77   P2p Pre-STD 
Gi2/0/24         Desg FWD 20000     128.78   P2p Pre-STD 
Gi2/0/25         Desg FWD 20000     128.79   P2p Pre-STD 
Gi2/0/31         Desg FWD 200000    128.85   P2p Pre-STD-Cf 
Gi2/1/1          Desg FWD 20000     128.103  P2p 

##### MST2    vlans mapped:   101,1210,1220-1223,1230,1240,1250
Bridge        address 44d3.ca5b.e600  priority      28674 (28672 sysid 2)
Root          this switch for MST2

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi1/0/1          Desg FWD 20000     128.1    P2p 
Gi1/0/2          Desg FWD 20000     128.2    P2p Pre-STD 
Gi1/0/3          Desg FWD 20000     128.3    P2p Pre-STD 
Gi1/0/4          Desg FWD 20000     128.4    P2p Pre-STD 
Gi1/0/5          Desg FWD 20000     128.5    P2p Pre-STD 
Gi1/0/6          Desg FWD 20000     128.6    P2p Pre-STD 
Gi1/0/7          Desg FWD 20000     128.7    P2p Pre-STD 
Gi1/0/8          Desg FWD 20000     128.8    P2p Pre-STD 
Gi1/0/9          Desg FWD 20000     128.9    P2p Pre-STD 
Gi1/0/13         Desg FWD 20000     128.13   P2p Pre-STD 
Gi1/0/14         Desg FWD 20000     128.14   P2p Pre-STD 
Gi1/0/15         Desg FWD 20000     128.15   P2p Pre-STD 
Gi1/0/16         Desg FWD 20000     128.16   P2p Pre-STD 
Gi1/0/17         Desg FWD 20000     128.17   P2p Pre-STD 
Gi1/0/18         Desg FWD 20000     128.18   P2p Pre-STD 
Gi1/0/19         Desg FWD 20000     128.19   P2p Pre-STD 
Gi1/0/20         Desg FWD 20000     128.20   P2p Pre-STD 
Gi1/0/21         Desg FWD 20000     128.21   P2p Pre-STD 
Gi1/0/22         Desg FWD 20000     128.22   P2p Pre-STD 
Gi1/0/23         Desg FWD 20000     128.23   P2p Pre-STD 
Gi1/0/29         Desg FWD 20000     128.29   P2p Pre-STD 
Gi1/0/32         Desg FWD 20000     128.32   P2p Pre-STD-Cf 
Gi1/0/36         Desg FWD 20000     128.36   P2p 
Gi1/0/38         Desg FWD 20000     128.38   P2p Pre-STD-Cf 
Gi1/0/42         Desg FWD 20000     128.42   P2p Pre-STD-Cf 
Te1/1/1          Desg FWD 2000      128.53   P2p 
Gi2/0/1          Desg FWD 20000     128.55   P2p 
Gi2/0/2          Desg FWD 20000     128.56   P2p Pre-STD 
Gi2/0/3          Desg FWD 20000     128.57   P2p Pre-STD 
Gi2/0/4          Desg FWD 20000     128.58   P2p Pre-STD 
Gi2/0/5          Desg FWD 20000     128.59   P2p Pre-STD 
Gi2/0/6          Desg FWD 20000     128.60   P2p Pre-STD 
Gi2/0/7          Desg FWD 20000     128.61   P2p Pre-STD 
Gi2/0/8          Desg FWD 20000     128.62   P2p Pre-STD 
Gi2/0/9          Desg FWD 20000     128.63   P2p Pre-STD 
Gi2/0/13         Desg FWD 20000     128.67   P2p Pre-STD 
Gi2/0/14         Desg FWD 20000     128.68   P2p Pre-STD 
Gi2/0/15         Desg FWD 20000     128.69   P2p Pre-STD 
Gi2/0/16         Desg FWD 20000     128.70   P2p Pre-STD 
Gi2/0/18         Desg FWD 20000     128.72   P2p Pre-STD 
Gi2/0/19         Desg FWD 20000     128.73   P2p Pre-STD 
Gi2/0/20         Desg FWD 20000     128.74   P2p Pre-STD 
Gi2/0/21         Desg FWD 20000     128.75   P2p Pre-STD 
Gi2/0/22         Desg FWD 20000     128.76   P2p Pre-STD 
Gi2/0/23         Desg FWD 20000     128.77   P2p Pre-STD 
Gi2/0/24         Desg FWD 20000     128.78   P2p Pre-STD 
Gi2/0/25         Desg FWD 20000     128.79   P2p Pre-STD 
Gi2/0/31         Desg FWD 200000    128.85   P2p Pre-STD-Cf 
Gi2/1/1          Desg FWD 20000     128.103  P2p 


 

Port configuration between switches.

Level 1

interface GigabitEthernet2/1/1
 description UP-F
 switchport trunk encapsulation dot1q
 switchport mode trunk
 storm-control broadcast level bps 10m
 storm-control multicast level bps 10m
 spanning-tree guard root
end

Level 2

interface GigabitEthernet1/0/1
 description KV04
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1-199,201-4094
 switchport mode trunk
 switchport nonegotiate
 ip dhcp snooping trust
end
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers