cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

68798
Views
0
Helpful
13
Replies
Highlighted

Cisco 3750 suspended interface when configuring LACP

I am attempting to configure two ports for LACP and I am only seeing one interface as member under the PortChannel that I created.

I am also seeing a Suspended interface on one of the ports.

This is my configuration

interface Port-channel12
description SERVER Gi1/0/12_Gi2/0/12

switchport access vlan 45


interface GigabitEthernet1/0/12
switchport access vlan 45
channel-group 12 mode active
spanning-tree portfast
spanning-tree bpdufilter enable


interface GigabitEthernet2/0/12
switchport access vlan 45
channel-group 12 mode active
spanning-tree portfast
spanning-tree bpdufilter enable

13 REPLIES 13
VIP Expert

Re: Cisco 3750 suspended interface when configuring LACP

Maria,

Are the NICs on the server up and have you configured the servers with LACP?

Are the ports on the switch in up and up mode? If yes to all then:

do a "shut" on both physical interfaces and on the port-channel. Then bring the port-channel back up (no sh) and test again.

HTH

Reza

Re: Cisco 3750 suspended interface when configuring LACP

Yes the servers are configured LACP

I did a "shut" & "no shut" on both interface.

I added Interface Protocol first and then configured the interface after with Channel-group # mode "active"

It's still only seeing one member out of two.

Re: Cisco 3750 suspended interface when configuring LACP

This is what I am getting

Port-channel12 is up, line protocol is up (connected)
  Hardware is EtherChannel, address is 0024.13c4.248c (bia 0024.13c4.248c)
  Description:

  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 0/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 1000Mb/s, link type is auto, media type is unknown
  input flow-control is off, output flow-control is unsupported
  Members in this channel: Gi1/0/12
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output 00:00:01, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/0 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     903 packets input, 117234 bytes, 0 no buffer
     Received 6134 broadcasts (902 multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 902 multicast, 0 pause input
     0 input packets with dribble condition detected
     30553 packets output, 3435677 bytes, 0 underruns
     0 output errors, 0 collisions, 24 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out
SKDR-3750-45#sh int g1/0/12
GigabitEthernet1/0/12 is up, line protocol is up (connected)
  Hardware is Gigabit Ethernet, address is 0024.13c4.248c (bia 0024.13c4.248c)
  Description:

  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 1000Mb/s, media type is 10/100/1000BaseTX
  input flow-control is off, output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:15, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/0 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 1000 bits/sec, 1 packets/sec
     6711177 packets input, 546552231 bytes, 0 no buffer
     Received 466960 broadcasts (461304 multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 461304 multicast, 0 pause input
     0 input packets with dribble condition detected
     13025887 packets output, 9434512474 bytes, 0 underruns
     0 output errors, 0 collisions, 14 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out
SKDR-3750-45#sh int g2/0/12
GigabitEthernet2/0/12 is up, line protocol is down (notconnect)
  Hardware is Gigabit Ethernet, address is 1c17.d38e.230c (bia 1c17.d38e.230c)
  Description: UNIX SKHP185R (10.222.45.185) connection
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 1000Mb/s, media type is 10/100/1000BaseTX
  input flow-control is off, output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output 00:00:22, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/0 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 1000 bits/sec, 1 packets/sec
     424484 packets input, 54765328 bytes, 0 no buffer
     Received 424460 broadcasts (424446 multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 424446 multicast, 0 pause input
     0 input packets with dribble condition detected
     3231342 packets output, 416538334 bytes, 0 underruns
     0 output errors, 0 collisions, 13 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out

sh etherchannel summary
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port


Number of channel-groups in use: 3
Number of aggregators:           3

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
10     Po10(SU)        LACP      Gi1/0/10(P) Gi2/0/11(s)
12     Po12(SU)        LACP      Gi1/0/12(P) Gi2/0/12(s)
24     Po24(SU)        LACP      Te1/0/1(P)  Te2/0/1(P)

Hall of Fame Community Legend

Re: Cisco 3750 suspended interface when configuring LACP

Hi Maria,

Can you please post the interface config for Po12, Gi1/0/12, Gi2/0/12?

Re: Cisco 3750 suspended interface when configuring LACP

HI The configuration that I used is on the first thread of the discussion.

Frequent Contributor

Re: Cisco 3750 suspended interface when configuring LACP

Few Questions :-

1> seems like it's 3750 switch stack , if yes can you please post the version of the IOS ?

2> are you seeing any Host mac flaps logs in your syslog ? if yes please post them as well.

Thanks

Manish

Hall of Fame Community Legend

Re: Cisco 3750 suspended interface when configuring LACP

Sorry.  Missed that one.  How about the other side?

Beginner

I had this same error on my

I had this same error on my test network and it was cabling related.  

Beginner

Re: Cisco 3750 suspended interface when configuring LACP

noticed that on the switch interface "GigabitEthernet2/0/12 is up, line protocol is down (notconnect)".

you may want to verify the configuration on the server's end.

Re: Cisco 3750 suspended interface when configuring LACP

Hi I was looking at your configuration. Try it this way and see if this works. I have several 3750's running LACP port channels. I assume the servers are using broadcom nics and drivers and broadcom utility has been upgraded.

nterface Port-channel12
description SERVER Gi1/0/12_Gi2/0/12

switchport access vlan 45

switchport mode access

switchport nonegotiate

interface GigabitEthernet1/0/12
switchport access vlan 45

switchport mode access

switchport nonegotiate
channel-group 12 mode active
spanning-tree portfast
spanning-tree bpdufilter enable


interface GigabitEthernet2/0/12
switchport access vlan 45

switchport mode access

switchport nonegotiate
channel-group 12 mode active
spanning-tree portfast
spanning-tree bpdufilter enable

You probably managed to solve

You probably managed to solve this, or gave up, but when the Port goes to a SUSPENDED state (s) - there is a difference in the physical or config layer, something like speed and/or duplex, so make sure that on "show interface" on all Port-channel members you have the same speed, and if not - revise the cable/other side/patch pannels.

 

Hope this helps :)

Beginner

What i did to solved this

What i did to solved this issue :

 

remove the port-channel on the suspended interface on one site , shutdown both ports , no shut the port suspended, you see the port up and running again, now shut the port again, enable port-channel again on the port and no shut the port again, if the port up, then no shut the other port.

 

I have the port-channel up and running again after above changes.

hope this will work for you, good luck.

 

Enthusiast

Re: Cisco 3750 suspended interface when configuring LACP

 

Device:

Cisco Switch 3850

 

Problem:

After upgraded to Release 3.6.8E MD we encountered below issue.

 

*Oct  7 2018 03:22:00.487 PST: %EC-5-CANNOT_BUNDLE2: Gi1/1/1 is not compatible with Po11 and will be suspended (trunk mode of Gi1/1/1 is dynamic, Po11 is access)

 

Workaround:
- Rollback to previous version - Okay

CreatePlease to create content
Content for Community-Ad