12-08-2015 08:27 PM - edited 03-08-2019 03:01 AM
Hello everyone, not sure if this is the right section for this but I figure i'll post anyways and try to get some input from you guys.
Just bought a Cisco 871W router and got it configured to work properly with wired, and I am successfully able to pull a good 20mb/s on a speed test, through ethernet. (20mb/s is what my ISP provides me) but on Wireless, I do another speed test and get about 1-5.
When I do a show int dot11radio0 I get this:
Dot11Radio0 is up, line protocol is up
Hardware is 802.11G Radio, address is 8843.e11a.1aa0 (bia 8843.e11a.1aa0)
MTU 1500 bytes, BW 54000 Kbit/sec, DLY 1000 usec,
reliability 223/255, txload 2/255, rxload 1/255
Encapsulation 802.1Q Virtual LAN, Vlan ID 1., loopback not set
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:26, output 00:00:00, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/7752/0 (size/max/drops/flushes); Total output drops: 43375
Queueing strategy: fifo
Output queue: 0/30 (size/max)
5 minute input rate 14000 bits/sec, 15 packets/sec
5 minute output rate 551000 bits/sec, 34 packets/sec
2108777 packets input, 251200033 bytes, 0 no buffer
Received 2611317 broadcasts, 0 runts, 0 giants, 5633 throttles
137294 input errors, 634455 CRC, 0 frame, 0 overrun, 0 ignored
0 input packets with dribble condition detected
3586275 packets output, 894527105 bytes, 0 underruns
19718 output errors, 0 collisions, 40 interface resets
0 unknown protocol drops
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out
Seems like I'm getting a lot of CRC/input errors and output drops on my wireless interface.
Can anybody help me out and get to the bottom of this?
This is my full config:
Current configuration : 3095 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname SKI
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable secret 5 $1$vQf2$490zA3tq5fFOM.jDuxU5u0
!
no aaa new-model
!
!
dot11 syslog
!
dot11 ssid PoopTicklerNextDoor
vlan 20
authentication open
authentication key-management wpa
guest-mode
wpa-psk ascii 7 152204030A022A2A2C3F3030455E
!
ip source-route
!
!
ip dhcp excluded-address 192.168.1.1 192.168.1.2
ip dhcp excluded-address 192.168.2.1 192.168.2.2
!
ip dhcp pool LAN
import all
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 8.8.8.8 4.2.2.2 4.2.2.3
!
ip dhcp pool WIRELESS
network 192.168.2.0 255.255.255.0
default-router 192.168.2.1
dns-server 8.8.8.8 4.2.2.2 4.2.2.3
!
!
ip cef
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
username dylan.guttowsky privilege 15 secret 5 $1$tptK$vtJJvZVYtptqWmPcmDJVq.
!
!
!
archive
log config
hidekeys
!
!
!
bridge irb
!
!
interface FastEthernet0
switchport access vlan 10
spanning-tree portfast
!
interface FastEthernet1
switchport access vlan 10
spanning-tree portfast
!
interface FastEthernet2
switchport access vlan 10
spanning-tree portfast
!
interface FastEthernet3
switchport access vlan 10
spanning-tree portfast
!
interface FastEthernet4
ip address dhcp
ip verify unicast source reachable-via rx allow-default 100
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface Dot11Radio0
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
ip virtual-reassembly
!
encryption vlan 20 mode ciphers aes-ccm
!
ssid PoopTicklerNextDoor
!
speed basic-54.0
station-role root
no cdp enable
!
interface Dot11Radio0.1
encapsulation dot1Q 20 native
bridge-group 20
bridge-group 20 subscriber-loop-control
bridge-group 20 spanning-disabled
bridge-group 20 block-unknown-source
no bridge-group 20 source-learning
no bridge-group 20 unicast-flooding
!
interface Vlan1
no ip address
ip nat inside
ip virtual-reassembly
bridge-group 1
bridge-group 1 spanning-disabled
!
interface Vlan10
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface Vlan20
no ip address
bridge-group 20
!
interface BVI20
ip address 192.168.2.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 FastEthernet4
no ip http server
no ip http secure-server
!
!
ip nat inside source list INSIDE_NAT_ADDRESSES interface FastEthernet4 overload
!
ip access-list standard INSIDE_NAT_ADDRESSES
permit 192.168.1.0 0.0.0.255
permit 192.168.2.0 0.0.0.255
!
!
!
!
!
!
control-plane
!
bridge 20 protocol ieee
bridge 20 route ip
!
line con 0
exec-timeout 0 0
password 7 06151820585D1E1811
logging synchronous
login
no modem enable
line aux 0
password 7 06151820585D1E1811
login
line vty 0 4
password 7 08325B4F1D0A121606
login
!
scheduler max-task-time 5000
end
Thank you!!!!
12-09-2015 12:24 AM
Hi there,
CRC errors are an indicator of RF interference. I assume when you conducted your speed test you ended up being reasonaly close to the router and still experienced slow speeds?
What is the output of:
sh controllers do11radio 0
We shouold check that DFS is enabled and that the controller is actively seeking an emptier channel.
cheers,
Seb.
12-09-2015 04:23 AM
Seb, this is the output. Yes I am very close to the router when I got these slow speeds.
interface Dot11Radio0
Radio ATHEROS AR5212, Base Address 8843.e11a.1aa0, BBlock version 0.01, Software version 3.00.0
Serial number: FOC13511EVW
Number of supported simultaneous BSSIlD on Dot11Radio0: 4
Carrier Set: Americas (US )
Uniform Spreading Required: No
Current Frequency: 2432 MHz Channel 5
Allowed Frequencies: 2412(1) 2417(2) 2422(3) 2427(4) 2432(5) 2437(6) 2442(7) 244 7(8) 2452(9) 2457(10) 2462(11)
Listen Frequencies:
Beacon Flags: 0; Beacons are disabled; Probes are disabled
Current CCK Power: 20 dBm
Allowed CCK Power Levels: 3 4 5 6 7 10 13 15 17 18 20
Current OFDM Power: 17 dBm
Allowed OFDM Power Levels: 3 4 5 6 7 10 13 15 17
ERP settings: short slot time.
Neighbors in non-erp mode:
Current Rates: basic-54.0
Active Rates: basic-54.0
Allowed Rates: 1.0 2.0 5.5 6.0 9.0 11.0 12.0 18.0 24.0 36.0 48.0 54.0
Best Range Rates: basic-1.0 2.0 5.5 6.0 9.0 11.0 12.0 18.0 24.0 36.0 48.0 54.0
Best Throughput Rates: basic-1.0 basic-2.0 basic-5.5 basic-6.0 basic-9.0 basic- 11.0 basic-12.0 basic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0
Default Rates: basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
Radio Management (RM) Configuration:
Regular AP RM Mode 1 Temp Setting Disabled
Temp Settings: AP Tx Power 0 AP Tx Channel 0 Client Tx Power 0
Rates:
Saved Settings: AP Tx Power 0 AP Tx Channel 5 Client Tx Power 0
Rates:
MCST RSCs: [0]0x0 [1]0x0 [2]0x0 [3]0x0 [4]0x0
TKIP Cum Stats: STA MIC-L-Errs MIC-R-Errs Replay C-Measure
0000.0000.0000 00000000 00000000 00000000 00000000
AES-CCMP Cum Stats: 00000006 replays discarded
QBSS Load: 0x0
Configured Local Access Class Parameters
Background: cw-min 4 cw-max 10 fixed-slot 7 admission-control Off txop 0
BestEffort: cw-min 4 cw-max 6 fixed-slot 3 admission-control Off txop 0
Video : cw-min 3 cw-max 4 fixed-slot 1 admission-control Off txop 3008
Voice : cw-min 2 cw-max 3 fixed-slot 1 admission-control Off txop 1504
Configured Cell Access Class Parameters
Background: cw-min 4 cw-max 10 fixed-slot 7 admission-control Off txop 0
BestEffort: cw-min 4 cw-max 10 fixed-slot 3 admission-control Off txop 0
Video : cw-min 3 cw-max 4 fixed-slot 2 admission-control Off txop 3008
Voice : cw-min 2 cw-max 3 fixed-slot 2 admission-control Off txop 1504
Transmit queues: Active 22 In Progress 20
---- Active --- In-Progress --------------- Counts --------------
Cnt Quo Bas Max Cnt Quo Bas Sent Discard Fail Retry Multi
Uplink 0 0 0 0 0 0 0 0 0 0 0 0
Voice 0 0 0 0 0 0 0 145 0 0 50 29
Video 0 0 0 0 0 0 0 0 0 0 0 0
BestEf 22 51 14 51 20 20 4 780776 28836 12 158943 75675
Multic 0 0 0 0 0 0 0 0 0 0 0 0
Backgr 0 0 0 0 0 0 0 0 0 0 0 0
BSSIDS Index Flags State Next Held Defer NonDefer Clients Tsf Dtim Txq
1AA0 0 08 0 2 0 0 0 0 2 4 0
Driver TX blocks in use: 22, high water mark: 104
Driver TX blocks across reset: 0, failure hw mark: 0
PSP packet reclaim count 0
Clients: 8021x auth in prog 0 allowed 0
Client AID VLAN Status Age Tx Mode Rate Encr Key
587f.5740.5bfd 113 20 0000 0000 78/60 0-0 00B1 0080 0200 0-16
501a.c5cb.8a6c 112 20 0000 0001 59/60 26-2 00B1 0080 0200 0-16
8853.9545.dcc1 95 20 0000 0000 41/60 0-0 00B1 0080 0200 0-16
3cab.8e8f.9e8b 91 20 0000 0000 66/60 0-0 00B1 0080 0200 0-16
Client RSC
587f.5740.5bfd [0]0x68C [1]0x6D3 [2]0x687 [3]0x688
501a.c5cb.8a6c [1]0x5954
8853.9545.dcc1 [0]0x8110 [1]0x81B7 [3]0x8142
3cab.8e8f.9e8b [0]0x493A [1]0x4D73 [2]0x10EC [3]0x4D6F
Vlan BSSID Clients PSP Encr Key0 Key1 Key2 Key3 SSIDs
0 1AA0 0 0 0 0
1 0000 0 0 0 0
20n 1AA0 0 5 4 214 128 x128 PoopTicklerNextDoor
0 bssid A0 flags 3 tsfo 0
1 bssid A0 flags 0 tsfo 0
2 bssid A0 flags 0 tsfo 0
3 bssid A0 flags 0 tsfo 0
4 bssid A0 flags 0 tsfo 0
5 bssid A0 flags 0 tsfo 0
6 bssid A0 flags 0 tsfo 0
7 bssid A0 flags 0 tsfo 0
8 bssid A0 flags 0 tsfo 0
9 bssid A0 flags 0 tsfo 0
10 bssid A0 flags 0 tsfo 0
11 bssid A0 flags 1 tsfo 0
12 bssid A0 flags 0 tsfo 0
Transmitted beacon for each BSSID 0: 22423
BeaconStuck count for each BSSID 0: 0
Noise Immunity level 0
Spur Immunity Level 0
Firstep Level 0
OFDM Weak Signal Detection ON
CCK Weak Signal Threshold low
Transmit Queue details:
Q_ONESHOTARM_SC=0x0 Q_ONESHOTARM_CC=0x0 Q_RDYTIMESHDN=0x0
Q_TXE=0x2, Q_TXD=0x0
Queue Number = 0
================
Q_TXDP=0x0 Q_STS=0x0 Q_CBRCFG=0x0 Q_MISC=0x800 Q_RDYTIMECFG=0x0
Queue Number = 1
================
Q_TXDP=0xAF09980 Q_STS=0x1 Q_CBRCFG=0x0 Q_MISC=0x800 Q_RDYTIMECFG=0x0
Desc=0xAF09980
FirstDesc=0xAF09980, LastDesc=0xAF09980, nextPtr=0xAF09480, StaleFlag=TR UE
thisPhysPtr=0xAF09980 frameLength=1554 more=0 destIdx=6
antModeXmit=0x0
bufferLength=1544 dataLeng=900 pak=0x83EE7EC4 pktType=0 noAck=0
dataFailCnt=0 RTSFailCnt=0, Filtered=0,
fifoUnderrun=0
excessiveRetries=0 pktTransmitOk=1, txAnt=1,
finalTSIdx=3
ackSigStrength=64 seqNum=1207, done=1
Desc=0xAF09480
FirstDesc=0xAF09480, LastDesc=0xAF09480, nextPtr=0xAF08A00, StaleFlag=FA LSE
thisPhysPtr=0xAF09480 frameLength=1554 more=0 destIdx=6
antModeXmit=0x0
bufferLength=1544 dataLeng=900 pak=0x83EE9990 pktType=0 noAck=0
dataFailCnt=0 RTSFailCnt=0, Filtered=0,
fifoUnderrun=0
excessiveRetries=0 pktTransmitOk=0, txAnt=0,
finalTSIdx=0
ackSigStrength=0 seqNum=0, done=0
Desc=0xAF08A00
FirstDesc=0xAF08A00, LastDesc=0xAF08A00, nextPtr=0xAF09E80, StaleFlag=FA LSE
thisPhysPtr=0xAF08A00 frameLength=1554 more=0 destIdx=6
antModeXmit=0x0
bufferLength=1544 dataLeng=900 pak=0x83EECB54 pktType=0 noAck=0
dataFailCnt=0 RTSFailCnt=0, Filtered=0,
fifoUnderrun=0
excessiveRetries=0 pktTransmitOk=0, txAnt=0,
finalTSIdx=0
ackSigStrength=0 seqNum=0, done=0
Desc=0xAF09E80
FirstDesc=0xAF09E80, LastDesc=0xAF09E80, nextPtr=0xAF0A280, StaleFlag=FA LSE
thisPhysPtr=0xAF09E80 frameLength=1554 more=0 destIdx=6
antModeXmit=0x0
bufferLength=1544 dataLeng=900 pak=0x83EEEDC8 pktType=0 noAck=0
dataFailCnt=0 RTSFailCnt=0, Filtered=0,
fifoUnderrun=0
excessiveRetries=0 pktTransmitOk=0, txAnt=0,
finalTSIdx=0
ackSigStrength=0 seqNum=0, done=0
Desc=0xAF0A280
FirstDesc=0xAF0A280, LastDesc=0xAF0A280, nextPtr=0xAF08800, StaleFlag=FA LSE
thisPhysPtr=0xAF0A280 frameLength=1554 more=0 destIdx=6
antModeXmit=0x0
bufferLength=1544 dataLeng=900 pak=0x83EF0C68 pktType=0 noAck=0
dataFailCnt=0 RTSFailCnt=0, Filtered=0,
fifoUnderrun=0
excessiveRetries=0 pktTransmitOk=0, txAnt=0,
finalTSIdx=0
ackSigStrength=0 seqNum=0, done=0
Desc=0xAF08800
FirstDesc=0xAF08800, LastDesc=0xAF08800, nextPtr=0xAF08200, StaleFlag=FA LSE
thisPhysPtr=0xAF08800 frameLength=1554 more=0 destIdx=6
antModeXmit=0x0
bufferLength=1544 dataLeng=900 pak=0x83EE1F10 pktType=0 noAck=0
dataFailCnt=0 RTSFailCnt=0, Filtered=0,
fifoUnderrun=0
excessiveRetries=0 pktTransmitOk=0, txAnt=0,
finalTSIdx=0
ackSigStrength=0 seqNum=0, done=0
Desc=0xAF08200
FirstDesc=0xAF08200, LastDesc=0xAF08200, nextPtr=0xAF08F80, StaleFlag=FA LSE
thisPhysPtr=0xAF08200 frameLength=1554 more=0 destIdx=6
antModeXmit=0x0
bufferLength=1544 dataLeng=900 pak=0x83EE6BA0 pktType=0 noAck=0
dataFailCnt=0 RTSFailCnt=0, Filtered=0,
fifoUnderrun=0
excessiveRetries=0 pktTransmitOk=0, txAnt=0,
finalTSIdx=0
ackSigStrength=0 seqNum=0, done=0
Desc=0xAF08F80
FirstDesc=0xAF08F80, LastDesc=0xAF08F80, nextPtr=0xAF09880, StaleFlag=FA LSE
thisPhysPtr=0xAF08F80 frameLength=1554 more=0 destIdx=6
antModeXmit=0x0
bufferLength=1544 dataLeng=900 pak=0x83EEB45C pktType=0 noAck=0
dataFailCnt=0 RTSFailCnt=0, Filtered=0,
fifoUnderrun=0
excessiveRetries=0 pktTransmitOk=0, txAnt=0,
finalTSIdx=0
ackSigStrength=0 seqNum=0, done=0
Desc=0xAF09880
FirstDesc=0xAF09880, LastDesc=0xAF09880, nextPtr=0xAF08400, StaleFlag=FA LSE
thisPhysPtr=0xAF09880 frameLength=1554 more=0 destIdx=6
antModeXmit=0x0
bufferLength=1544 dataLeng=900 pak=0x83EEDAA4 pktType=0 noAck=0
dataFailCnt=0 RTSFailCnt=0, Filtered=0,
fifoUnderrun=0
excessiveRetries=0 pktTransmitOk=0, txAnt=0,
finalTSIdx=0
ackSigStrength=0 seqNum=0, done=0
Desc=0xAF08400
FirstDesc=0xAF08400, LastDesc=0xAF08400, nextPtr=0xAF09180, StaleFlag=FA LSE
thisPhysPtr=0xAF08400 frameLength=1554 more=0 destIdx=6
antModeXmit=0x0
bufferLength=1544 dataLeng=900 pak=0x83EE7348 pktType=0 noAck=0
dataFailCnt=0 RTSFailCnt=0, Filtered=0,
fifoUnderrun=0
excessiveRetries=0 pktTransmitOk=0, txAnt=0,
finalTSIdx=0
ackSigStrength=0 seqNum=0, done=0
Desc=0xAF09180
FirstDesc=0xAF09180, LastDesc=0xAF09180, nextPtr=0xAF08980, StaleFlag=FA LSE
thisPhysPtr=0xAF09180 frameLength=1554 more=0 destIdx=6
antModeXmit=0x0
bufferLength=1544 dataLeng=900 pak=0x83EE6F74 pktType=0 noAck=0
dataFailCnt=0 RTSFailCnt=0, Filtered=0,
fifoUnderrun=0
excessiveRetries=0 pktTransmitOk=0, txAnt=0,
finalTSIdx=0
ackSigStrength=0 seqNum=0, done=0
Desc=0xAF08980
FirstDesc=0xAF08980, LastDesc=0xAF08980, nextPtr=0xAF09C80, StaleFlag=FA LSE
thisPhysPtr=0xAF08980 frameLength=1554 more=0 destIdx=6
antModeXmit=0x0
bufferLength=1544 dataLeng=900 pak=0x83EE0FC0 pktType=0 noAck=0
dataFailCnt=0 RTSFailCnt=0, Filtered=0,
fifoUnderrun=0
excessiveRetries=0 pktTransmitOk=0, txAnt=0,
finalTSIdx=0
ackSigStrength=0 seqNum=0, done=0
Desc=0xAF09C80
FirstDesc=0xAF09C80, LastDesc=0xAF09C80, nextPtr=0xAF09F00, StaleFlag=FA LSE
thisPhysPtr=0xAF09C80 frameLength=1554 more=0 destIdx=6
antModeXmit=0x0
bufferLength=1544 dataLeng=900 pak=0x83EE2A8C pktType=0 noAck=0
dataFailCnt=0 RTSFailCnt=0, Filtered=0,
fifoUnderrun=0
excessiveRetries=0 pktTransmitOk=0, txAnt=0,
finalTSIdx=0
ackSigStrength=0 seqNum=0, done=0
Desc=0xAF09F00
FirstDesc=0xAF09F00, LastDesc=0xAF09F00, nextPtr=0xAF0A000, StaleFlag=FA LSE
thisPhysPtr=0xAF09F00 frameLength=1554 more=0 destIdx=6
antModeXmit=0x0
bufferLength=1544 dataLeng=900 pak=0x83EF17E4 pktType=0 noAck=0
dataFailCnt=0 RTSFailCnt=0, Filtered=0,
fifoUnderrun=0
excessiveRetries=0 pktTransmitOk=0, txAnt=0,
finalTSIdx=0
ackSigStrength=0 seqNum=0, done=0
Desc=0xAF0A000
FirstDesc=0xAF0A000, LastDesc=0xAF0A000, nextPtr=0xAF09C00, StaleFlag=FA LSE
thisPhysPtr=0xAF0A000 frameLength=1554 more=0 destIdx=6
antModeXmit=0x0
bufferLength=1544 dataLeng=900 pak=0x83EE587C pktType=0 noAck=0
dataFailCnt=0 RTSFailCnt=0, Filtered=0,
fifoUnderrun=0
excessiveRetries=0 pktTransmitOk=0, txAnt=0,
finalTSIdx=0
ackSigStrength=0 seqNum=0, done=0
Desc=0xAF09C00
FirstDesc=0xAF09C00, LastDesc=0xAF09C00, nextPtr=0xAF09B00, StaleFlag=FA LSE
thisPhysPtr=0xAF09C00 frameLength=1554 more=0 destIdx=6
antModeXmit=0x0
bufferLength=1544 dataLeng=900 pak=0x83EE492C pktType=0 noAck=0
dataFailCnt=0 RTSFailCnt=0, Filtered=0,
fifoUnderrun=0
excessiveRetries=0 pktTransmitOk=0, txAnt=0,
finalTSIdx=0
ackSigStrength=0 seqNum=0, done=0
Desc=0xAF09B00
FirstDesc=0xAF09B00, LastDesc=0xAF09B00, nextPtr=0xAF08D00, StaleFlag=FA LSE
thisPhysPtr=0xAF09B00 frameLength=1554 more=0 destIdx=6
antModeXmit=0x0
bufferLength=1544 dataLeng=900 pak=0x83EEBC04 pktType=0 noAck=0
dataFailCnt=0 RTSFailCnt=0, Filtered=0,
fifoUnderrun=0
excessiveRetries=0 pktTransmitOk=0, txAnt=0,
finalTSIdx=0
ackSigStrength=0 seqNum=0, done=0
Desc=0xAF08D00
FirstDesc=0xAF08D00, LastDesc=0xAF08D00, nextPtr=0xAF09500, StaleFlag=FA LSE
thisPhysPtr=0xAF08D00 frameLength=1554 more=0 destIdx=6
antModeXmit=0x0
bufferLength=1544 dataLeng=900 pak=0x83EF00EC pktType=0 noAck=0
dataFailCnt=0 RTSFailCnt=0, Filtered=0,
fifoUnderrun=0
excessiveRetries=0 pktTransmitOk=0, txAnt=0,
finalTSIdx=0
ackSigStrength=0 seqNum=0, done=0
Desc=0xAF09500
FirstDesc=0xAF09500, LastDesc=0xAF09500, nextPtr=0xAF08680, StaleFlag=FA LSE
thisPhysPtr=0xAF09500 frameLength=1554 more=0 destIdx=6
antModeXmit=0x0
bufferLength=1544 dataLeng=900 pak=0x83EE54A8 pktType=0 noAck=0
dataFailCnt=0 RTSFailCnt=0, Filtered=0,
fifoUnderrun=0
excessiveRetries=0 pktTransmitOk=0, txAnt=0,
finalTSIdx=0
ackSigStrength=0 seqNum=0, done=0
Desc=0xAF08680
FirstDesc=0xAF08680, LastDesc=0xAF08680, nextPtr=0xAF08280, StaleFlag=FA LSE
thisPhysPtr=0xAF08680 frameLength=1554 more=0 destIdx=6
antModeXmit=0x0
bufferLength=1544 dataLeng=900 pak=0x83EF1F8C pktType=0 noAck=0
dataFailCnt=0 RTSFailCnt=0, Filtered=0,
fifoUnderrun=0
excessiveRetries=0 pktTransmitOk=0, txAnt=0,
finalTSIdx=0
ackSigStrength=0 seqNum=0, done=0
Desc=0xAF08280
FirstDesc=0xAF08280, LastDesc=0xAF08280, nextPtr=0x0, StaleFlag=FALSE
thisPhysPtr=0xAF08280 frameLength=1554 more=0 destIdx=6
antModeXmit=0x0
bufferLength=1544 dataLeng=900 pak=0x83EE4184 pktType=0 noAck=0
dataFailCnt=0 RTSFailCnt=0, Filtered=0,
fifoUnderrun=0
excessiveRetries=0 pktTransmitOk=0, txAnt=0,
finalTSIdx=0
ackSigStrength=0 seqNum=0, done=0
Queue Number = 2
================
Q_TXDP=0x0 Q_STS=0x0 Q_CBRCFG=0x0 Q_MISC=0x800 Q_RDYTIMECFG=0x0
Queue Number = 3
================
Q_TXDP=0xAF08D80 Q_STS=0x0 Q_CBRCFG=0x0 Q_MISC=0x800 Q_RDYTIMECFG=0x0
Desc=0xAF08D80
FirstDesc=0xAF08D80, LastDesc=0xAF08D80, nextPtr=0x0, StaleFlag=TRUE
thisPhysPtr=0xAF08D80 frameLength=30 more=0 destIdx=0
antModeXmit=0x0
bufferLength=26 dataLeng=900 pak=0x84304A74 pktType=0 noAck=0
dataFailCnt=0 RTSFailCnt=0, Filtered=0,
fifoUnderrun=0
excessiveRetries=0 pktTransmitOk=1, txAnt=1,
finalTSIdx=0
ackSigStrength=63 seqNum=2006, done=1
Queue Number = 4
================
Q_TXDP=0xAF0A200 Q_STS=0x0 Q_CBRCFG=0x0 Q_MISC=0x800 Q_RDYTIMECFG=0x0
Desc=0xAF0A200
FirstDesc=0xAF0A200, LastDesc=0xAF0A200, nextPtr=0x0, StaleFlag=TRUE
thisPhysPtr=0xAF0A200 frameLength=157 more=0 destIdx=0
antModeXmit=0x0
bufferLength=153 dataLeng=900 pak=0x84311D00 pktType=4 noAck=0
dataFailCnt=2 RTSFailCnt=0, Filtered=0,
fifoUnderrun=0
excessiveRetries=1 pktTransmitOk=0, txAnt=1,
finalTSIdx=0
ackSigStrength=59 seqNum=215, done=1
Queue Number = 5
================
Q_TXDP=0x0 Q_STS=0x0 Q_CBRCFG=0x0 Q_MISC=0x0 Q_RDYTIMECFG=0x0
Queue Number = 6
================
Q_TXDP=0x0 Q_STS=0x0 Q_CBRCFG=0x0 Q_MISC=0x0 Q_RDYTIMECFG=0x0
Queue Number = 7
================
Q_TXDP=0x0 Q_STS=0x0 Q_CBRCFG=0x0 Q_MISC=0x0 Q_RDYTIMECFG=0x0
Queue Number = 8
================
Q_TXDP=0x0 Q_STS=0x0 Q_CBRCFG=0x0 Q_MISC=0x862 Q_RDYTIMECFG=0x1015800
Queue Number = 9
================
Q_TXDP=0xAF09280 Q_STS=0x0 Q_CBRCFG=0x0 Q_MISC=0x8A2 Q_RDYTIMECFG=0x0
Desc=0xAF09280
FirstDesc=0xAF09280, LastDesc=0xAF09280, nextPtr=0x0, StaleFlag=FALSE
thisPhysPtr=0xAF09280 frameLength=163 more=0 destIdx=0
antModeXmit=0x0
bufferLength=159 dataLeng=900 pak=0x83CB235C pktType=3 noAck=1
dataFailCnt=0 RTSFailCnt=0, Filtered=0,
fifoUnderrun=0
excessiveRetries=0 pktTransmitOk=1, txAnt=0,
finalTSIdx=0
ackSigStrength=28 seqNum=1208, done=1
RADAR registers
MAC_RX_FILTER = 0x91
MAC_PHY_ERROR = 0x0
PHY_RADAR_0 = 0x5D50E188
MAC Registers
=== 0x0008: 0x00000004
=== 0x000C: 0x0AF06DC0
=== 0x0010: 0x00000000
=== 0x0014: 0x00000105
=== 0x0018: 0x00000000
=== 0x001C: 0x00000000
=== 0x0020: 0x00000000
=== 0x0024: 0x00000001
=== 0x0028: 0x00000000
=== 0x002C: 0x00000000
=== 0x0030: 0x00000013
=== 0x0034: 0x00000003
=== 0x0038: 0x0AF072D0
=== 0x003C: 0x00000000
=== 0x0040: 0x00000001
=== 0x0044: 0x00000008
=== 0x0048: 0x00000008
=== 0x004C: 0x00000010
=== 0x0050: 0x00000000
=== 0x0054: 0x0000001F
=== 0x0058: 0x00000000
=== 0x005C: 0x009A1BF5
=== 0x0060: 0x00000000
=== 0x0064: 0x00000000
=== 0x0068: 0x00000000
=== 0x006C: 0x00000000
=== 0x0070: 0x00000000
=== 0x0074: 0x00000000
=== 0x0078: 0x00000000
=== 0x007C: 0x00000000
=== 0x0080: 0x00001000
=== 0x0084: 0x00000000
=== 0x0088: 0x00000000
=== 0x008C: 0x08000000
=== 0x0090: 0x00000000
=== 0x0094: 0x00000000
=== 0x0098: 0x00000000
=== 0x009C: 0x00000000
=== 0x00A0: 0x000909F5
=== 0x00A4: 0x0000011F
=== 0x00A8: 0x0000011F
=== 0x00AC: 0x0000011F
=== 0x00B0: 0x00000000
=== 0x00B4: 0x00000000
QCU Registers
=== 0x0800: 0x00000000
=== 0x0804: 0x0AF0A000
=== 0x0808: 0x00000000
=== 0x080C: 0x0AF08D80
=== 0x0810: 0x0AF0A200
=== 0x0814: 0x00000000
=== 0x0818: 0x00000000
=== 0x081C: 0x00000000
=== 0x0820: 0x00000000
=== 0x0824: 0x0AF09280
=== 0x08C0: 0x00000000
=== 0x08C4: 0x00000000
=== 0x08C8: 0x00000000
=== 0x08CC: 0x00000000
=== 0x08D0: 0x00000000
=== 0x08D4: 0x00000000
=== 0x08D8: 0x00000000
=== 0x08DC: 0x00000000
=== 0x08E0: 0x00000000
=== 0x08E4: 0x00000000
=== 0x09C0: 0x00000800
=== 0x09C4: 0x00000800
=== 0x09C8: 0x00000800
=== 0x09CC: 0x00000800
=== 0x09D0: 0x00000800
=== 0x09D4: 0x00000000
=== 0x09D8: 0x00000000
=== 0x09DC: 0x00000000
=== 0x09E0: 0x00000862
=== 0x09E4: 0x000008A2
DCU Registers
=== 0x1000: 0x00000001
=== 0x1004: 0x00000002
=== 0x1008: 0x00000004
=== 0x100C: 0x00000008
=== 0x1010: 0x00000010
=== 0x1014: 0x00000020
=== 0x1018: 0x00000040
=== 0x101C: 0x00000080
=== 0x1020: 0x00000100
=== 0x1024: 0x00000200
=== 0x1028: 0x00000000
=== 0x102C: 0x00000000
=== 0x1030: 0x00000160
=== 0x1034: 0x00000000
=== 0x1038: 0x00000000
=== 0x103C: 0x00000000
=== 0x1040: 0x007FFC0F
=== 0x1044: 0x0030FC0F
=== 0x1048: 0x00103C07
=== 0x104C: 0x00101C03
=== 0x1050: 0x00101C03
=== 0x1054: 0x002FFC0F
=== 0x1058: 0x002FFC0F
=== 0x105C: 0x002FFC0F
=== 0x1060: 0x00101C03
=== 0x1064: 0x00101C03
=== 0x1068: 0x00000000
=== 0x106C: 0x00000000
=== 0x1070: 0x0000018C
=== 0x1074: 0x00000000
=== 0x1078: 0x00000000
=== 0x107C: 0x00000000
=== 0x1080: 0x0008200F
=== 0x1084: 0x0008200F
=== 0x1088: 0x0008200F
=== 0x108C: 0x0008200F
=== 0x1090: 0x0008200F
=== 0x1094: 0x00020804
=== 0x1098: 0x00020804
=== 0x109C: 0x00020804
=== 0x10A0: 0x0008200F
=== 0x10A4: 0x0008200F
=== 0x10A8: 0x00000000
=== 0x10AC: 0x00000000
=== 0x10B0: 0x00003E38
=== 0x10B4: 0x00000000
=== 0x10B8: 0x00000000
=== 0x10BC: 0x00000000
=== 0x10C0: 0x00000000
=== 0x10C4: 0x00000000
=== 0x10C8: 0x00100BC0
=== 0x10CC: 0x001005E0
=== 0x10D0: 0x001005E0
=== 0x10D4: 0x00000000
=== 0x10D8: 0x00000000
=== 0x10DC: 0x00000000
=== 0x10E0: 0x001005E0
=== 0x10E4: 0x001005E0
=== 0x10E8: 0x00000000
=== 0x10EC: 0x00000000
=== 0x10F0: 0x0000B0E0
=== 0x1230: 0x00000000
PCI Registers
=== 0x4000: 0x00000000
=== 0x4004: 0x00000000
=== 0x4008: 0x00000000
=== 0x400C: 0x00000000
=== 0x4010: 0x00000014
=== 0x4014: 0x00000000
=== 0x4018: 0x00000000
=== 0x401C: 0x00000000
=== 0x4020: 0x00000059
=== 0x4024: 0x00000000
=== 0x4028: 0x00000000
=== 0x402C: 0x000003FF
=== 0x4030: 0x00000000
Eeprom Registers
=== 0x6000: 0x00000000
=== 0x6004: 0x00000000
=== 0x6008: 0x00000000
=== 0x600C: 0x00000000
=== 0x6010: 0x00000000
PCU Registers
=== 0x8000: 0x1AE14388
=== 0x8004: 0x3881A01A
=== 0x8008: 0x1AE14388
=== 0x800C: 0x0000A01A
=== 0x8010: 0x00000000
=== 0x8014: 0x08400840
=== 0x8018: 0x00000700
=== 0x801C: 0x12E013AB
=== 0x8020: 0x00000064
=== 0x8024: 0x003B7ED9
=== 0x8028: 0x00007E14
=== 0x802C: 0x0003F090
=== 0x8030: 0x0193F050
=== 0x8034: 0x00007DF5
=== 0x8038: 0x0000E567
=== 0x803C: 0x00000091
=== 0x8040: 0x9DFF67C0
=== 0x8044: 0x4BF18E78
=== 0x8048: 0x00000000
=== 0x804C: 0xC9F7C4BE
=== 0x8050: 0x00000006
=== 0x8054: 0x00016DE0
=== 0x8058: 0x00000002
=== 0x805C: 0xFFFFC78F
=== 0x8060: 0x0000000F
BB Registers
=== 0x9800: 0x00000007
=== 0x9804: 0x00000000
=== 0x9808: 0x00000000
=== 0x980C: 0xAD848E19
=== 0x9810: 0x7D28E000
=== 0x9814: 0xA86C7F6B
=== 0x9818: 0x00000043
=== 0x981C: 0x00000001
=== 0x9820: 0x02020200
=== 0x9824: 0x00000E0E
=== 0x9828: 0x0A020201
=== 0x982C: 0x0002A002
=== 0x9830: 0x00000000
=== 0x9834: 0x00000E0E
=== 0x9838: 0x0000000B
=== 0x983C: 0x00020100
=== 0x9840: 0x206A017A
=== 0x9844: 0x137219A2
=== 0x9848: 0x0019EA75
=== 0x984C: 0x72C0613C
=== 0x9850: 0x0C98B0E0
=== 0x9854: 0x00000859
=== 0x9858: 0x7EC80D2E
=== 0x985C: 0x3139605E
=== 0x9860: 0x00009D18
=== 0x9864: 0x0D01CE00
=== 0x9868: 0x409A4190
=== 0x986C: 0x050CB081
=== 0x9870: 0x0000001F
=== 0x9874: 0x0000007F
=== 0x9878: 0x0000000E
=== 0x9900: 0x00000000
=== 0x9904: 0x00000000
=== 0x9908: 0x00000000
=== 0x990C: 0x00800000
=== 0x9910: 0x00000001
=== 0x9914: 0x00000898
=== 0x9918: 0x00000108
=== 0x991C: 0x00000C80
=== 0x9920: 0x0510F85F
=== 0x9924: 0x10058A05
=== 0x9928: 0x00000000
=== 0x992C: 0x00000004
=== 0x9930: 0x4A006800
=== 0x9934: 0x34343434
=== 0x9938: 0x2C303434
=== 0x993C: 0x0000003C
=== 0x9940: 0x00000004
=== 0x9944: 0xF7B81010
=== 0x9948: 0x9280B212
=== 0x994C: 0x00080F40
=== 0x9950: 0x00000000
=== 0x9954: 0x5D50E188
=== 0x9958: 0x000000FF
=== 0x995C: 0x004B6A8E
=== 0x9960: 0x02082481
=== 0x9964: 0x01041442
=== 0x9968: 0x000003FF
=== 0x996C: 0x00000000
=== 0x9970: 0x192FB515
=== 0x9C00: 0x00000000
=== 0x9C04: 0xCF3BFF7E
=== 0x9C08: 0x000007CF
=== 0x9C0C: 0x00002631
=== 0x9C10: 0xCA8A25F4
=== 0x9C14: 0xC5374009
=== 0x9C18: 0xFBCCDDC7
=== 0x9C1C: 0x0000001F
Log Buffer:
12-09-2015 04:27 AM
What output do you get for:
dot11 dot11radio 0 carrier busy
sh dot11 carrier busy
12-09-2015 06:04 AM
This is the output I got:
SKI#dot11 dot11radio 0 carrier busy
SKI#sh dot11 carrier busy
Frequency Carrier Busy %
--------- --------------
2412 100
2417 100
2422 100
2427 100
2432 100
2437 100
2442 100
2447 100
2452 100
2457 100
2462 100
12-09-2015 06:09 AM
!
That is incredible, never seen congestion like that! :)
Lets try and put it in a single channel band:
!
int dot11radio 0
channel 6
!
now run the carrier test again;
dot11 dot11radio 0 carrier busy
sh dot11 carrier busy
What is the output now?
12-09-2015 06:18 AM
Yeah I live in a Military barracks, kind of a like a dorm per say. Lots of routers around me.
Just curious, cause my cheap old netgear router that was like $40 didn't do this haha.
SKI#dot11 dot11radio 0 carrier busy
SKI#sh dot11 carrier busy
SKI#sh dot11 carrier busy
SKI#sh dot11 carrier busy
SKI#sh dot11 carrier busy
SKI#sh dot11 carrier busy
SKI#sh dot11 carrier busy
SKI#sh dot11 carrier busy
SKI#sh dot11 carrier busy
Frequency Carrier Busy %
--------- --------------
2412 100
2417 100
2422 100
2427 100
2432 100
2437 100
2442 100
2447 100
2452 100
2457 100
2462 100
12-09-2015 06:28 AM
Could be that you netgear was running 5GHz which has shorter range but more channels to use, so ultimately less interference.
Try using the phone app I suggested, you may find a corner of the room with less interference.
At least now your 871 is using just a single channel band, so you *may* get a slight increase in speed. Try it...
12-09-2015 06:52 AM
The speed is still around the same.
Did a wired test on my xbox, it's around 12mb/s for that, did wireless and it's at 1.13mb/s. Says I have around 42% packet loss
My netgear is 2.4ghz 802.11n so idk what could be going on
Edit: go ahead and post another suggestion, but I gotta head to bed. 12am here. Thanks for the help, hopefully we will get to the bottom of this.
12-09-2015 07:17 AM
Came accross thie cisco bug which affects your router and the carrier test:
https://tools.cisco.com/bugsearch/bug/CSCef04982
Download the phone app and find the least congested channel.
Or try:
!
int dot11radio 0
channel least-congested
!
...reload the router and see if that makes a difference.
cheers,
Seb.
12-09-2015 11:55 PM
Got the phone app, my wifi is in the least congested right now. I had it set to that before, still slow performance.. It's on channel 9 now.
12-10-2015 12:09 AM
Channel 9 will be overlapping with channel bands 6 and 11.
Your options are 1,6 or 11.
With the app is your SSID the strongest signal visible, albeit crowd by other SSIDs?
12-10-2015 12:33 AM
That's what it picks for least-congested.
I was looking around, and I adjusted the power for local and client to max. Did a test, and I am not getting much packet loss anymore on my wireless.
Changed world mode to JP and indoor, don't know if that did anything.
Also, took ip nat inside off of Vlan1, don't know if that did anything either lol.
Getting no packet loss on my xbox now via wireless, and I am getting about 11.8 down and on wired I'm getting 19.99, so getting closer.
Still getting some crc errors.
This is what I see, my SSID is PoopTickerNextDoor lol
12-10-2015 12:43 AM
OK then some good progress. Based on the screenshot, putting the radio interface on channel 11 will reduce the RF interference further.
Regarding the NAT, looking at your config VLAN1 is not used on the wireless or wired network so it is safe to remove.
12-10-2015 12:56 AM
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide