cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1821
Views
0
Helpful
8
Replies

cisco 887va Vlan 1 ping vlan 2 but no internet access

willie002
Beginner
Beginner

I have setup a cisco 887va router with two vlans, VLAN1 with 192.168.0.1 and vlan2 with 192.168.1.1, vlan1 can ping vlan2 and also adsl modem that is 192.168.1.1 on vlan2 but can't access or ping internet addresses

1 Accepted Solution

Accepted Solutions

Hi,

you should add a default route pointing towards the modem/router:

ip route 0.0.0.0 0..0.0 192.168.1.x

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

View solution in original post

8 Replies 8

cadet alain
Mentor
Mentor

Hi,

Can you ping internet from your router ?

Did you enable NAT ?

example:

int vlan 1

ip nat inside

int vlan 2

ip nat inside

int dialer0

ip nat outside

access-list 1 permit 192.168.0.0 0.0.0.255

access-list 1 permit 192.168.1.0 0.0.0.255

ip nat inside source list 1 interface dialer0

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

Our ISP supplied us with a adsl modem pre-configured with all the ip's on it. We want to use the 887 between the local lan and the ISP adsl. vlan1 is local and vlan2 is setup for the adsl connection.

NAT is setup on vlan1 as inside and vlan2 as outside.

Regards

So can you ping 8.8.8.8 from the cisco device ?

Is vlan 1 correctly translated ?

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

No the router can't ping 8.8.8.8

Here is the config file

Building configuration...

Current configuration : 3945 bytes

!

! Last configuration change at 16:52:29 PCTime Tue Jun 25 2013 by kws

version 15.3

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

no logging buffered

enable secret 4 wTu1WsK5Nn9HYNtXwMMxJu2.6Rk7Ulps99fVVl9eqLU

!

no aaa new-model

memory-size iomem 10

clock timezone PCTime 2 0

!

!

ip port-map imap port tcp 143 list 7 description IMAP

ip port-map http port tcp 80 list 5 description HTTP

ip port-map smtp port tcp 25 list 4 description SMTP Mail

ip port-map user-rdp port tcp 3389 list 9 description RDP

ip port-map pop3 port tcp 110 list 3 description POP3 Mail

ip port-map imaps port tcp 993 list 8 description IMPAS

ip port-map https port tcp 443 list 6 description HTTPS

!

!

!

!

ip domain name kwscarriers.co.za

ip name-server 192.168.1.1

ip name-server 168.210.2.2

ip name-server 196.14.239.2

ip cef

no ipv6 cef

!

parameter-map type regex ccp-regex-nonascii

pattern [^\x00-\x80]

parameter-map type protocol-info yahoo-servers

server name scs.msg.yahoo.com

server name scsa.msg.yahoo.com

server name scsb.msg.yahoo.com

server name scsc.msg.yahoo.com

server name scsd.msg.yahoo.com

server name cs16.msg.dcn.yahoo.com

server name cs19.msg.dcn.yahoo.com

server name cs42.msg.dcn.yahoo.com

server name cs53.msg.dcn.yahoo.com

server name cs54.msg.dcn.yahoo.com

server name ads1.vip.scd.yahoo.com

server name radio1.launch.vip.dal.yahoo.com

server name in1.msg.vip.re2.yahoo.com

server name data1.my.vip.sc5.yahoo.com

server name address1.pim.vip.mud.yahoo.com

server name edit.messenger.yahoo.com

server name messenger.yahoo.com

server name http.pager.yahoo.com

server name privacy.yahoo.com

server name csa.yahoo.com

server name csb.yahoo.com

server name csc.yahoo.com

parameter-map type protocol-info msn-servers

server name messenger.hotmail.com

server name gateway.messenger.hotmail.com

server name webmessenger.msn.com

parameter-map type protocol-info aol-servers

server name login.oscar.aol.com

server name toc.oscar.aol.com

server name oam-d09a.blue.aol.com

!

multilink bundle-name authenticated

!

!

license udi pid CISCO887VA-K9 sn FCZ17199002

license boot module c880-data level advipservices_npe

!

!

username kws privilege 15 secret 4 wTu1WsK5Nn9HYNtXwMMxJu2.6Rk7Ulps99fVVl9eqLU

username Willie privilege 15 view root secret 4 dXECdgs7knvNbc.W.d63mlJt.HIaUIjJ6CUEkWSE7Zw

!

!

controller VDSL 0

!

!

class-map type inspect match-any ccp-cls-protocol-p2p

match protocol edonkey signature

match protocol gnutella signature

match protocol kazaa2 signature

match protocol fasttrack signature

match protocol bittorrent signature

class-map type inspect match-any ccp-cls-icmp-access

match protocol icmp

match protocol tcp

match protocol udp

class-map type inspect match-any ccp-cls-protocol-im

match protocol ymsgr yahoo-servers

match protocol msnmsgr msn-servers

match protocol aol aol-servers

!

!

!

!

interface Ethernet0

no ip address

!

interface ATM0

no ip address

no atm ilmi-keepalive

!

interface FastEthernet0

no ip address

!

interface FastEthernet1

no ip address

!

interface FastEthernet2

no ip address

!

interface FastEthernet3

description WAN

switchport access vlan 2

switchport trunk native vlan 2

no ip address

!

interface Vlan1

description $FW_INSIDE$

ip address 192.168.0.1 255.255.255.0

ip nat inside

ip virtual-reassembly in

!

interface Vlan2

ip address 192.168.1.2 255.255.255.0

ip nat outside

ip virtual-reassembly in

!

ip forward-protocol nd

ip http server

ip http authentication local

no ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

!

ip nat inside source list 1 interface Vlan2 overload

!

!

access-list 1 remark CCP_ACL Category=2

access-list 1 permit 192.168.0.0 0.0.0.255

!

control-plane

!

!

!

line con 0

no modem enable

line aux 0

line vty 0 4

login local

transport input telnet

!

!

end

Posting your config would be really helpful.

No the router can't ping 8.8.8.8

Here is the config file

Building configuration...

Current configuration : 3945 bytes

!

! Last configuration change at 16:52:29 PCTime Tue Jun 25 2013 by kws

version 15.3

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

no logging buffered

enable secret 4 wTu1WsK5Nn9HYNtXwMMxJu2.6Rk7Ulps99fVVl9eqLU

!

no aaa new-model

memory-size iomem 10

clock timezone PCTime 2 0

!

!

ip port-map imap port tcp 143 list 7 description IMAP

ip port-map http port tcp 80 list 5 description HTTP

ip port-map smtp port tcp 25 list 4 description SMTP Mail

ip port-map user-rdp port tcp 3389 list 9 description RDP

ip port-map pop3 port tcp 110 list 3 description POP3 Mail

ip port-map imaps port tcp 993 list 8 description IMPAS

ip port-map https port tcp 443 list 6 description HTTPS

!

!

!

!

ip domain name kwscarriers.co.za

ip name-server 192.168.1.1

ip name-server 168.210.2.2

ip name-server 196.14.239.2

ip cef

no ipv6 cef

!

parameter-map type regex ccp-regex-nonascii

pattern [^\x00-\x80]

parameter-map type protocol-info yahoo-servers

server name scs.msg.yahoo.com

server name scsa.msg.yahoo.com

server name scsb.msg.yahoo.com

server name scsc.msg.yahoo.com

server name scsd.msg.yahoo.com

server name cs16.msg.dcn.yahoo.com

server name cs19.msg.dcn.yahoo.com

server name cs42.msg.dcn.yahoo.com

server name cs53.msg.dcn.yahoo.com

server name cs54.msg.dcn.yahoo.com

server name ads1.vip.scd.yahoo.com

server name radio1.launch.vip.dal.yahoo.com

server name in1.msg.vip.re2.yahoo.com

server name data1.my.vip.sc5.yahoo.com

server name address1.pim.vip.mud.yahoo.com

server name edit.messenger.yahoo.com

server name messenger.yahoo.com

server name http.pager.yahoo.com

server name privacy.yahoo.com

server name csa.yahoo.com

server name csb.yahoo.com

server name csc.yahoo.com

parameter-map type protocol-info msn-servers

server name messenger.hotmail.com

server name gateway.messenger.hotmail.com

server name webmessenger.msn.com

parameter-map type protocol-info aol-servers

server name login.oscar.aol.com

server name toc.oscar.aol.com

server name oam-d09a.blue.aol.com

!

multilink bundle-name authenticated

!

!

license udi pid CISCO887VA-K9 sn FCZ17199002

license boot module c880-data level advipservices_npe

!

!

username kws privilege 15 secret 4 wTu1WsK5Nn9HYNtXwMMxJu2.6Rk7Ulps99fVVl9eqLU

username Willie privilege 15 view root secret 4 dXECdgs7knvNbc.W.d63mlJt.HIaUIjJ6CUEkWSE7Zw

!

!

controller VDSL 0

!

!

class-map type inspect match-any ccp-cls-protocol-p2p

match protocol edonkey signature

match protocol gnutella signature

match protocol kazaa2 signature

match protocol fasttrack signature

match protocol bittorrent signature

class-map type inspect match-any ccp-cls-icmp-access

match protocol icmp

match protocol tcp

match protocol udp

class-map type inspect match-any ccp-cls-protocol-im

match protocol ymsgr yahoo-servers

match protocol msnmsgr msn-servers

match protocol aol aol-servers

!

!

!

!

interface Ethernet0

no ip address

!

interface ATM0

no ip address

no atm ilmi-keepalive

!

interface FastEthernet0

no ip address

!

interface FastEthernet1

no ip address

!

interface FastEthernet2

no ip address

!

interface FastEthernet3

description WAN

switchport access vlan 2

switchport trunk native vlan 2

no ip address

!

interface Vlan1

description $FW_INSIDE$

ip address 192.168.0.1 255.255.255.0

ip nat inside

ip virtual-reassembly in

!

interface Vlan2

ip address 192.168.1.2 255.255.255.0

ip nat outside

ip virtual-reassembly in

!

ip forward-protocol nd

ip http server

ip http authentication local

no ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

!

ip nat inside source list 1 interface Vlan2 overload

!

!

access-list 1 remark CCP_ACL Category=2

access-list 1 permit 192.168.0.0 0.0.0.255

!

control-plane

!

!

!

line con 0

no modem enable

line aux 0

line vty 0 4

login local

transport input telnet

!

!

end

Hi,

you should add a default route pointing towards the modem/router:

ip route 0.0.0.0 0..0.0 192.168.1.x

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

Hi Alain

Thanks for your help it worked.

Regards

Willie

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers