cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
365
Views
0
Helpful
0
Replies

CISCO C9300L - Multicast Routing VLAN Interfaces (Static)

Oleksandr Y.
Beginner
Beginner

Hello Community, I have been scavenging the internet for possible leads or solutions but found nothing so far, wondering if someone has attempted this or maybe a similar network design or maybe some tips and tricks that might help with this configuration.

NOTE: I am using HSRP actually and from what I have read in the: https://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst9300/software/release/16-6/configuration_guide/ip_mcast_rtng/b_166_ip_mcast_rtng_9300_cg.pdf hsrp-aware PIM is not supported - but either way most of the equipment in the system is not PIM enabled which means I have to manually direct the MCAST stream, which is OK because the network is not very much complicated. Please see the simplified network layout attached. 

So the idea here is that Server (on the left) with IP 10.10.40.50 is the source of the Multicast stream. I can see the MCAST traffic incoming on Physical Interface of the 9300 - the physical interface is linked to interface Vlan40 where I would be expecting the Multicast traffic to show up as well - I only see incoming unicast traffic at this point (the actual bitrate is reflecting the amount of MCAST traffic I am sending) which is not necessarily bad, but It does not look like this VLAN40 interface is considering this incoming traffic as Multicast at all, so that is issue #1, next step would be to get this traffic out of interface Vlan105 and into a PEP server (the server acts as a bridge of sorts, so anything going into it on subnet 192.168.15.0 /24 will be coming out on subnet 192.168.16.0 /24 after being processed). This traffic will then have to make it back to the 9300 on interface VLAN106 and from there the next hop would be the Modulator @ 192.168.254.111 IP address - this completes the actual path that actually Unicast and Multicast traffic will be traversing. 

 

If anyone has any ideas please or has experienced the same situation trying to set up such a LAB  

!

interface GigabitEthernet1/0/36
switchport trunk allowed vlan 40,100,103,203,303,4093
switchport mode trunk
load-interval 30
end

!

interface Vlan40
ip address 10.10.40.2 255.255.255.0
no ip redirects
ip pim sparse-dense-mode
standby 40 ip 10.10.40.1
standby 40 timers 1 3
standby 40 priority 110
standby 40 preempt
load-interval 30
end

!

Here is where we see the output on the Physical Link: 

CISCO-9300# sh int gi1/0/36
GigabitEthernet1/0/36 is up, line protocol is up (connected)
Hardware is Gigabit Ethernet, address is 4ce1.7675.bba4 (bia 4ce1.7675.bba4)
MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 14/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 100Mb/s, media type is 10/100/1000BaseTX
input flow-control is on, output flow-control is unsupported
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:00, output 00:00:00, output hang never
Last clearing of "show interface" counters 00:01:05
Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
30 second input rate 5496000 bits/sec, 586 packets/sec
30 second output rate 171000 bits/sec, 131 packets/sec
38449 packets input, 44700431 bytes, 0 no buffer
Received 31493 broadcasts (31207 multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 31207 multicast, 0 pause input
0 input packets with dribble condition detected
8951 packets output, 1435013 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 unknown protocol drops
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 pause output
0 output buffer failures, 0 output buffers swapped out

 

CISCO-9300# sh int vlan 40
Vlan40 is up, line protocol is up , Autostate Enabled
Hardware is Ethernet SVI, address is 4ce1.7675.bbe4 (bia 4ce1.7675.bbe4)
Internet address is 10.10.40.2/24
MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive not supported
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:00, output 00:00:00, output hang never
Last clearing of "show interface" counters 00:00:19
Input queue: 0/375/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
30 second input rate 5417000 bits/sec, 536 packets/sec
30 second output rate 52000 bits/sec, 45 packets/sec
10704 packets input, 13554550 bytes, 0 no buffer
Received 0 broadcasts (0 IP multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
874 packets output, 130605 bytes, 0 underruns
0 output errors, 0 interface resets
0 unknown protocol drops
0 output buffer failures, 0 output buffers swapped out

 

NOW on a normal router if I would like to direct traffic out a certain interface I would use something like "ip igmp static-group [mcast group ip]" but this does not really help, and I am partially blaming the fact that interface Vlan40 does not understand that the incoming traffic is actual multicast ... any ideas are very much appreciated. 

0 Replies 0
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers