05-10-2022 01:00 PM
I'm attempting to enable multicast, it doesn't appear to be difficult to configure but obviously I'm doing something wrong. I would think that if I plug client1 into int1 and send video to the group, I should be able to easily subscribe to it from client2. On the 9300 CLI I can see client1 is sending to the group, but Wireshark running on client2 shows the SW isn't sending advertisements. When I try to tune into the stream on client2 Wireshark shows me that the client is sending solicitations for the multicast but I never see the 9300 respond. Below is the configuration I think is necessary. Please tell me what I'm over looking.
!
ip multicast-routing
!
interface GigabitEthernet1/0/1
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/2
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface Vlan10
description Video
ip address 192.168.1.1 255.255.255.0
ip pim dense-mode
ip igmp join-group 239.0.0.201
!
Solved! Go to Solution.
05-10-2022 02:34 PM
Since this is all in the same vlan, you only need "ip igmp snooping vlan xx" and ip igmp snooping querier address xx.xx.x.x
you really don't need "ip pim dense-mode"
Also, have a look at this link for troubleshooting tips.
HTH
05-10-2022 01:20 PM
Can you share the show running?
You should have the command " ip mfib "
and you can add the command to the interface instead:
nterface GigabitEthernet1/0/1
switchport access vlan 10
ip pim dense-mode
ip igmp join-group 239.0.0.201
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/2
switchport access vlan 10
ip pim dense-mode
ip igmp join-group 239.0.0.201
switchport mode access
spanning-tree portfast
05-10-2022 02:34 PM
Since this is all in the same vlan, you only need "ip igmp snooping vlan xx" and ip igmp snooping querier address xx.xx.x.x
you really don't need "ip pim dense-mode"
Also, have a look at this link for troubleshooting tips.
HTH
05-11-2022 08:34 AM
Would the querier address be what I have configured as the VLAN 10 gateway, 192.168.1.1? Or something else?
05-16-2022 01:10 PM
I removed ip pim and ip igmp join-group. My video seems to work within the vlan with just the following:
!
ip multicast-routing
!
!
ip igmp snooping querier address 192.168.1.1
ip igmp snooping querier
no ip igmp snooping
!
interface GigabitEthernet1/0/1
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet1/0/2
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface Vlan10
description Video
ip address 192.168.1.1 255.255.255.0
!
Your input helped me configure it to do what I would've liked/expected.
If I wanted to multicast across VLANs, would additional configuration would be necessary?
05-16-2022 01:35 PM
Hello
Yes - To route MC between vlans you would required to use PIM
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide