cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1196
Views
0
Helpful
16
Replies

Cisco Catalyst switch link issues

I have a Cisco C9300 switch and the port does not link up when connected to WS-C4506, however when i connect the C9300 to a 2960 the same port links up.
Is there an issue with a catalyst switch port not linking up when connected to another catalyst switch port?

 

16 Replies 16

Check speed and duplex for link.

It should be auto negotiating everything, it auto negotiated everything when connected to C2960:

Here are the outputs:

Port 47 when connected to the  WS-C4506 and port 48 connected to the 2960:

Te1/0/47 notconnect 1 auto auto 100/1000/2.5G/5G/10GBaseTX

Te1/0/48 connected 1 a-full a-1000 100/1000/2.5G/5G/10GBaseTX

 

This switch is brand new switch out of the box with no configuration and i have noticed similar behaviors with other C9300 as well.

I am just looking for it to link nothing more than that, but it does not even recognize the link at all.

Is this a bug?

Would you post the output of these commands from both the 9300 and the 4506

from show run the configuration of the switch inteface

show interface <interfaceID>

HTH

Rick

There is physical mismatch between SW's.

I Will send private messages share some note.

Following is the config on the switch ports:

Switch#sh run int te1/0/47
Building configuration...

Current configuration : 42 bytes
!
interface TenGigabitEthernet1/0/47
end

Switch#sh run int te1/0/48
Building configuration...

Current configuration : 42 bytes
!
interface TenGigabitEthernet1/0/48
end

 

Following are the interface details:

Switch#sh int tenGigabitEthernet 1/0/47
TenGigabitEthernet1/0/47 is down, line protocol is down (notconnect)
Hardware is Ten Gigabit Ethernet, address is dc77.4c65.efaf (bia dc77.4c65.efaf)
MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Auto-duplex, Auto-speed, media type is 100/1000/2.5G/5G/10GBaseTX
input flow-control is on, output flow-control is unsupported
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:07:03, output 00:07:02, output hang never
Last clearing of "show interface" counters never
Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 12000 bits/sec, 16 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
59887 packets input, 6508968 bytes, 0 no buffer
Received 41280 broadcasts (4487 multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 4487 multicast, 0 pause input
0 input packets with dribble condition detected
299 packets output, 26920 bytes, 0 underruns
Output 0 broadcasts (0 multicasts)
0 output errors, 0 collisions, 2 interface resets
14 unknown protocol drops
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 pause output
0 output buffer failures, 0 output buffers swapped out
Switch#sh int tenGigabitEthernet 1/0/48
TenGigabitEthernet1/0/48 is up, line protocol is up (connected)
Hardware is Ten Gigabit Ethernet, address is dc77.4c65.efb0 (bia dc77.4c65.efb0)
MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 1000Mb/s, media type is 100/1000/2.5G/5G/10GBaseTX
input flow-control is on, output flow-control is unsupported
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:02, output 00:00:01, output hang never
Last clearing of "show interface" counters never
Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
261 packets input, 37056 bytes, 0 no buffer
Received 51 broadcasts (51 multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 51 multicast, 0 pause input
0 input packets with dribble condition detected
1379 packets output, 106435 bytes, 0 underruns
Output 0 broadcasts (0 multicasts)
0 output errors, 0 collisions, 2 interface resets
0 unknown protocol drops
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 pause output
0 output buffer failures, 0 output buffers swapped out

We noticed this in production and testing to see if this is just one switch or are all 9300 working like this?

I am looking for possible mismatch between switches. Providing output from only one switch is not helpful.

HTH

Rick

Cisco C9300 port 48 connected to Cisco 2960 on port 5

Switch#sh run int tenGigabitEthernet 1/0/48
Building configuration...

Current configuration : 42 bytes
!
interface TenGigabitEthernet1/0/48
end

Switch#sh int tenGigabitEthernet 1/0/48
TenGigabitEthernet1/0/48 is up, line protocol is up (connected)
Hardware is Ten Gigabit Ethernet, address is dc77.4c65.efb0 (bia dc77.4c65.efb0)
MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 1000Mb/s, media type is 100/1000/2.5G/5G/10GBaseTX
input flow-control is on, output flow-control is unsupported
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:02, output 00:00:01, output hang never
Last clearing of "show interface" counters never
Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
261 packets input, 37056 bytes, 0 no buffer
Received 51 broadcasts (51 multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 51 multicast, 0 pause input
0 input packets with dribble condition detected
1379 packets output, 106435 bytes, 0 underruns
Output 0 broadcasts (0 multicasts)
0 output errors, 0 collisions, 2 interface resets
0 unknown protocol drops
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 pause output
0 output buffer failures, 0 output buffers swapped out

On Cisco 2960 port 5

s-cc-dd-1#sh run int gi 0/5
Building configuration...

Current configuration : 87 bytes
!
interface GigabitEthernet0/5
switchport access vlan 87
switchport mode access
end

s-cc-dd-1#sh int gi0/5

GigabitEthernet0/5 is up, line protocol is up (connected)
Hardware is Gigabit Ethernet, address is 70d3.79b6.3505 (bia 70d3.79b6.3505)
MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 1000Mb/s, media type is 10/100/1000BaseTX
input flow-control is off, output flow-control is unsupported
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:01, output 00:00:01, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
2838 packets input, 215022 bytes, 0 no buffer
Received 2404 broadcasts (2404 multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 2404 multicast, 0 pause input
0 input packets with dribble condition detected
528 packets output, 71528 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
144 unknown protocol drops
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 pause output
0 output buffer failures, 0 output buffers swapped out

(I will post the other link on the next comment)

just to update after almost 45 minutes now, the link is up between the C9300 and WS-C4506 , here are the details:

On port 47 of C9300:

Switch#sh run int te1/0/47
Building configuration...

Current configuration : 42 bytes
!
interface TenGigabitEthernet1/0/47
end

Switch#sh int te1/0/47
TenGigabitEthernet1/0/47 is up, line protocol is up (connected)
Hardware is Ten Gigabit Ethernet, address is dc77.4c65.efaf (bia dc77.4c65.efaf)
MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 1000Mb/s, media type is 100/1000/2.5G/5G/10GBaseTX
input flow-control is on, output flow-control is unsupported
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:00, output 00:00:01, output hang never
Last clearing of "show interface" counters never
Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 4000 bits/sec, 5 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
64341 packets input, 7461290 bytes, 0 no buffer
Received 43766 broadcasts (6730 multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 6730 multicast, 0 pause input
0 input packets with dribble condition detected
1051 packets output, 84063 bytes, 0 underruns
Output 0 broadcasts (0 multicasts)
0 output errors, 0 collisions, 2 interface resets
28 unknown protocol drops
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 pause output
0 output buffer failures, 0 output buffers swapped out

On port 5/29 of WS-C4506:

Building configuration...

Current configuration : 164 bytes
!
interface GigabitEthernet5/29
description Jack 3082
switchport trunk native vlan 87
switchport trunk allowed vlan 87,501,3001,3201
switchport mode trunk
end

s-abc-cde#sh int gi 5/29
GigabitEthernet5/29 is up, line protocol is up (connected)
Hardware is Gigabit Ethernet Port, address is 1cdf.0fc3.c53c (bia 1cdf.0fc3.c53c)
Description: Jack 3082
MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 1000Mb/s, link type is auto, media type is 10/100/1000-TX
input flow-control is off, output flow-control is off
Auto-MDIX on (operational: on)
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:00, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 3000 bits/sec, 5 packets/sec
203316 packets input, 17055545 bytes, 0 no buffer
Received 6653 broadcasts (6617 multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 input packets with dribble condition detected
8357634 packets output, 1066554746 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out

 

Note: Nothing changed, configuration was not changed, the cable was not touched and link was not flapped. The link came up on its own.
We have noticed the same in production as well , so is this like a bug?

 

Thanks for the update. It is strange that the connection did come up but after a long delay. I wish that the interface outputs had been done while the connection was still not working. Perhaps that might have provided some clue about the issue.

I do note that there is one mismatch shown in the outputs. On the 2960 the switch port is configured as an access port. On the 4506 the interface is a trunk carrying 4 vlans. I do not see how this mismatch could cause the symptoms you describe, but this mismatch is something that you should address.

HTH

Rick

If there was a mismatch should not the port first link up and then throw an error? It does not recognize the port at all. It always throws up as "not connected". Also if both the ports are trunked or access ports i would still be able to recreate this issue. On the field we had the 9300 connect to the C4506 , the ports on each of the devices were a trunk port. We used different ports on the switch configured as trunk and it would not come back up. Of course 30 minutes later it would come back up , is this a known bug or something new?  I can provide you with interface outputs when the links are not up since i just need to reboot the switch so to have a look.


alanvthomas1991@gmail.com wrote:
so is this like a bug?

It is and the bug lies with the 9300.

We call this behaviour "ghost ports".  

What is the Bug id and the version to fix this?

Ghost ports only happen, predominantly, on switches on IOS-XE.  Classic IOS very rarely (or never) ever have this. 

Reboot the offending switch member is the only workaround.

Only monitoring this port I dont think there is issue according to config you share.

Review Cisco Networking for a $25 gift card