07-06-2018 08:44 AM - edited 03-08-2019 03:35 PM
So I did configure 2 switches for trunking but they are unable to ping each other. Please help. Not sure what I'm doing wrong.
Switch 1 - Configuration
Switch#show run
Building configuration...
Current configuration : 1646 bytes
!
version 12.1
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch
!
enable password cisco
!
ip subnet-zero
!
spanning-tree extend system-id
!
!
interface FastEthernet0/1
switchport trunk allowed vlan 1-100
switchport mode trunk
no ip address
!
interface FastEthernet0/2
no ip address
!
interface FastEthernet0/3
no ip address
!
interface FastEthernet0/4
no ip address
!
interface FastEthernet0/5
no ip address
!
interface FastEthernet0/6
no ip address
!
interface FastEthernet0/7
no ip address
!
interface FastEthernet0/8
no ip address
!
interface FastEthernet0/9
no ip address
!
interface FastEthernet0/10
no ip address
!
interface FastEthernet0/11
no ip address
!
interface FastEthernet0/12
no ip address
!
interface FastEthernet0/13
no ip address
!
interface FastEthernet0/14
no ip address
!
interface FastEthernet0/15
no ip address
!
interface FastEthernet0/16
no ip address
!
interface FastEthernet0/17
no ip address
!
interface FastEthernet0/18
no ip address
!
interface FastEthernet0/19
no ip address
!
interface FastEthernet0/20
no ip address
!
interface FastEthernet0/21
no ip address
!
interface FastEthernet0/22
no ip address
!
interface FastEthernet0/23
switchport access vlan 50
switchport mode access
no ip address
!
interface FastEthernet0/24
no ip address
!
interface GigabitEthernet0/1
no ip address
!
interface GigabitEthernet0/2
no ip address
!
interface Vlan1
no ip address
no ip route-cache
shutdown
!
ip http server
!
!
line con 0
line vty 0 4
login
line vty 5 15
login
!
end
Switch 2 - Configuration
Switch#show run
Building configuration...
Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch
!
enable secret 5 $1$5Aku$zFReGOOhdtOg9V1nU8PKQ/
!
!
!
!
!
!
ip subnet-zero
!
!
!
interface FastEthernet0/1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1-100,1002-1005
switchport mode trunk
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
switchport access vlan 50
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface FastEthernet0/25
!
interface FastEthernet0/26
!
interface FastEthernet0/27
!
interface FastEthernet0/28
!
interface FastEthernet0/29
!
interface FastEthernet0/30
!
interface FastEthernet0/31
switchport access vlan 100
!
interface FastEthernet0/32
!
interface FastEthernet0/33
!
interface FastEthernet0/34
!
interface FastEthernet0/35
!
interface FastEthernet0/36
!
interface FastEthernet0/37
!
interface FastEthernet0/38
!
interface FastEthernet0/39
!
interface FastEthernet0/40
!
interface FastEthernet0/41
!
interface FastEthernet0/42
!
interface FastEthernet0/43
!
interface FastEthernet0/44
!
interface FastEthernet0/45
!
interface FastEthernet0/46
!
interface FastEthernet0/47
!
interface FastEthernet0/48
switchport access vlan 99
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface VLAN1
no ip directed-broadcast
no ip route-cache
!
!
line con 0
transport input none
stopbits 1
line vty 0 4
login
line vty 5 15
login
!
end
Switch#
07-06-2018 09:04 AM
- Wether the designated interfaces have become trunk links can be verified with 'show interface status' ; but ping is unrelated to trunking. Usually you will give every switch an IP address on it's management interface, hence resulting in reachability trough ping.
M.
07-06-2018 09:09 AM
Which IP are you trying to ping? You need to configure IP address for VLAN1 on both switches then only you can ping.
Thanks,
Abhishek
07-06-2018 10:25 AM
I was trying to ping the IP of the computers.
Ping from PC1 with IP 192.68.100.100 to PC2 with IP 192.168.50.50 but it didn't ping - Transmit failed, general failure.
07-06-2018 10:33 AM - edited 07-06-2018 10:34 AM
In the config's posted neither switch has an IP address or a default gateway. Create a vlan (layer 2) Create an SVI of the same vlan and assign an Ip to it. Then create a default gateway if you want to ping anything off of the subnet used for the vlan's. I assume there is a router somewhere?
Oh and be sure the SVI (Layer 3 vlan interface) is no shut.
07-06-2018 10:47 AM
No router, just testing switch to switch
07-06-2018 10:58 AM
These two computers may be in different subnets depending on the subnet mask configured on them.
If you put both computers in the same network they should be able to ping each other. I'm hoping it's just a typo on PC1 but try this
PC1
192.168.100.101
255.255.255.0
GW 192.168.100.1
PC2
192.168.100.102
255.255.255.0
GW 192.168.100.1
If these two pc's are connected to interfaces configured for switchport access vlan 100 on each switch and the trunk allows vlan 100 then you may be in business.
07-06-2018 11:20 AM
Awesome
I can ping..........YESSSSS
Now, how can I ping from 192.168.100.100 to IP 192.168.50.50
What if I have multiple networks and need them to access the same printers and the same file server
07-06-2018 11:55 AM
- Beyond the scope of the forum but in the domain of study-and-learn....
M.
07-06-2018 11:58 AM
You need a routed interface for each network, ie layer 3 or IP. You will need to enable the SDM routing template and ip routing. I think this thread and the link at the bottom of it has what you're looking for but it is based off of 2960's.
If you want to learn more networking make sure to have a solid understanding of Layer 2 vs Layer 3. What we made work was just a Layer 2 connection.
07-08-2018 07:48 AM
First, check the ports on the switch that you used to link it to the computer are on the same VLAN.
For example: computer A ---- Switch ----- Switch ----- computer B
Both A and B ports on the switch must be on the same VLAN.
Second: check that you have created the VLAN of question on all the switches.
Third: Make sure that the trunk links are allowed to transfer the VLAN in question.
Yours scinerely.
07-09-2018 06:52 AM
Actually, you cannot ping between switches because they work in layer 2. Layer 3 switches are exceptional. So, if you want to check your work, link two computers into your switches in question and then give each computer an ip from the same mask. Finally. use the ping.
07-09-2018 08:49 AM
No you can, assuming you have created an SVI.
The switch would also contain an ARP table.
Martin
07-09-2018 11:17 AM
I am talking apart from L3 switches. Look at his output, he does not have any SVI.
07-09-2018 01:16 PM
I see what your saying, originally it read as you need a L3 switch to ping another node.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide