12-07-2004 10:10 AM - edited 03-05-2019 11:21 AM
I have one 2955 Switch out of the box and need to configure http to connect from the web browser and need also telnet. I followed the manual for configuring, setting the passwords and setting ip server http for instance, but doesn't work.
Could somebody help me?.
Thanks.
12-07-2004 12:14 PM
I assume you are still using vlan 1. TO start with
a. you will configure vlan 1 interface with an ip address of your choice. (192.168.1.1/24)
int vlan 1
ip add 192.168.1.1 255.255.255.0
b. Configure (say) port 1 into vlan 1 -
int fa0/1
switchport access vlan 1
switchport mode access
spanning-tree portfast
c. Put your PC to access this switch in port 1. Configure IP 192.168.1.2/24 for your PC.
d. To enable HTTP web server on the switch
Switch(config)#ip http server
Switch(config)#ip http authentication local
Switch(config)#username josepss password cisco
e. To enable telnet (login using username configured above)
Switch(config)#line vty 0 4
Switch(config-line)#login local
Hope that helps!
12-09-2004 02:25 AM
Hi! I wrote these instructions but don't work. This switch is connected to the other switches in the ethernet and have to be available to connect with http or telnet from anywhere inside the network and not only from one specific port.
Thanks for your help and if there is any other idea will be wellcome.
12-09-2004 03:45 AM
Please post the configuration of the switch here and I'll help you get it working. Also, if possible give the IP subnet(s) of the rest of your network.
12-09-2004 05:22 AM
Thanks for your reply. Here it is the configuration for the switch. I have a 193.148.197.0/24
(254 hosts) network.
The current configuration, after some trials, is:
CIM_EGR_SW1#sh running-conf
Building configuration...
Current configuration : 1532 bytes
!
version 12.1
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname CIM_EGR_SW1
!
enable password xxxxx
!
username xxxx password xxxx
ip subnet-zero
!
!
alarm profile defaultPort
!
alarm facility temperature primary relay major
alarm facility temperature primary syslog
alarm facility temperature primary notifies
spanning-tree extend system-id
!
!
interface FastEthernet0/1
switchport mode access
no ip address
!
interface FastEthernet0/2
no ip address
!
interface FastEthernet0/3
no ip address
!
interface FastEthernet0/4
no ip address
!
interface FastEthernet0/5
no ip address
!
interface FastEthernet0/6
no ip address
!
interface FastEthernet0/7
no ip address
!
interface FastEthernet0/8
switchport mode access
no ip address
!
interface FastEthernet0/9
no ip address
!
interface FastEthernet0/10
no ip address
!
interface FastEthernet0/11
no ip address
!
interface FastEthernet0/12
no ip address
!
interface GigabitEthernet0/1
no ip address
!
interface GigabitEthernet0/2
no ip address
!
!
ip address 193.148.197.10 255.255.255.0
no ip route-cache
shutdown
!
ip default-gateway 193.148.197.1
ip http server
ip http authentication local
!
snmp-server engineID local xxxxx
snmp-server community xxxx
snmp-server community xxxx
!
line con 0
password xxxx
line vty 0 4
password xxxx
login local
line vty 5 15
password xxxx
login
!
end
12-09-2004 07:26 AM
Are you able to access the switch's web page from a PC directly connected to this switch ? Are you able to ping from the PC to this switch ?
12-09-2004 09:47 AM
No,I am not able to connect from one port of the same switch.And the ping from the console doen't see any IP on the network
12-10-2004 02:16 AM
You have the interface shutdown (this is the default) after you create a new interface. You have to bring it up by issuing a "no shutdown" command.
ip address 193.148.197.10 255.255.255.0
no ip route-cache
shutdown <-------------
Do a "no shutdown" on this interface and try it again.
-=Phil=-
12-10-2004 09:44 AM
Thank you very much for your help. Now I can connect to the switch by http and telnet and the problem is solved.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide