10-26-2018 09:26 AM
Hello,
I configured the mgmt0 interface with an IP address(10.1.200.6/24) that's on the default vrf (vrf default) and connect the port to an ethernet port (Eth2/10) on the same chassis. I configured the default route as follows:
interface mgmt0
vrf member management
vrf context management
ip route 0.0.0.0/0 10.1.200.1
When I try to ping the mgmt interface, it won't respond. I realize that the mgmt interface is on a different vrf (vrf management) than the default vrf, will I need to create route leaking?
sh ip route vrf management
IP Route Table for VRF "management"
'*' denotes best ucast next-hop
'**' denotes best mcast next-hop
'[x/y]' denotes [preference/metric]
'%<string>' in via output denotes VRF <string>
0.0.0.0/0, ubest/mbest: 1/0
*via 10.1.200.1, [1/0], 18:11:52, static
10.1.200.0/24, ubest/mbest: 1/0, attached
*via 10.1.200.6, mgmt0, [0/0], 18:12:45, direct
10.1.200.6/32, ubest/mbest: 1/0, attached
*via 10.1.200.6, mgmt0, [0/0], 18:12:45, local
Solved! Go to Solution.
10-29-2018 07:05 AM
Thanks for your input!
Finally, I was able to configure the mgmt 0 interface on the default vdc and access it using ssh.
Here's the configuration I performed as it might be useful for others that might run into this issue:
1- Configure one of the line interfaces with the appropriate vlan (in my case, I used vlan 200):
config t
int eth2/44
description Link_To_Mgmt0
switchport access vlan 200
spanning-tree port type edge
spanning-tree bpduguard enable
exit
2- On the default vdc, configure the mgmt0 with the designated ip address and assign it to vrf management:
interface mgmt. 0
description Link_To_Eth2/44
vrf member management
ip address 10.1.200.6/24
3- On the default vdc, configure the default route on vrf management:
vrf context management
ip route 0.0.0.0/0 10.1.200.1
4- Test by pinging the default gateway using the vrf management
ping 10.1.200.1 vrf management
nx7k_default_vdc# ping 10.1.200.1 vrf management
PING 10.1.200.1 (10.1.200.1): 56 data bytes
64 bytes from 10.1.200.1: icmp_seq=0 ttl=200 time=1.361 ms
64 bytes from 10.1.200.1: icmp_seq=1 ttl=200 time=1.444 ms
64 bytes from 10.1.200.1: icmp_seq=2 ttl=200 time=1.003 ms
64 bytes from 10.1.200.1: icmp_seq=3 ttl=200 time=0.979 ms
64 bytes from 10.1.200.1: icmp_seq=4 ttl=200 time=1.014 ms
^C
--- 10.1.200.1 ping statistics ---
5 packets transmitted, 5 packets received, 0.00% packet loss
round-trip min/avg/max = 0.979/1.16/1.444 ms
5- Test by pinging the mgmt0 interface from my desktop
C:\Users\admin>ping 10.1.200.6
Pinging 10.1.200.6 with 32 bytes of data:
Reply from 10.1.200.6: bytes=32 time=2ms TTL=254
Reply from 10.1.200.6: bytes=32 time<1ms TTL=254
Reply from 10.1.200.6: bytes=32 time<1ms TTL=254
Reply from 10.1.200.6: bytes=32 time<1ms TTL=254
Ping statistics for 10.1.200.6:
Packets: Sent = 4, Received = 4, Lost = 0 (0%
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 2ms, Average = 0ms
That's all I had to do to configure the mgmt. 0 interface on the default vdc.
Best, ~zK
10-26-2018 09:59 AM
The management interface is in management VRF.
So if you want to ping you need to use VRF management to ping.
10-26-2018 10:21 AM
Thanks for the input. I should've been clearer, I can ping the interface from the NX7K default route but when I try to ping the mgmt interface from my desktop it doesn't respond. I can ping other hosts within the 10.1.200.x/24 subnet, though!
Best, ~zK
10-26-2018 12:17 PM
what is the device from you try to ping ? what is the IP address of the PC. and where it is connected
looking at configuration where is the ip configuration ( may be you have not posted full configuration here to understand)
interface mgmt0
vrf member management
vrf context management
ip route 0.0.0.0/0 10.1.200.1
10-29-2018 07:05 AM
Thanks for your input!
Finally, I was able to configure the mgmt 0 interface on the default vdc and access it using ssh.
Here's the configuration I performed as it might be useful for others that might run into this issue:
1- Configure one of the line interfaces with the appropriate vlan (in my case, I used vlan 200):
config t
int eth2/44
description Link_To_Mgmt0
switchport access vlan 200
spanning-tree port type edge
spanning-tree bpduguard enable
exit
2- On the default vdc, configure the mgmt0 with the designated ip address and assign it to vrf management:
interface mgmt. 0
description Link_To_Eth2/44
vrf member management
ip address 10.1.200.6/24
3- On the default vdc, configure the default route on vrf management:
vrf context management
ip route 0.0.0.0/0 10.1.200.1
4- Test by pinging the default gateway using the vrf management
ping 10.1.200.1 vrf management
nx7k_default_vdc# ping 10.1.200.1 vrf management
PING 10.1.200.1 (10.1.200.1): 56 data bytes
64 bytes from 10.1.200.1: icmp_seq=0 ttl=200 time=1.361 ms
64 bytes from 10.1.200.1: icmp_seq=1 ttl=200 time=1.444 ms
64 bytes from 10.1.200.1: icmp_seq=2 ttl=200 time=1.003 ms
64 bytes from 10.1.200.1: icmp_seq=3 ttl=200 time=0.979 ms
64 bytes from 10.1.200.1: icmp_seq=4 ttl=200 time=1.014 ms
^C
--- 10.1.200.1 ping statistics ---
5 packets transmitted, 5 packets received, 0.00% packet loss
round-trip min/avg/max = 0.979/1.16/1.444 ms
5- Test by pinging the mgmt0 interface from my desktop
C:\Users\admin>ping 10.1.200.6
Pinging 10.1.200.6 with 32 bytes of data:
Reply from 10.1.200.6: bytes=32 time=2ms TTL=254
Reply from 10.1.200.6: bytes=32 time<1ms TTL=254
Reply from 10.1.200.6: bytes=32 time<1ms TTL=254
Reply from 10.1.200.6: bytes=32 time<1ms TTL=254
Ping statistics for 10.1.200.6:
Packets: Sent = 4, Received = 4, Lost = 0 (0%
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 2ms, Average = 0ms
That's all I had to do to configure the mgmt. 0 interface on the default vdc.
Best, ~zK
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide