11-20-2012 11:28 AM - edited 03-07-2019 10:09 AM
hi,
i have a 3560 connecting to a sp with limited bandwidth. i have one interface on the switch whose traffic i do not want to drop. i want this traffic to go into the high priority queue. i am not sure how this should be configured, but here is my best guess and my current qos configuration on the switch:
mls qos map cos-dscp 0 8 16 26 32 46 48 56
mls qos srr-queue output cos-map queue 1 threshold 3 5
mls qos srr-queue output cos-map queue 2 threshold 1 4 6 7
mls qos srr-queue output cos-map queue 2 threshold 2 3
mls qos srr-queue output cos-map queue 4 threshold 3 0 1 2
mls qos srr-queue output dscp-map queue 1 threshold 3 46
mls qos srr-queue output dscp-map queue 2 threshold 1 32 48 56
mls qos srr-queue output dscp-map queue 2 threshold 2 26
mls qos srr-queue output dscp-map queue 4 threshold 3 0 1 2 3 4 5 6 7
mls qos srr-queue output dscp-map queue 4 threshold 3 8 9 10 11 12 13 14 15
mls qos srr-queue output dscp-map queue 4 threshold 3 16 17 18 19 20 21 22 23
mls qos srr-queue output dscp-map queue 4 threshold 3 24 25 27 28 29 30 31 33
mls qos srr-queue output dscp-map queue 4 threshold 3 34 35 36 37 38 39 40 41
mls qos srr-queue output dscp-map queue 4 threshold 3 42 43 44 45 47 49 50 51
mls qos srr-queue output dscp-map queue 4 threshold 3 52 53 54 55 57 58 59 60
mls qos srr-queue output dscp-map queue 4 threshold 3 61 62 63
mls qos queue-set output 1 threshold 1 150 300 100 400
mls qos queue-set output 1 threshold 2 150 300 50 400
mls qos queue-set output 1 threshold 3 150 300 50 400
mls qos queue-set output 1 threshold 4 200 300 100 1000
mls qos queue-set output 1 buffers 10 20 1 69
mls qos
interface FastEthernet0/1
description access 2851
switchport access vlan 177
switchport mode access
srr-queue bandwidth share 10 20 1 69
priority-queue out
mls qos trust dscp
i would change fa0/1 to the following
no mls qos trust dscp
mls qos cos 5
mls qos cos override
since cos 5 is mapped to dscp 46 then this traffic would go into the priority queue. is this correct ?
if anyone has any insight i would appreciate it. thanks.
11-20-2012 12:25 PM
Bob,
I would enter like this :-
!
!
int fas 0/1
no mls qos trust dscp
mls qos cos 5 override
!
!
Then :-
show mls qos in fas 0/1
verify results
Regards,
Alex.
Please rate useful posts.
11-21-2012 05:42 AM
ios doesn't support
mls qos cos 5 override
i am using 12.2(55)se6 and you have to enter 2 separate commands.
11-20-2012 12:36 PM
When the switch receives the frame with a cos value of 5 it will consult the cos-dscp table and derive a dscp value from this. On the output interface the switch will then use the dscp-cos map to derive the correct cos value. You should check that with the 'sh qos maps dscp-cos' command that the mappings are correct. It's also worth noting that you're setting the dscp value to 46, which if you have voice running in your network with the same dscp value could cause real issues. You'll also need to enable the 'priority queue out' command on the output interface.
Sent from Cisco Technical Support iPad App
11-21-2012 05:41 AM
i am not using voice at this site. here is how the port is configured and what i am seeing. i guess what i don't understand is why i am seeing dscp values other than 46 and cos values other than 5 ?
interface FastEthernet0/26
switchport access vlan 96
switchport mode access
switchport voice vlan 450
power inline consumption 9000
srr-queue bandwidth share 10 20 1 69
priority-queue out
mls qos cos 5
mls qos cos override
spanning-tree portfast
end
boa-12idf-cs356048ps-1#sh mls qos maps dscp-cos
Load for five secs: 7%/0%; one minute: 8%; five minutes: 8%
Time source is NTP, 06:38:48.492 arizona Wed Nov 21 2012
Dscp-cos map:
d1 : d2 0 1 2 3 4 5 6 7 8 9
---------------------------------------
0 : 00 00 00 00 00 00 00 00 01 01
1 : 01 01 01 01 01 01 02 02 02 02
2 : 02 02 02 02 03 03 03 03 03 03
3 : 03 03 04 04 04 04 04 04 04 04
4 : 05 05 05 05 05 05 05 05 06 06
5 : 06 06 06 06 06 06 07 07 07 07
6 : 07 07 07 07
boa-12idf-cs356048ps-1#sh mls qos maps cos-d
boa-12idf-cs356048ps-1#sh mls qos maps cos-dscp
Load for five secs: 8%/0%; one minute: 8%; five minutes: 8%
Time source is NTP, 06:38:54.901 arizona Wed Nov 21 2012
Cos-dscp map:
cos: 0 1 2 3 4 5 6 7
--------------------------------
dscp: 0 8 16 26 32 46 48 56
boa-12idf-cs356048ps-1#
boa-12idf-cs356048ps-1#sh mls qos int fa0/26 statistics
Load for five secs: 6%/0%; one minute: 8%; five minutes: 9%
Time source is NTP, 06:39:23.590 arizona Wed Nov 21 2012
FastEthernet0/26 (All statistics are in packets)
dscp: incoming
-------------------------------
0 - 4 : 70630 0 0 0 0
5 - 9 : 0 0 0 0 0
10 - 14 : 0 0 0 0 0
15 - 19 : 0 0 0 0 0
20 - 24 : 0 0 0 0 0
25 - 29 : 0 0 0 0 0
30 - 34 : 0 0 0 0 0
35 - 39 : 0 0 0 0 0
40 - 44 : 0 0 0 0 0
45 - 49 : 0 0 0 0 0
50 - 54 : 0 0 0 0 0
55 - 59 : 0 0 0 0 0
60 - 64 : 0 0 0 0
dscp: outgoing
-------------------------------
0 - 4 : 191110 0 0 0 12
5 - 9 : 0 0 0 6445 0
10 - 14 : 0 0 0 0 0
15 - 19 : 0 0 0 0 0
20 - 24 : 0 0 0 0 0
25 - 29 : 0 0 0 0 0
30 - 34 : 0 0 0 0 0
35 - 39 : 0 0 0 0 0
40 - 44 : 0 0 0 0 0
45 - 49 : 0 1 0 28824 0
50 - 54 : 0 0 0 0 0
55 - 59 : 0 0 0 0 0
60 - 64 : 0 0 0 0
cos: incoming
-------------------------------
0 - 4 : 0 0 0 0 0
5 - 7 : 70823 0 0
cos: outgoing
-------------------------------
0 - 4 : 267515 6445 0 0 0
5 - 7 : 82941 28824 0
output queues enqueued:
queue: threshold1 threshold2 threshold3
-----------------------------------------------
queue 0: 0 0 83209
queue 1: 28826 584 73873
queue 2: 0 0 0
queue 3: 0 0 273642
output queues dropped:
queue: threshold1 threshold2 threshold3
-----------------------------------------------
queue 0: 0 0 0
queue 1: 0 0 0
queue 2: 0 0 0
queue 3: 0 0 0
Policer: Inprofile: 0 OutofProfile: 0
boa-12idf-cs356048ps-1#
11-21-2012 05:44 AM
i know you see the switchport voice vlan command but this is a test switch in our test network and not the site we will be deploying the qos change on. so there is no voice at the remote site.
11-21-2012 02:10 PM
What you're seeing is what I would expect. When you enable 'mls qos' by the default you're not trusting dscp and re-writing the dscp to 0, so this is why you're seeing all incoming dscp values as 0. The outgoing dscp values just depend on what values are going out the interface, coming from elsewhere in the network. You can see all incoming cos values are going in to the correct queue, there may be other values present if you haven't cleared the counters?
Sent from Cisco Technical Support iPad App
11-23-2012 05:20 AM
got it, thanks for all your help. it's greatly appreciated.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide