cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1330
Views
1
Helpful
11
Replies

Connecting 2 switchtes

avilt
Level 3
Level 3

Sorry for the basic question, we have bought two new Catalyst 2950 switches and to uplink them I used the cross-over cable.

It was not working so I changed it to straight cables which works fine. Is it a normal behaviour. As per my knowledge, to connect 2 similar devices we have to use cross-over cables.

Thank You.

3 Accepted Solutions

Accepted Solutions

Sure it can.  2960/2960S switch ports are MDI/MDI-X.

View solution in original post

Yes that is absolutly normal, because both switches support the autonegotiation. If you want to learn more about the behaviour look here:

http://en.wikipedia.org/wiki/Medium_dependent_interface

greets Martin

View solution in original post

Oh nuts.  I'm sooooooooooooooo sorry.

The correct command is "sh interface transceiver properties".

Switch#sh int g 2/0/48 trans properties
Diagnostic Monitoring is not implemented.
Name : Gi2/0/48
Administrative Speed: auto
Administrative Duplex: auto
Administrative Auto-MDIX: on
Administrative Power Inline: N/A
Operational Speed: auto
Operational Duplex: auto
Operational Auto-MDIX: on
Media Type: 10/100/1000BaseTX

One more thing:  Do NOT configure speed and duplex setting (leave them in "auto" or default) for MDI/MDI-X to work.

View solution in original post

11 Replies 11

Leo Laohoo
Hall of Fame
Hall of Fame

2950 do not support MDI/MDI-X so you should use cross-over.

1.  Maybe the 2nd switch is not a 2950 but a newer model.  Perhaps a 2960.

2.  Maybe it's not a straight-through cable.  If you connect the same cable from the switch to a PC or laptop will the link go up?

Sorry, both are Catalyst 2960-S models. One is 24 port and the other one is 48 port.

It works fine with straight cables. Is it a normal behaviour?

Sure it can.  2960/2960S switch ports are MDI/MDI-X.

Yes that is absolutly normal, because both switches support the autonegotiation. If you want to learn more about the behaviour look here:

http://en.wikipedia.org/wiki/Medium_dependent_interface

greets Martin

How can verify this capability on the switch and why the cross-over cable should not work?

How can verify this capability on the switch

use the command "sh interface cap".

why the cross-over cable should not work?

Cross-over or straight-through doesn't matter because the switch supports MDI/MDI-X.

From the following output, how can I verify MDI/MDI-X capability?

SW-24#show interfaces gigabitEthernet 1/0/1 capabilities
GigabitEthernet1/0/1
  Model:                 WS-C2960S-24TS-L
  Type:                  10/100/1000BaseTX
  Speed:                 10,100,1000,auto
  Duplex:                half,full,auto
  Trunk encap. type:     802.1Q
  Trunk mode:            on,off,desirable,nonegotiate
  Channel:               yes
  Broadcast suppression: percentage(0-100)
  Flowcontrol:           rx-(off,on,desired),tx-(none)
  Fast Start:            yes
  QoS scheduling:        rx-(not configurable on per port basis),
                                  tx-(4q3t) (3t: Two configurable values and one fixed.)
  CoS rewrite:           yes
  ToS rewrite:           yes
  UDLD:                  yes
  Inline power:          no
  SPAN:                  source/destination
  PortSecure:            yes
  Dot1x:                 yes
SW-24#

Oh nuts.  I'm sooooooooooooooo sorry.

The correct command is "sh interface transceiver properties".

Switch#sh int g 2/0/48 trans properties
Diagnostic Monitoring is not implemented.
Name : Gi2/0/48
Administrative Speed: auto
Administrative Duplex: auto
Administrative Auto-MDIX: on
Administrative Power Inline: N/A
Operational Speed: auto
Operational Duplex: auto
Operational Auto-MDIX: on
Media Type: 10/100/1000BaseTX

One more thing:  Do NOT configure speed and duplex setting (leave them in "auto" or default) for MDI/MDI-X to work.

Alright,

What is the command to disable MDI/MDI-X feature on the interface if at all possible.

What is the command to disable MDI/MDI-X feature on the interface if at all possible.

For obvious reasons, the command "no mdix auto" will disable MDI/MDI-X of an interface.  There is, in my experience, no global command available.

Leo Laohoo
Hall of Fame
Hall of Fame

Wow!  Someone gave me a 1 star for making the right assumption!

Review Cisco Networking for a $25 gift card