05-17-2013 11:10 AM - edited 03-07-2019 01:25 PM
Hi,
I have recently been task with migrating our server room to a different site. Site A which is the old site will be connected to Site B with a 100 meg metro Ethernet connection. From my understanding this is just like extending your LAN. Site B has a connection to our MPLS cloud to other sites. Site A has a 3750x switch as the core router/switch it is the default gateway for all servers and client machines. Site B will also have a 3750X. The problem I am seeing with this setup, is that if the metro Ethernet link goes down, then the servers that are in site B will lose their default gateway which is the switch in Site A. So other clients in other sites will not be able to communicate with servers in Site B. So I have a couple of questions. 1. Can you setup two layer 3 switches and still pass vlan information between the two. Example, lets say the metro e connection is connected on port 48 on both sides. Then in Site B I want to create another vlan and have the switch become a router for that vlan can this be done?
2. I read that you could just make the ports connecting the 2 sites as interface ports and be on a separate network. But my vendor seems to think this will not work because it is a metro Ethernet. Does anyone know if this is true.
Solved! Go to Solution.
05-17-2013 12:02 PM
Example Config:
------Switch A Config-----
vlan 2
name servers
vlan 3
name mgmt
vlan 4
name engineering
int vlan 2
ip address 10.2.1.2 255.255.255.0
standby 1 ip 10.2.1.1
standby 1 pri 110
standby 1 pree
int vlan 3
ip addres 10.3.1.2 255.255.255.0
standby 1 ip 10.3.1.1
standby 1 pri 110
standby 1 pree
int vlan 4
ip address 10.4.1.2 255.255.255.0
standby 1 ip 10.4.1.1
standby 1 pri 110
standby 1 pree
int giga 1/0/1
des (Link to Site B)
switchport
switchport trunk encap dot
switchport mode trunk
--------Site B switch---------
vlan 2
name servers
vlan 3
name mgmt
vlan 4
name engineering
int vlan 2
ip address 10.2.1.3 255.255.255.0
standby 1 ip 10.2.1.1
standby 1 pri 90
standby 1 pree
int vlan 3
ip address 10.3.1.3 255.255.255.0
standby 1 ip 10.3.1.1
standby 1 pri 90
standby 1 pree
int vlan 4
ip address 10.4.1.3 255.255.255.0
standby 1 ip 10.4.1.1
standby 1 pri 90
standby 1 pree
int giga 1/0/1
des (Link to Site A)
switchport
sw tr encap dot
sw mode trunk
Servers's default gateway would be 10.2.1.1 or 10.3.1.1 or 10.4.1.1 etc
By default 10.2.1.1 would be ACTIVE at Site A
If the link fails Site B would be come ACTIVE
05-17-2013 11:33 AM
You will have to connect the 2 switches via a Trunk link.
You then need to configure all VLANS at Site b that are at Site A
You then need to turn on HSRP for all VLANS with Site A being active. Your HSRP virtual ip address will need to be what your current default gatway address is. For instance.
Int vlan 1
ip address 10.1.1.1
would need to change to
Int vlan 1
ip address 10.1.1.2
standby 1 ip 10.1.1.1
If the link goes down Site B will take over the default gateway role.
05-17-2013 11:45 AM
Thanks for you replay. So when you say configure all vlans at Site B that are at Site A, wouldn't the vlans already be configured on the switch in site B since they are trunked? Or do you mean you have to configure the vlan interfaces on both?
05-17-2013 11:38 AM
Hi,
What you are trying to is basically have a vlan/subnet in each location. That is very much possible, but you would need to talk to your ISP to change your connection in both locations from layer-2 to layer-3. That would give each side its own vlan/subnet and if you loose the WAN connection, you only loose the remote side and not the local.
HTH
05-17-2013 11:43 AM
Thanks for you reply. Yes i know that is an option, but the cost becomes a factor. It is much more for layer 3 connection, then the layer 2.
05-17-2013 11:49 AM
Will the WAN link pass dot1q frames? Or is it strickly layer 3?
05-17-2013 11:50 AM
It is strictly a layer 2 link. So yes Vlan info will pass.
05-17-2013 11:52 AM
Copy the config of Switch A please
05-17-2013 11:54 AM
I don't have this setup yet. I am just pre planning at this time.
05-17-2013 12:02 PM
Example Config:
------Switch A Config-----
vlan 2
name servers
vlan 3
name mgmt
vlan 4
name engineering
int vlan 2
ip address 10.2.1.2 255.255.255.0
standby 1 ip 10.2.1.1
standby 1 pri 110
standby 1 pree
int vlan 3
ip addres 10.3.1.2 255.255.255.0
standby 1 ip 10.3.1.1
standby 1 pri 110
standby 1 pree
int vlan 4
ip address 10.4.1.2 255.255.255.0
standby 1 ip 10.4.1.1
standby 1 pri 110
standby 1 pree
int giga 1/0/1
des (Link to Site B)
switchport
switchport trunk encap dot
switchport mode trunk
--------Site B switch---------
vlan 2
name servers
vlan 3
name mgmt
vlan 4
name engineering
int vlan 2
ip address 10.2.1.3 255.255.255.0
standby 1 ip 10.2.1.1
standby 1 pri 90
standby 1 pree
int vlan 3
ip address 10.3.1.3 255.255.255.0
standby 1 ip 10.3.1.1
standby 1 pri 90
standby 1 pree
int vlan 4
ip address 10.4.1.3 255.255.255.0
standby 1 ip 10.4.1.1
standby 1 pri 90
standby 1 pree
int giga 1/0/1
des (Link to Site A)
switchport
sw tr encap dot
sw mode trunk
Servers's default gateway would be 10.2.1.1 or 10.3.1.1 or 10.4.1.1 etc
By default 10.2.1.1 would be ACTIVE at Site A
If the link fails Site B would be come ACTIVE
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide