cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2098
Views
0
Helpful
5
Replies
Highlighted
Beginner

copy scp not working on Cisco Switch WS-C3850-24P

Recently i need to migrate our windows 2008 server that installed with ssh tectia.

All my laptop and checkpoint firewall were able to sftp to the new server successfully.

 

However, for cisco switch we have, i have tried several different devices but the copy scp wont work.

 

I tried to get file from sftp server to switch and vice versa.

copy flash: scp://XXX.XX.28.65:10022

copy scp://XXX.XX.29.49:10022 flash:

 

All will resulted in error below:

%Error writing scp://*****@XXX.XX.29.49:10022/test.txt (Undefined error)

 

I have tried to insert all parameter in 1 line (username, pwd) but still not working.

I also tried to insert the full file path and it also prompt me with undefined error.

 

Any idea what can i check further?

 

5 REPLIES 5
Highlighted
VIP Expert

Hello,

 

what SCP software are you using (Putty is good option) ? 

 

Did you generate the rsa key on your switch ?

 

Check the link below:

 

https://blog.pierky.com/cisco-ios-configuration-management-using-scp-and-pscp/ 

Highlighted

I'm using SSH Tectia in the server.

I read the guide you posted earlier and seem like that not configured on the switch.

However the scp was working fine on the old server even without the mentioned config.

 

As a workaround, i tried the method suggested by enable the ip scp on the switch but seem like it still not working.

From the event log in the windows server, the scp traffic not even reaching the server as the log didnt captured any traffic.

 

Is there any other configuration apart from this ip scp server that required on Cisco devices?

Highlighted

I do a trace route to the next hop of the new server.

I encounter error:

exec request failed on channel 0
lost connection

 

Is this something i should check on the switch or server side?

Same like previous, the server log didnt captured any traffic.

 

copy scp://xxx.xxx.29.49:10022 bootflash:
Enter source filename: test1.txt
Enter vrf (If no input, current vrf 'default' is considered):
Enter username: user
The authenticity of host 'xxx.xxx.29.49 (xxx.xxx.29.49)' can't be established.
RSA key fingerprint is SHA1:xx:xx:xx:xx:xxx:xxx
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added 'xxx.xx.29.49' (RSA) to the list of known hosts.
user@xxx.xxx.29.49's password:
exec request failed on channel 0

 

copy bootflash: scp://xxx.xxx.29.49:10022
Enter source filename: xxx.log
Enter vrf (If no input, current vrf 'default' is considered):
Enter username: user
user@xxx.xxx.29.49's password:
exec request failed on channel 0
lost connection

 

Highlighted

Hello,

 

can you check the thread below ? Not sure if that is applicable in your case...

 

https://superuser.com/questions/240907/scp-exec-request-failed-on-channel-0

Highlighted
Beginner

I know this is an older thread, but I figured others will experience this issue and this may help.  Try adding vrf Mgmt-vrf to the end of the command.  

Content for Community-Ad