cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

DHCP across Trunk

Gateway Church
Enthusiast
Enthusiast

I am plugging a device into FastEthernet 1/0/22.  I cannot get DHCP across the trunk.  Config is at link.  Any ideas? 

https://www.dropbox.com/s/gsyai3e94s170hv/FRS.rtf

17 REPLIES 17

Gateway Church
Enthusiast
Enthusiast

More details: device is a lightweight AP that is configured for HREAP local routing.  Vlan support is enabled.  Natve vlan is 80.  No other vlan is specified.  I did have this setup prior with multiple vlans at play but tried to simplify it to troubleshoot. The interface on the AP has been configured entirely by the controller; however, I did ssh into it and verify that it was setup correctly with the proper encapsulation. 

The gateway and dhcp pool are on the same switch as the trunk.  This is what is throwing me. 

Also, when SSHed into the AP the switch shows up as a CDP neighbor but the AP does not show up as a neighbor to the switch. 

Switch - Show Version

Switch Ports Model              SW Version            SW Image                

------ ----- -----              ----------            ----------              

*    1 26    WS-C3750-24P       12.2(55)SE6           C3750-IPSERVICESK9-M  

AP -

Product/Model Number                 : AIR-LAP1242AG-A-K9

Hello Josh.

I couldn't open the link for some reason... I got error web site not available for some reason...

Anyways.. I wonder if:

- Is the device connected to FA1/0/22 the AP?

- Is the int FA1/0/22 configured as a trunk?

- What if you connect a PC into FA1/0/22? is it getting an dinamyc IP address in vlan 80? if so the wired network is working fine and you have isolated the problem to be with the wireless connection, if the PC wired connected to int FA1/0/22 is still not able to get an IP address then the problem most be in the 3750 or behind it..

Try doing those steps to isolate the problem either with the wired or wireless connection to continue with the troubleshooting.

Regards.

Wilson B.

I tried that.  No luck with the connected computer. I did that to troubleshoot at first and landed on the switch being the issue.  The config is at the other side of the link.

https://www.dropbox.com/s/gsyai3e94s170hv/FRS.rtf

Exerpts:

ip dhcp excluded-address 10.55.80.0 10.55.80.15

ip dhcp excluded-address 10.55.80.250 10.55.80.255

ip dhcp pool VLAN80

   network 10.55.80.0 255.255.255.0

   default-router 10.55.80.1

   dns-server 10.51.40.58 10.51.40.57

   domain-name gatewaystaff.com

   lease 0 8

vlan 80

interface FastEthernet1/0/22

description WAP FRI-03

switchport trunk encapsulation dot1q

switchport trunk native vlan 80

switchport trunk allowed vlan 80

switchport mode trunk

interface Vlan80

ip address 10.55.80.1 255.255.255.0

I also tried switchport nonegotiate

IF the AP is in FlexConnect/H-REAP is the AP connected to a Trunk port?

Post the output to the command "sh cdp n F1/0/22 det".

It is in H-REAP mode and it works when the port is in access mode; however, not when trunked.  Because of this I can only use a single VLAN; however, I have a guest SSID/VLAN to broadcast.