cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
816
Views
0
Helpful
4
Replies

DHCP failed APIPA is being used

Saraaz
Level 1
Level 1

i keep trying to fix it and I'm not sure where the problem is.

4 Replies 4

Hi

 

   Among others problem, the main problem here is that you have two router between the PC and the DHCP server.  You need to know that as a Layer 3 device, the router will not send the PC broadcast to the DHCP server. 

 So, will not work this way.  Either you simplefy your topology, or you need to do a lot of configuration in order to work.

Martin L
VIP
VIP

First of all ping router to router fails. then we can move to dhcp issue.

Ping Router1 to  NAT router fails because of you are using switching module to gain more ports (not sure if it's intentional or not);  Two ways to fix it; remove switching module and use gig port instead.  2nd one, if u use switching module, all ports are connecting to SVI, so IP of that SVI , (in your case vlan 50) should be assigned to interface vlan 50 (i see vlan 1 only in shutdown).  SVI does routing for all ports that belong to that vlan (assigned via module)

Then your  static route issue should be solved; Use  show  ip ro 192.168.10.1 to see that issue is solved. 

If you have a router between DHCP server and PCs you will need an ip helper address on interface so that B-cast are forwarded to server.  (#ip helper-address x.x.x.x)

here is partial solution:

interface Vlan50

no shut

ip address 192.168.50.2 255.255.255.0

router 1

interface GigabitEthernet0/0/1

ip address 192.168.10.1 255.255.255.0

ip helper-address 192.168.40.10

 

Regards, ML
**Please Rate All Helpful Responses **

Hello

The interfaces connecting to Rtr 1 and rtr2 are physically incorrect, as such the ip addressing isnt working, once you have corrected that you should be fine.


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Hello,

 

make the changes marked in bold. Also, the wireless laptops did not work because you need to install the wireless modules. I added the modules as well. Currently, there is no wireless authentication, you might want to configure that for good practice (WPA2 is recommended). I attached the revised file (saved in PT version 8.1.1, make sure you have that version installed.

 

Router1#sh run
Building configuration...

Current configuration : 1410 bytes
!
version 15.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router1
!
--> ip cef
no ipv6 cef
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0/0
ip address 192.168.50.1 255.255.255.252
duplex auto
speed auto
!
interface GigabitEthernet0/0/1
ip address 192.168.10.1 255.255.255.0
--> ip helper-address 192.168.40.10
duplex auto
speed auto
!
interface GigabitEthernet0/0/2
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/1/0
switchport mode access
switchport nonegotiate
!
interface GigabitEthernet0/1/1
switchport mode access
switchport nonegotiate
!
interface GigabitEthernet0/1/2
switchport mode access
switchport nonegotiate
!
interface GigabitEthernet0/1/3
switchport mode access
switchport nonegotiate
!
interface GigabitEthernet0/2/0
switchport mode access
switchport nonegotiate
!
interface GigabitEthernet0/2/1
switchport mode access
switchport nonegotiate
!
interface GigabitEthernet0/2/2
switchport mode access
switchport nonegotiate
!
interface GigabitEthernet0/2/3
switchport mode access
switchport nonegotiate
!
interface Vlan1
no ip address
shutdown
!
--> no router rip
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.50.2
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end

 

Router_NAT#sh run
Building configuration...

Current configuration : 1763 bytes
!
version 15.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router_NAT
!
no ip cef
no ipv6 cef
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0/0
ip address 192.168.100.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/0/1
ip address 192.168.40.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/0/2
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/1/0
switchport mode access
switchport nonegotiate
!
interface GigabitEthernet0/1/1
switchport access vlan 50
switchport mode access
switchport nonegotiate
!
interface GigabitEthernet0/1/2
switchport mode access
switchport nonegotiate
!
interface GigabitEthernet0/1/3
switchport mode access
switchport nonegotiate
!
interface GigabitEthernet0/2/0
switchport access vlan 60
switchport mode access
switchport nonegotiate
!
interface GigabitEthernet0/2/1
switchport mode access
switchport nonegotiate
!
interface GigabitEthernet0/2/2
switchport mode access
switchport nonegotiate
!
interface GigabitEthernet0/2/3
switchport mode access
switchport nonegotiate
!
interface Vlan1
no ip address
shutdown
!
--> interface Vlan50
mac-address 0002.17b5.1401
ip address 192.168.50.2 255.255.255.252
!
--> interface Vlan60
mac-address 0002.17b5.1402
ip address 192.168.60.2 255.255.255.252
!
--> no router rip
!
ip classless
ip route 192.168.10.0 255.255.255.0 192.168.50.1
ip route 192.168.20.0 255.255.255.0 192.168.60.1
ip route 192.168.30.0 255.255.255.0 192.168.60.1
ip route 0.0.0.0 0.0.0.0 192.168.100.2
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end

 

Router2#sh run
Building configuration...

Current configuration : 1437 bytes
!
version 15.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router2
!
ip cef
no ipv6 cef
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0/0
ip address 192.168.30.1 255.255.255.0
--> ip helper-address 192.168.40.10
duplex auto
speed auto
!
interface GigabitEthernet0/0/1
ip address 192.168.60.1 255.255.255.252
duplex auto
speed auto
!
interface GigabitEthernet0/0/2
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/1/0
switchport access vlan 10
switchport mode access
switchport nonegotiate
!
interface GigabitEthernet0/1/1
switchport mode access
switchport nonegotiate
!
interface GigabitEthernet0/1/2
switchport mode access
switchport nonegotiate
!
interface GigabitEthernet0/1/3
switchport mode access
switchport nonegotiate
!
interface GigabitEthernet0/2/0
switchport mode access
switchport nonegotiate
!
interface GigabitEthernet0/2/1
switchport mode access
switchport nonegotiate
!
interface GigabitEthernet0/2/2
switchport mode access
switchport nonegotiate
!
interface GigabitEthernet0/2/3
switchport mode access
switchport nonegotiate
!
interface Vlan1
no ip address
shutdown
!
--> no router rip
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.60.2
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end

Review Cisco Networking for a $25 gift card