cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
374
Views
10
Helpful
7
Replies
Highlighted
Beginner

DHCP on L3 switch not working

Hi,

 

Trying to setup a L3 switch with DHCP server running and handing out addresses on all ports.

I have a very simple PT file with PC connected to 3650 in GigEth1/0/1, pool configured.

Still doesn't work... Please help me find the problem.

Attached is the PT file.

 

Thanks!

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Hello,

 

here is one way to make it work:

 

ip routing
!
ip dhcp excluded-address 192.168.10.1
!
ip dhcp pool LAN
network 192.168.10.0 255.255.255.0
default-router 192.168.10.1
!
ip cef
no ipv6 cef
!
interface GigabitEthernet1/0/1
switchport access vlan 10
switchport mode access
switchport nonegotiate
!
interface Vlan10
mac-address 00d0.ff3e.7301
ip address 192.168.10.1 255.255.255.0

View solution in original post

7 REPLIES 7
Highlighted
VIP Expert

What is the password for the L3 switch ?

Highlighted

The password is aderet

Highlighted

Hello,

 

here is one way to make it work:

 

ip routing
!
ip dhcp excluded-address 192.168.10.1
!
ip dhcp pool LAN
network 192.168.10.0 255.255.255.0
default-router 192.168.10.1
!
ip cef
no ipv6 cef
!
interface GigabitEthernet1/0/1
switchport access vlan 10
switchport mode access
switchport nonegotiate
!
interface Vlan10
mac-address 00d0.ff3e.7301
ip address 192.168.10.1 255.255.255.0

View solution in original post

Highlighted

Thanks!

will try that on real hardware when I have access to it. 
Would the same and exact syntax work on the 3750 as well? (That’s the model I have in the lab). 

Highlighted

Hello,

 

the syntax on the 3750 is the same.

 

The MAC address on the Vlan interface is something Packet Tracer automatically configures, it is not needed on a real device.

Highlighted

In your case, you need to create a vlan 2 interface:

 

interface Vlan 2

ip address 192.168.1.1 255.255.255.0

 

Attached the working file.

 

 

Highlighted


Another beginner question

why is the need to specify a MAC address when setting up the VLAN? (The last part of the config)

Content for Community-Ad