cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2494
Views
4
Helpful
2
Replies

DHCP on Separate VLANs (2600 Router & 2950)

natedog75
Level 1
Level 1

I am trying to run the 2600 router as a DHCP server for 6 VLANs. I have setup the router and one switch for testing. I have three total switches (all 2950) and two access points (AIR1231G) to setup eventually but would like to make it work on one switch before trying to complicate things further.

If I manually assign an IP address (192.168.2.x) to the PC I can ping every device all the way back to the modem (192.168.7.254) and out to the internet. If I try to get an IP via DHCP I get a private ip (169.254.x.x). DHCP is not working.

I am not sure what step I am missing but I have tried several things and I obviously am missing something. Please help me out with a set of fresh eyes.

My path is as follows:

AT&T DSL MODEM

               v

CISCO 2621 ROUTER

               v

CISCO CATALYST 2950T SWITCH

               v

              PC

Modem is connected to FA 0/1 on the router.

Switch (Port FA 0/1) is connected to FA 0/0 on the router.

I have six sub interfaces/VLANs configured on FA 0/0

192.168.1.x - 192.168.6.x

IP designations are as follows

Modem is on 192.168.7.0 network

Router and switch are on 192.168.1.0 network

PC is on VLAN 2 which is on 192.168.2.0 network

Configs Below vvvvvvv

CISCO 2600 Series ROUTER

Building configuration...

Current configuration : 3891 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname JANDJ_ROUTER1

!

enable secret 5 $1$iuCb$Zhp8zsYIS7y/Sb3UQ1lGW/

!

ip subnet-zero

!

!

ip dhcp excluded-address 192.168.1.1 192.168.1.49

ip dhcp excluded-address 192.168.2.1 192.168.2.49

ip dhcp excluded-address 192.168.3.1 192.168.3.49

ip dhcp excluded-address 192.168.4.1 192.168.4.49

ip dhcp excluded-address 192.168.5.1 192.168.5.49

ip dhcp excluded-address 192.168.6.1 192.168.6.49

!

ip dhcp pool 1

   network 192.168.1.0 255.255.255.0

   default-router 192.168.1.1

   dns-server 208.67.222.222

!

ip dhcp pool 2

   network 192.168.2.0 255.255.255.0

   default-router 192.168.2.1

   dns-server 208.67.222.222

!

ip dhcp pool 3

   network 192.168.3.0 255.255.255.0

   default-router 192.168.3.1

   dns-server 208.67.222.222

!

ip dhcp pool 4

   network 192.168.4.0 255.255.255.0

   default-router 192.168.4.1

   dns-server 208.67.222.222

!

ip dhcp pool 5

   network 192.168.5.0 255.255.255.0

   default-router 192.168.5.1

   dns-server 208.67.222.222

!

ip dhcp pool 6

   network 192.168.6.0 255.255.255.0

   default-router 192.168.6.1

   dns-server 208.67.222.222

!

!

!

!

interface FastEthernet0/0

description Connection to JANDJ_HOME1

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.1

encapsulation dot1Q 1 native

ip address 192.168.1.1 255.255.255.0

ip access-group 1 in

no ip redirects

ip nat inside

!

interface FastEthernet0/0.2

encapsulation dot1Q 2

ip address 192.168.2.1 255.255.255.0

ip access-group 2 in

no ip redirects

ip nat inside

!

interface FastEthernet0/0.3

encapsulation dot1Q 3

ip address 192.168.3.1 255.255.255.0

ip access-group 3 in

no ip redirects

ip nat inside

!

interface FastEthernet0/0.4

encapsulation dot1Q 4

ip address 192.168.4.1 255.255.255.0

ip access-group 4 in

no ip redirects

ip nat inside

!

interface FastEthernet0/0.5

encapsulation dot1Q 5

ip address 192.168.5.1 255.255.255.0

ip access-group 5 in

no ip redirects

ip nat inside

!

interface FastEthernet0/0.6

encapsulation dot1Q 6

ip address 192.168.6.1 255.255.255.0

ip access-group 6 in

no ip redirects

ip nat inside

!

interface Serial0/0

no ip address

shutdown

!

interface FastEthernet0/1

ip address 192.168.7.1 255.255.255.0

ip nat outside

duplex auto

speed auto

!

ip nat inside source list 1 interface FastEthernet0/1 overload

ip nat inside source list 2 interface FastEthernet0/0.2 overload

ip nat inside source list 3 interface FastEthernet0/0.3 overload

ip nat inside source list 4 interface FastEthernet0/0.4 overload

ip nat inside source list 5 interface FastEthernet0/0.5 overload

ip nat inside source list 6 interface FastEthernet0/0.6 overload

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.7.254

ip http server

ip pim bidir-enable

!

access-list 1 permit 192.168.1.0 0.0.0.255

access-list 1 permit 192.168.2.0 0.0.0.255

access-list 1 permit 192.168.3.0 0.0.0.255

access-list 1 permit 192.168.4.0 0.0.0.255

access-list 1 permit 192.168.5.0 0.0.0.255

access-list 1 permit 192.168.6.0 0.0.0.255

access-list 1 permit 192.168.7.0 0.0.0.255

access-list 2 permit 192.168.2.0 0.0.0.255

access-list 2 permit 192.168.1.0 0.0.0.255

access-list 2 permit 192.168.7.0 0.0.0.255

access-list 3 permit 192.168.3.0 0.0.0.255

access-list 3 permit 192.168.1.0 0.0.0.255

access-list 3 permit 192.168.7.0 0.0.0.255

access-list 4 permit 192.168.4.0 0.0.0.255

access-list 4 permit 192.168.1.0 0.0.0.255

access-list 4 permit 192.168.7.0 0.0.0.255

access-list 5 permit 192.168.5.0 0.0.0.255

access-list 5 permit 192.168.1.0 0.0.0.255

access-list 5 permit 192.168.7.0 0.0.0.255

access-list 6 permit 192.168.6.0 0.0.0.255

access-list 6 permit 192.168.1.0 0.0.0.255

access-list 6 permit 192.168.7.0 0.0.0.255

!

line con 0

password 7 0539030834406E1D49174744

login

line aux 0

line vty 0 4

password 7 113B1C02021E2B1854387B72

login

!

end

CISCO CATALYST 2950T SWITCH

Current configuration : 3087 bytes

!

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname SWITCH_HOME_1

!

enable secret 5 $1$51zQ$D/I6MxxoOk3zHeQsYAT400

!

ip subnet-zero

!

!

spanning-tree mode pvst

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

!

!

!

!

00:02:39: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed state to up

interface FastEthernet0/1

switchport mode trunk

!

interface FastEthernet0/2

switchport mode trunk

!

interface FastEthernet0/3

switchport access vlan 2

switchport mode access

spanning-tree portfast

!

interface FastEthernet0/4

switchport access vlan 999

switchport mode access

shutdown

!

interface FastEthernet0/5

switchport access vlan 999

switchport mode access

shutdown

!

interface FastEthernet0/6

switchport access vlan 999

switchport mode access

shutdown

!

interface FastEthernet0/7

switchport access vlan 999

switchport mode access

shutdown

!

interface FastEthernet0/8

switchport access vlan 999

switchport mode access

shutdown

!

interface FastEthernet0/9

switchport access vlan 999

switchport mode access

shutdown

!

interface FastEthernet0/10

switchport access vlan 999

switchport mode access

shutdown

!

interface FastEthernet0/11

switchport access vlan 999

switchport mode access

shutdown

!

interface FastEthernet0/12

switchport access vlan 999

switchport mode access

shutdown

!

interface FastEthernet0/13

switchport access vlan 999

switchport mode access

shutdown

!

interface FastEthernet0/14

switchport access vlan 999

switchport mode access

shutdown

!

interface FastEthernet0/15

switchport access vlan 999

switchport mode access

shutdown

!

interface FastEthernet0/16

switchport access vlan 999

switchport mode access

shutdown

!

interface FastEthernet0/17

switchport access vlan 999

switchport mode access

shutdown

!

interface FastEthernet0/18

switchport access vlan 999

switchport mode access

shutdown

!

interface FastEthernet0/19

switchport access vlan 999

switchport mode access

shutdown

!

interface FastEthernet0/20

switchport access vlan 999

switchport mode access

shutdown

!

interface FastEthernet0/21

switchport access vlan 999

switchport mode access

shutdown

!

interface FastEthernet0/22

switchport access vlan 999

switchport mode access

shutdown

!

interface FastEthernet0/23

switchport access vlan 999

switchport mode access

shutdown

!

interface FastEthernet0/24

switchport access vlan 999

switchport mode access

shutdown

!

interface GigabitEthernet0/1

description LINK_TO_OFFICE1

switchport mode trunk

!

interface GigabitEthernet0/2

description LINK_TO_SHOP1

switchport mode trunk

!

interface Vlan1

ip address 192.168.1.3 255.255.255.0

ip helper-address 192.168.1.1

no ip route-cache

!

interface Vlan2

ip address 192.168.2.2 255.255.255.0

no ip route-cache

shutdown

!

ip http server

banner login ^C

W A R N I N G

Authorized users only. Violators will be prosecuted. ^C

!

line con 0

password 7 0036160111572B125F331C18

logging synchronous

login

line vty 0 4

password 7 0036160111572B125F331C18

login

line vty 5 15

password 7 113B1C02021E2B1854387B72

login

!

!

end

1 Accepted Solution

Accepted Solutions

cadet alain
VIP Alumni
VIP Alumni

Hi,

the problem is with your ACLs on the f0/0.x subinterfaces because they are dropping the DHCP Discover messages with a source IP of 0.0.0.0 and also why are you natting on your inside subinterfaces ?

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

View solution in original post

2 Replies 2

Hello

Router

conf t

service dhcp

Switch

1) no need for the SVI 2 on the 2950 as the router is performing inter-vlan routing

2) Have you created the L2 vlans on the 2950 switch

conf t

vlan 2,999

exit

3) Is vtp correct so it can be propergated to the other switches.

4) Give the switch a defaut-gateway - 192.168.1.1

res

Paul

Please don't forget to rate any posts that have been helpful.

Thanks.


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

cadet alain
VIP Alumni
VIP Alumni

Hi,

the problem is with your ACLs on the f0/0.x subinterfaces because they are dropping the DHCP Discover messages with a source IP of 0.0.0.0 and also why are you natting on your inside subinterfaces ?

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
Review Cisco Networking for a $25 gift card