01-06-2012 01:43 PM - edited 03-07-2019 04:12 AM
My actual Scenario
1 x 4500 and 1 x 3560
They are gateways of 8 Vlans
They are doing HSRP in each of those Vlans
The 4500 is the Active
There is a DHCP Pool for each of those Vlans on both gateways
Using "ip dhcp excluded-address" I ensured that the range of provided ips by each DHCP server will not be overlapped
Obs.: Reducing the lease time, I ended with the calls bringing related problems.
OK, every thing is blue, every thing is fine.
But the network diagram is realy complex(41 switchs, 89 uplinks), and depending of how is the network flow, one or other server answer first or latter.
For many reasons I would like that the secondary DHCP server would answer only if the primary DHCP server goes down.
To me, the bigger reason is that DHCP database would be only in one DHCP server.
But there is other reasons.
I passed by many frustrated solutions:
Try to force a delay on the answer on one of the servers. - Impossible.
Try to disable DHCP server, and, using EEM, enable it only if router became active in HSRP. - I couldn't do It.
What I'm thinking now is use the HSRP resource to resolve it.
On both routers I would put a "ip helper-address" pointing to an Virtual_HSRP_IP.
And depending on which router is the active, him will answer the request.
My first doubt is:
Would it work?
The second doubt is:
Could I use the same Virtual_HSRP_IP that exists on that Vlan(see example 1),
or I would need to point it to a Virtual_HSRP_IP in a different Vlan(see example 2)?
Example 1
-----------------------------------
| 4500 |
-----------------------------------
interface Vlan1
ip address 10.10.0.2 255.255.0.0
ip helper-address 10.10.0.1
standby 1 ip 10.10.0.1
standby 1 priority 110
standby 1 preempt
standby 1 track 10 decrement 30
ip dhcp pool VLAN1
network 10.10.0.0 255.255.0.0
default-router 10.10.0.1
domain-name anything.com
dns-server 8.8.8.8
lease 0 1
-----------------------------------
| 3560 |
-----------------------------------
interface Vlan1
ip address 10.10.0.3 255.255.0.0
ip helper-address 10.10.0.1
standby 1 ip 10.10.0.1
standby 1 priority 90
standby 1 preempt
standby 1 track 10 decrement 30
ip dhcp pool VLAN1
network 10.10.0.0 255.255.0.0
default-router 10.10.0.1
domain-name anything.com
dns-server 8.8.8.8
lease 0 1
Example 2
-----------------------------------
| 4500 |
-----------------------------------
interface Vlan1
ip address 10.10.0.2 255.255.0.0
ip helper-address 10.99.0.1
standby 1 ip 10.10.0.1
standby 1 priority 110
standby 1 preempt
standby 1 track 10 decrement 30
interface Vlan99
ip address 10.99.0.2 255.255.0.0
standby 1 ip 10.99.0.1
standby 1 priority 110
standby 1 preempt
standby 1 track 10 decrement 30
ip dhcp pool VLAN1
network 10.10.0.0 255.255.0.0
default-router 10.10.0.1
domain-name anything.com
dns-server 8.8.8.8
lease 0 1
-----------------------------------
| 3560 |
-----------------------------------
interface Vlan1
ip address 10.10.0.3 255.255.0.0
ip helper-address 10.99.0.1
standby 1 ip 10.10.0.1
standby 1 priority 90
standby 1 preempt
standby 1 track 10 decrement 30
interface Vlan99
ip address 10.99.0.3 255.255.0.0
standby 1 ip 10.99.0.1
standby 1 priority 110
standby 1 preempt
standby 1 track 10 decrement 30
ip dhcp pool VLAN1
network 10.10.0.0 255.255.0.0
default-router 10.10.0.1
domain-name anything.com
dns-server 8.8.8.8
lease 0 1
01-06-2012 02:15 PM
You cannot use ip helpers when the dhcp server is directly on the switch which is the L3 for the vlans where the requests originate from.
The kind of solution proposed here will likely break dhcp completely.
Best solution is what you have: to stay with a scope per switch, the alternative is to install a dedicated (linux) dhcp server.
Linux is free and runs on virtually everything; it wont cost a fortune.
regards,
Leo
01-07-2012 01:35 PM
Well, I don't know...
Maybe I'm in right direction.
Searching by "Cisco ip helper-address" I found some thing about VGR(Virtual Router Group), that is related to HSRP.
Here is an example that is similar with what I want.
http://www.cisco.com/en/US/docs/ios-xml/ios/ipapp/configuration/12-4t/iap-udp-vrg.html
Tomorrow, depending on my enthusiasm, I will test this config.
01-08-2012 01:14 AM
The only problem is the feature is in 12.4T, your switches are at 12.2...
11-02-2015 12:36 PM
Hi Douglas,
I would believe the solution you suggested with a separate vlan with VRRP/HSRP to be used as the IP address of your DHCP server would work. Did this not work for you?
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide