cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
675
Views
0
Helpful
1
Replies

different OSPF process with same network statements

p oh
Level 1
Level 1

Hi 

I came across a mis-configuration on a router that looks similar to below:

Router A has two different OSPF process declaring the same networks.  OSPF appears to be working.  What kind of network issues will occur with this sort of mis-configuration.   Unless I start redistributing between process 100 and 200, there shouldn't be any noticeable issues on the network?

Router A:

interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 10.0.0.2 255.255.255.252
ip ospf network point-to-point
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
router ospf 200
router-id 2.2.2.2
log-adjacency-changes
network 2.2.2.2 0.0.0.0 area 0
network 10.0.0.0 0.0.0.3 area 0
!
router ospf 100
log-adjacency-changes
network 2.2.2.2 0.0.0.0 area 0
network 10.0.0.0 0.0.0.3 area 0

Router B:

interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 10.0.0.1 255.255.255.252
ip ospf network point-to-point
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
router ospf 100
router-id 1.1.1.1
log-adjacency-changes
network 1.1.1.1 0.0.0.0 area 0
network 10.0.0.0 0.0.0.3 area 0

R1#sh ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
2.2.2.2 0 FULL/ - 00:00:32 10.0.0.2 FastEthernet0/0


R1#sh ip ospf interface bri
Interface PID Area IP Address/Mask Cost State Nbrs F/C
Lo0 100 0 1.1.1.1/32 1 LOOP 0/0
Fa0/0 100 0 10.0.0.1/30 1 P2P 1/1
R1#
R1#
R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

1.0.0.0/32 is subnetted, 1 subnets
C 1.1.1.1 is directly connected, Loopback0
2.0.0.0/32 is subnetted, 1 subnets
O 2.2.2.2 [110/2] via 10.0.0.2, 00:51:21, FastEthernet0/0
10.0.0.0/30 is subnetted, 1 subnets
C 10.0.0.0 is directly connected, FastEthernet0/0


R1#sh ip route ospf 100
2.0.0.0/32 is subnetted, 1 subnets
O 2.2.2.2 [110/2] via 10.0.0.2, 00:51:26, FastEthernet0/0

R1#sh ip route ospf 200

R1#sh ip ospf database

OSPF Router with ID (1.1.1.1) (Process ID 100)

Router Link States (Area 0)

Link ID ADV Router Age Seq# Checksum Link count
1.1.1.1 1.1.1.1 1304 0x80000004 0x004A9E 3
2.2.2.2 2.2.2.2 1163 0x80000004 0x00E7F7 3
R1#


R2#sh ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
1.1.1.1 0 FULL/ - 00:00:30 10.0.0.1 FastEthernet0/0
R2#sh ip ospf int
R2#sh ip ospf interface bri
Interface PID Area IP Address/Mask Cost State Nbrs F/C
Lo0 200 0 2.2.2.2/32 1 LOOP 0/0
Fa0/0 200 0 10.0.0.2/30 1 P2P 1/1
R2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

1.0.0.0/32 is subnetted, 1 subnets
O 1.1.1.1 [110/2] via 10.0.0.1, 00:50:57, FastEthernet0/0
2.0.0.0/32 is subnetted, 1 subnets
C 2.2.2.2 is directly connected, Loopback0
10.0.0.0/30 is subnetted, 1 subnets
C 10.0.0.0 is directly connected, FastEthernet0/0
R2#sh ip route ospf 100

R2#sh ip route ospf 200
1.0.0.0/32 is subnetted, 1 subnets
O 1.1.1.1 [110/2] via 10.0.0.1, 00:51:09, FastEthernet0/0
R2#sh ip ospf da
R2#sh ip ospf database

OSPF Router with ID (10.0.0.2) (Process ID 100)

Router Link States (Area 0)

Link ID ADV Router Age Seq# Checksum Link count
10.0.0.2 10.0.0.2 980 0x80000002 0x009E8B 0

OSPF Router with ID (2.2.2.2) (Process ID 200)

Router Link States (Area 0)

Link ID ADV Router Age Seq# Checksum Link count
1.1.1.1 1.1.1.1 1314 0x80000004 0x004A9E 3
2.2.2.2 2.2.2.2 1171 0x80000004 0x00E7F7 3
R2#

1 Reply 1

Peter Paluch
Cisco Employee
Cisco Employee

Peter,

This configuration is not valid. Two or more processes can not run over a single interface; OSPFv2 packets have no field that would help distinguish between different OSPF process instances and their messages.

What happens is that the first OSPF process that occurs in the configuration starts to own these interfaces, and the second OSPF process will not be allowed to work with them. A quick test is the show ip ospf interface brief command output: Note that on Router A, it would be OSPF process 200 owning the Lo0 and Fa0/0 interfaces. In essence, on Router A, the OSPF process 100 has no interfaces to run over.

Best regards,
Peter

Review Cisco Networking for a $25 gift card