04-11-2015 05:44 AM - edited 03-07-2019 11:30 PM
Hi all,
If i give ISP's DNS when both isp's up , Internet working for end user.But if one isp goes down , that isp's dns configured machine unable to access internet. but if i give 4.2.2.2 or 8.8.8.8 it is working.
How to solve this issue..?
I have Configured like this,
ip name-server 4.2.2.2
ip name-server 8.8.8.8
ip name-server 182.19.95.34
ip name-server 182.19.95.66
ip name-server 218.248.255.146
ip name-server 218.248.255.147
multilink bundle-name authenticated
!
!
!
c
!
!
!
track 1 interface GigabitEthernet0/0 ip routing
delay down 10 up 10
!
track 2 interface GigabitEthernet0/1 ip routing
delay down 10 up 10
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
description "BSNL WAN LINK - 10 Mbps"
ip address 117.239.x.x 255.255.255.252
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface GigabitEthernet0/1
description "VODAFONE WAN LINK - 10 MBps"
ip address 122.15.x.x 255.255.255.252
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface FastEthernet0/0/0
switchport access vlan 100
no ip address
!
interface FastEthernet0/0/1
description "LAM"
switchport access vlan 500
no ip address
!
interface FastEthernet0/0/2
no ip address
!
interface FastEthernet0/0/3
no ip address
!
interface Vlan1
no ip address
!
interface Vlan500
ip address 192.168.23.1 255.255.255.0 secondary
ip address 192.168.24.1 255.255.255.0 secondary
ip address 192.168.25.1 255.255.255.0 secondary
ip address 192.168.18.1 255.255.255.0 secondary
ip address 192.168.19.1 255.255.255.0 secondary
ip address 192.168.20.1 255.255.255.0 secondary
ip address 117.239.x.x 255.255.255.248 secondary
ip address 192.168.22.1 255.255.255.0 secondary
ip address 192.168.21.1 255.255.255.0 secondary
ip address 192.168.27.1 255.255.255.0 secondary
ip address 192.168.28.1 255.255.255.0 secondary
ip address 192.168.29.1 255.255.255.0 secondary
ip address 192.168.30.1 255.255.255.0 secondary
ip address 122.15.x.x 255.255.255.240 secondary
ip address 192.168.26.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
ip forward-protocol nd
!
ip http server
ip http authentication local
ip http secure-server
!
ip nat pool BSNL 117.239.x.x 117.239.x.xnetmask 255.255.255.248
ip nat pool VODAFONE 122.15.x.x 122.15.x.x netmask 255.255.255.240
ip nat inside source route-map BSNL pool BSNL overload
ip nat inside source route-map VODAFONE pool VODAFONE overload
ip route 0.0.0.0 0.0.0.0 117.239.x.x
ip route 0.0.0.0 0.0.0.0 122.15.x.x
ip route 4.2.2.2 255.255.255.255 GigabitEthernet0/1 122.15.x.x
ip route 8.8.8.8 255.255.255.255 GigabitEthernet0/0 117.239.x.x
ip route 218.248.255.146 255.255.255.255 GigabitEthernet0/0 117.239.x.x
ip route 218.248.255.147 255.255.255.255 GigabitEthernet0/0 117.239.x.x
ip route 182.19.35.34 255.255.255.255 GigabitEthernet0/1 122.15.x.x
ip route 182.19.35.66 255.255.255.255 GigabitEthernet0/1 122.15.x.x
!
access-list 100 permit ip 192.168.0.0 0.0.255.255 any
access-list 101 permit ip 192.168.0.0 0.0.255.255 any
!
route-map BSNL permit 10
match ip address 100
match interface GigabitEthernet0/0
!
route-map VODAFONE permit 10
match ip address 100
match interface GigabitEthernet0/1
Thanks.,
Prakalathan.K
04-13-2015 06:55 AM
Hi,
Im not sure Ive really understood where you see a problem but first thing I can guess at is do you have an EEM Script to clear your existing dynamic NAT translations for when the failover occurs?
Also I dont see anything in the static routing config to actually use the tracks that you have configured... after a failover if you do show track do you see that its updated?
04-19-2015 09:30 PM
Hi Chris,
Thanks to reply.the problem is,
1)DNS server of BSNL was reachable, if ISP BSNL is down
2)client with BSNL dns server cannot go online even though BSNL dns server was reachable from client however BSNL ISP was down
same issue with Vodafone ISP
3)if he use the internet DNS server ( like 4.2.2.2 and 8.8.8.8 ) client can browse websites even if Vodafone or BSNL ISP is down
Thanks.,
Prakalathan
04-28-2015 11:59 AM
Hi,
Sorry Ive been away with work just coming back to this now.
Do you mean your client PCs had in their adapter settings configured the DNS server of BSNL? Or are you using another internal DNS server that then forwards out to BSNL on clients behalf?
I'm guessing these are the routes to BSNL DNS Servers:
ip route 218.248.255.146 255.255.255.255 GigabitEthernet0/0 117.239.x.x
ip route 218.248.255.147 255.255.255.255 GigabitEthernet0/0 117.239.x.x
I think this is your issue:
Are you aware you dont have any tracking in the above command? So the static route you set above is going to remain even if BSNL itself is down, which will cause your DNS requests to those IPs to fail.
I think theres a very easy fix which is to use 8.8.8.8 as this is an anycast address or root hints for your forwarders anyway; but let's figure out the problem and fix it anyway as a good learning exercise.
05-03-2015 11:58 PM
Hi Chris,
Thanks for reply.
I checked with ISP side , for some security reasons they are not allowing other ISP's inside with their ISP.
Thanks.,
Prakalathan.K
04-28-2015 12:01 PM
Hi,
Sorry Ive been away with work just coming back to this now.
Do you mean your client PCs had in their adapter settings configured the DNS server of BSNL? Or are you using another internal DNS server that then forwards out to BSNL on clients behalf?
I'm guessing these are the routes to BSNL DNS Servers:
ip route 218.248.255.146 255.255.255.255 GigabitEthernet0/0 117.239.x.x
ip route 218.248.255.147 255.255.255.255 GigabitEthernet0/0 117.239.x.x
I think this is your issue:
Are you aware you dont have any tracking in the above command? So the static route you set above is going to remain even if BSNL itself is down, which will cause your DNS requests to those IPs to fail.
I think theres a very easy fix which is to use 8.8.8.8 as this is an anycast address or root hints for your forwarders anyway; but let's figure out the problem and fix it anyway as a good learning exercise.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide