cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
603
Views
0
Helpful
7
Replies

dual dhcp pools fa 1

jasonbrown23
Level 1
Level 1

why wont my ip phone get the right ip address? is this even going to work like this? i have a 1811 and on fa1 i have a switch set up. i would like to set up an ip phone and have the wifi on my lap top to get a specific ip. im just trying to get the ip phone to work right now and still cant it keeps taking a 192 address

 

ip dhcp pool 1
   import all
   network 192.168.1.0 255.255.255.0
   dns-server 208.67.222.220 65.32.5.111 65.32.5.74 
   default-router 192.168.1.1 
   domain-name BrownTown
   lease 31
!
ip dhcp pool IP-Phone
   host 199.11.28.19 255.255.255.248
   client-identifier 8875.5650.bb76
   default-router 199.11.28.17 
   dns-server 144.230.31.245 144.230.31.117 144.230.30.245 
   option 150 ip 10.246.190.205 10.246.182.205 
   domain-name dhcp.sprint
!


interface FastEthernet1
 description $ETH-LAN$
 ip address 199.11.28.17 255.255.255.248 secondary
 ip address 192.168.1.1 255.255.255.0
 ip access-group in_out out
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nat inside
 ip virtual-reassembly max-reassemblies 1000
 load-interval 30
 duplex auto
 speed auto
!

this pops up in my arp


#   sho arp 
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  192.168.1.12            2   8875.5650.bb76  ARPA   FastEthernet1

 edit update i got it work needed to switch my ip's on the interface 


interface FastEthernet1
 description LAN$$$$
 ip address 192.168.1.1 255.255.255.0 secondary
 ip address 199.11.28.17 255.255.255.248
 ip access-group in_out out
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nat inside
 ip virtual-reassembly max-reassemblies 1000
 load-interval 30
 duplex auto
 speed auto
!

then set up my pools 

 


ip dhcp pool 1
   import all
   network 192.168.1.0 255.255.255.0
   dns-server 208.67.222.220 65.32.5.111 65.32.5.74 
   default-router 192.168.1.1 
   domain-name BrownTown
   lease 31
!
ip dhcp pool IP-Phone
   host 199.11.28.19 255.255.255.248
   client-identifier 0188.7556.50bb.76
   default-router 199.11.28.17 
   dns-server 144.230.31.245 144.230.31.117 144.230.30.245 
   option 150 ip 10.246.190.205 10.246.182.205 
   domain-name dhcp.
!
ip dhcp pool -Laptop
   host 199.11.28.20 255.255.255.248
   client-identifier 01e8.e0b7.cdf3.66
   default-router 199.11.28.17 
   dns-server 144.230.31.245 144.230.31.117 144.230.30.245 
   domain-name dhcp.
!
ip dhcp pool Laptop-wifi
   host 199.11.28.18 255.255.255.248
   client-identifier 01c4.8508.ac82.4e
   default-router 199.11.28.17 
   dns-server 144.230.31.245 144.230.31.117 144.230.30.245 
   domain-name dhcp.

7 Replies 7

Reza Sharifi
Hall of Fame
Hall of Fame

On the router, create 2 sub-interfaces one for voice and one date

example:

interface FastEthernet1

interface FastEthernet1.10

ip address 199.11.28.19 255.255.255.248

encapsulation dot1q 10

 

interface FastEthernet1.20

 ip address 192.168.1.1 255.255.255.0

encapsulation dot1q 20

Also trunk the switch interface that connect to the router with vlan 10 and 20

HTH

 

 

 

 

the switch is a dumb switch can this still work? NETGEAR 8 Port Gigabit Business

Hello

try:

ip dhcp pool IP-Phone
   client-identifier 0188.7556.50bb.76

 

dhcp server:
debug ip dhcp server packet -  (to verfiy mac address of client)

res

Paul
 


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul


5424418: *Jul  2 17:35:48.273 PCTime: DHCPD: DHCPREQUEST received from client 0188.7556.50bb.76.
5424419: *Jul  2 17:35:48.273 PCTime: DHCPD: Appending default domain from pool
5424420: *Jul  2 17:35:48.273 PCTime: DHCPD: Using hostname 'SEP88755650BB76.BrownTown.' for dynamic update (from hostname option)
5424421: *Jul  2 17:35:48.273 PCTime: DHCPD: Sending DHCPACK to client 0188.7556.50bb.76 (192.168.1.12).
5424422: *Jul  2 17:35:48.273 PCTime: DHCPD: broadcasting BOOTREPLY to client 8875.5650.bb76.
5424423: *Jul  2 17:35:55.357 PCTime: DHCPD: DHCPINFORM received from client 0100.1a4d.5734.75 (192.168.1.129).
5424424: *Jul  2 17:35:55.357 PCTime: DHCPD: Sending DHCPACK to client 0100.1a4d.5734.75 (192.168.1.129).
5424425: *Jul  2 17:35:55.357 PCTime: DHCPD: unicasting BOOTREPLY to client 001a.4d57.3475 (192.168.1.129).

 

still not getting the right ip but looks like i can try and mess with this and make it work.

Hello

Try bootp instead:

ip dhcp pool IP-Phone
Hardware address 8875.5650.bb76

res

Paul


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

no its not liking that 


BrownTown(dhcp-config)#Hardware address ?           
  <0-255>   ARP hardware type from "Assigned Numbers" RFC
  ethernet  10Mb Ethernet
  ieee802   IEEE 802 networks
  <cr>

i did get this in 


ip dhcp pool IP-Phone

   host 199.11.28.19 255.255.255.248
   hardware-address 8875.5650.bb76
   default-router 199.11.28.17 
   dns-server 144.230.31.245 144.230.31.117 144.230.30.245 
   option 150 ip 10.246.190.205 10.246.182.205 
   domain-name dhcp.sprint
!

edit 

still the same 


5424490: *Jul  2 18:13:41.185 PCTime: DHCPD: DHCPREQUEST received from client 0188.7556.50bb.76.
5424491: *Jul  2 18:13:41.185 PCTime: DHCPD: Appending default domain from pool
5424492: *Jul  2 18:13:41.185 PCTime: DHCPD: Using hostname 'SEP88755650BB76.BrownTown.' for dynamic update (from hostname option)
5424493: *Jul  2 18:13:41.185 PCTime: DHCPD: Sending DHCPACK to client 0188.7556.50bb.76 (192.168.1.12).
5424494: *Jul  2 18:13:41.185 PCTime: DHCPD: broadcasting BOOTREPLY to client 8875.5650.bb76.

edit edit

tryed removeing my ip pool 1


5424506: *Jul  2 18:16:05.037 PCTime: DHCPD: DHCPINFORM received from client 0100.1a4d.5734.75 (192.168.1.129).
5424507: *Jul  2 18:16:05.037 PCTime: DHCPD: Finding a relay for client 0100.1a4d.5734.75 on interface FastEthernet1.
5424508: *Jul  2 18:16:08.037 PCTime: DHCPD: DHCPINFORM received from client 0100.1a4d.5734.75 (192.168.1.129).
5424509: *Jul  2 18:16:08.037 PCTime: DHCPD: Finding a relay for client 0100.1a4d.5734.75 on interface FastEthernet1.
5424510: *Jul  2 18:16:22.709 PCTime: DHCPD: DHCPREQUEST received from client 0188.7556.50bb.76.
5424511: *Jul  2 18:16:22.709 PCTime: DHCPD: Finding a relay for client 0188.7556.50bb.76 on interface FastEthernet1.
5424512: *Jul  2 18:16:31.885 PCTime: DHCPD: DHCPREQUEST received from client 0188.7556.50bb.76.

Hello

When using secondary addressing DHCP will chose the primary ip address for dhcp and offer address from that primary dhcp pool, There is an option you can use call smart-relay which will poll for an address on from the secondary pool if the primary pool is exhausted.(we actually use this feature on one our trusts cores)

however In your case your have defined a static so DHCP doesn't require a dhcp pool for this, But i am thinking this router will need an active interface on this subnetwork for this static addressing to be allocated  like the suggestion by Resa

 

res

Paul


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card