cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
415
Views
0
Helpful
6
Replies
TariqMK
Beginner

eBGP Multihop Lab Configuration

Hi all,

 

I am building a basic eBGP lab to test out the concept of making 2 non-directly connected neighbours BGP peers.

 

The network the BGP routers will be going 'across' is an OSPF network.

 

The lab is below along with relevant configuration:

2018-05-24_10h42_49.png

OSPF Config:

R4
router ospf 10
network 172.16.0.0 0.0.0.3 area 0
network 172.16.0.8 0.0.0.3 area 0

R5
router ospf 10
network 172.16.0.4 0.0.0.3 area 0
network 172.16.0.8 0.0.0.3 area 0

Unfortunately it doesn't seem to work, does anyone have some idea what I am doing wrong?

 

6 REPLIES 6
Jon Marshall
VIP Community Legend

 

So are you trying to peer across the 172.16.x.x OSPF network ? 

 

What do the routing tables on R4 and R5 look like ie. do they have routes to each others IPs ? 

 

Also R4's neighbor IP cannot be 10.0.0.4  as that is a subnet address in your topology. 

 

Jon

Hi Jon,

 

Thanks for pointing that out, not sure how I missed that. I changed the neighbor to 10.0.0.5 instead.

 

As requested, the Routing Tables of R4 and R5 are below:

R4
Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.0.0.0/30 is directly connected, Ethernet0/0
L 10.0.0.2/32 is directly connected, Ethernet0/0
172.16.0.0/16 is variably subnetted, 5 subnets, 2 masks
C 172.16.0.0/30 is directly connected, Ethernet0/1
L 172.16.0.1/32 is directly connected, Ethernet0/1
O 172.16.0.4/30 [110/20] via 172.16.0.10, 00:02:31, Ethernet0/2
[110/20] via 172.16.0.2, 00:02:31, Ethernet0/1
C 172.16.0.8/30 is directly connected, Ethernet0/2
L 172.16.0.9/32 is directly connected, Ethernet0/2


R5
Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.0.0.4/30 is directly connected, Ethernet0/0
L 10.0.0.5/32 is directly connected, Ethernet0/0
172.16.0.0/16 is variably subnetted, 5 subnets, 2 masks
O 172.16.0.0/30 [110/20] via 172.16.0.9, 00:27:46, Ethernet0/2
[110/20] via 172.16.0.5, 00:27:36, Ethernet0/1
C 172.16.0.4/30 is directly connected, Ethernet0/1
L 172.16.0.6/32 is directly connected, Ethernet0/1
C 172.16.0.8/30 is directly connected, Ethernet0/2
L 172.16.0.10/32 is directly connected, Ethernet0/2

 

Jon Marshall
VIP Community Legend

 

So R4 and R4 do not have routes to the IPs you have used for the neighbor IPs. 

 

You need to advertise the 10.0.0.x/30 subnets into OSPF.

 

Jon

So I need to redistribute BGP into OSPF? Or just add a static route for R4 and R5 pointing to the BGP neighbor addresses?
Jon Marshall
VIP Community Legend

 

You could use statics although you would also need them on R3 as well or you can do - 

 

R4

 

router ospf 10
network 10.0.0.0 0.0.0.3 area 0
passive-interface e0/0

 

R5

 

router ospf 10
network 10.0.0.4 0.0.0.3 area 0
passive-interface e0/0

 

Jon

Jon Marshall
VIP Community Legend

 

Apologies, got that the wrong way round. 

 

Have just edited previous post with correct details :) 

 

Jon