cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
323
Views
0
Helpful
3
Replies

Establish EIGRP adjacency through 819-4g router not supporting EIGRP

Eric Marshott
Beginner
Beginner

I have a Cisco 819 with 4G which is a "spoke" and has a layer 3 DMVPN connection to the "hub."

Diagram

This (C819HG-4G-V-K9) router does not support EIGRP, therefore I cannot establish adjacency to the DMVPN "hub." It is hearing eigrp hellos over the tunnel interface.

I have a router which does support EIGRP which I would like to "pass-through" the unsupported router, and establish an adjacency with the hub.

My router is connected to the vlan 1 on the 819 router and I am seeing these debug messages as a result of "debug ip packet" with access list specifying only EIGRP:

  Dec 30 12:37:52.849 EST: IP: s=172.22.201.162 (Vlan1), d=224.0.0.10, len 60, input feature, MCI Check(108), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE
  Dec 30 12:37:52.849 EST: IP: s=172.22.201.162 (Vlan1), d=224.0.0.10, len 60, unroutable
  Dec 30 12:37:56.000 EST: IP: s=10.242.244.1 (Tunnel100), d=224.0.0.10, len 60, input feature, packet consumed, MCI Check(108), rtype 0, forus FALSE, sendself FALSE, mtu 0, fwdchk FALSE

As you can see, the (unsupported) 819/4g router is seeing both eigrp hello multicast packets but an adjacency is not established because:

  1. The hello seen on the tunnel interface is not passed through to the VLAN 1
  2. The hello seen on the VLAN 1 is "unroutable" and is not forwarded onto the tunnel interface

A static route is defined for default traffic to use the ip address at the "hub" router, which I am able to ping from the CLI of the "spoke" 819/4g router.

All traffic from the EIGRP router is statically destined to the 819/4g router.

Is there a way that I can establish the EIGRP adjacency "across" the 819/4g to the DMVPN "hub", without having EIGRP running on the 4g router?

I have tried connecting the router to the WAN/gigabit interface of the 819/4g router without luck, so I thought it might work connecting it to a VLAN/switchport.

Could I add the tunnel to the VLAN so that communication on the tunnel will be heard across the VLAN?

How do I route these EIGRP multicasts through the 819 router so that the EIGRP supported router connected to VLAN 1 could establish adjacency?

I am not permitted to make additional configuration the the DMVPN-HUB which is running EIGRP.

3 Replies 3

casanavep
Participant
Participant

please send the configurations for both the tunnel and VLAN interfaces

--HUB--

interface Tunnel100
bandwidth 1000000
ip address 10.242.244.1 255.255.254.0
no ip redirects
ip mtu 1400
no ip split-horizon eigrp 1
ip nhrp authentication <retracted>
ip nhrp map multicast dynamic
ip nhrp map group 150Mbps-GROUP service-policy output 150Mbps-PARENT
ip nhrp map group 100Mbps-GROUP service-policy output 100Mbps-PARENT
ip nhrp map group 50Mbps-GROUP service-policy output 50Mbps-PARENT
ip nhrp map group 10Mbps-GROUP service-policy output 10Mbps-PARENT
ip nhrp map group 3Mbps-GROUP service-policy output 3Mbps-PARENT
ip nhrp network-id 100
ip nhrp holdtime 600
ip tcp adjust-mss 1360
tunnel source GigabitEthernet0/0
tunnel mode gre multipoint
tunnel key 100
tunnel vrf INET-PUBLIC
tunnel protection ipsec profile DMVPN-PROFILE
hold-queue 1984 in
hold-queue 1984 out
end

--spoke/819-4g--

interface Tunnel100
description Tunnel to PSDC
bandwidth 50000
ip address 10.242.244.100 255.255.254.0
no ip redirects
ip mtu 1400
ip nhrp authentication <retracted>
ip nhrp group 50Mbps-GROUP
ip nhrp map multicast <public IP retracted>
ip nhrp map 10.242.244.1 <public IP retracted>
ip nhrp network-id 100
ip nhrp holdtime 600
ip nhrp nhs 10.242.244.1
ip tcp adjust-mss 1360
tunnel source Cellular0
tunnel mode gre multipoint
tunnel key 100
tunnel protection ipsec profile DMVPN-PROFILE shared
end

interface Vlan1
ip address 172.22.201.161 255.255.255.252
end

VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Fa0, Fa1, Fa2, Fa3

--router supporting EIGRP--

interface GigabitEthernet0/0
ip address 172.22.201.162 255.255.255.252
speed 100
duplex full
end

Given that the hub IP address is in subnet 10.242.244.0 and that the router IP address is in subnet 172.22.201.160 it will not be possible to establish an EIGRP neighbor relationship between these two hosts at least not with their current addressing. If you want the hub to become an EIGRP neighbor with the router you need to find a way to have them have addresses in a common subnet. If the 819 router needs to be the device connecting to outside then I do not see a way to get EIGRP between your remote router and the jub.

HTH

Rick

HTH

Rick
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers