cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
557
Views
4
Helpful
7
Replies

Etherchannel between layer 2 and layer 3 device:increase bandwidth?

shanel1
Level 1
Level 1

So I have a question about utilizing etherchannel between a layer 2 switch and routed interfaces on a layer 3 switch.

I am building the standard 3 layer topology based of an example, with access switches feeding into multiple distribution switches, and I got the idea to double the amount of links and utilize etherchannel.

Configuration on Multilayer switch:

interface Port-channel12
no switchport
ip address 192.168.1.1 255.255.255.0
interface FastEthernet0/21
no switchport
no ip address
channel-group 12 mode on
!
interface FastEthernet0/22
no switchport
no ip address
channel-group 12 mode on

Config on Access switch:

interface Port-channel1
interface FastEthernet0/23
channel-group 1 mode on
!
interface FastEthernet0/24
channel-group 1 mode on

 

Traffic is flowing, and if a link goes down, the connection stays up. However, when I'm running a simulation in packet tracer, I am noticing that it will only use one link, unless that link is down. Will this port-channel configuration actually double bandwidth to the device, or is it just for redundancy since it is using a different protocol on both ends?

Additionally, is it overkill to double-connect an access switch to every distribution switch, since the multiple distribution switches should provide redundancy anyway?

Thanks,

Shane

 
1 Accepted Solution

Accepted Solutions

Generally, Etherchannel provides an interface that can be used usually the same as one of its underlying interfaces.  So, if you can have L2 on one side and L3 on the other, Etherchannel would normally allow the same across it.

BTW, forgot to mention, in my prior reply, hashing choice is per side, and can differ between end-points, and sometimes should differ between end points.

Your hash algorithms are only src or dst and MAC or IP?  Often if there's a src IP and dst MAC or IP choice, that's usually a good, if not also the optimal, choice.

What your choice of hashing algorithm normally is based on what attributes of the frame or packet will change the most in the egress direction.

For example, suppose you have a L3 gateway connected to a VLAN, with multiple host, sending traffic across an Etherchannel.  I.e. one IP/MAC (the gateway's) communicating with lots of hosts on the same subnet.

If you only had a src or dst with the choice of MAC or IP, traffic from the gateway has the same src (itself) but many dst (other hosts).  So, for Etherchannel from gateway toward hosts you would want to use dst MAC or IP.

Conversely, from the hosts, they are all sending traffic to the same dst, by each has a different src.  So, now you should use src  MAC or IP.

If you have a src and dst MAC or IP, such would work for either direction.

Again, what's important, look to use whatever attribute, of the frames or packets, that changes across multiple flows.

View solution in original post

7 Replies 7

Reza Sharifi
Hall of Fame
Hall of Fame

Hi Shane,

Additionally, is it overkill to double-connect an access switch to every distribution switch, since the multiple distribution switches should provide redundancy anyway?

Yes, that is a good idea because Ethernet channels provide redundancy but do not necessarily increase the bandwidth. 

So, when you add more ports to an EtherChannel, it is like adding more lanes to a highway. Adding more lanes allows you to fit more cars onto the highway, but the speed can still be 55 MPH. So there is no bandwidth increase because a car can only use one lane at a time and can go up to 55 MPH.

HTH 

 

Joseph W. Doherty
Hall of Fame
Hall of Fame

Etherchannel, besides providing redundancy, does also provide additional aggregate bandwidth, but that's not the same as providing additional bandwidth as if you were increasing the bandwidth on a single link.

Firstly, with Etherchannel, a single flow is limited to using just one link.

Secondly, Etherchannel uses a hash algorithm to select a flow's link, which may not well distribute flows, in fact, worst case, all flows are directed to the same link.

Thirdly, Etherchannel does not take into account current link loading, so even is one link is at full utilization while another is at zero utilization, a new flow may be directed to the already fully utilized link.

Lastly, assuming all flow are randomly distributed, because of the third point, a dual Etherchannel will net about an effective 50% bandwidth increase, not doubling.

So, is Etherchannel worth using? It can be, much depends on your network goals and requirements.

Thank you for the response!

Is it possible that using etherchannel between layer 2 and layer 3 instead of between two similiar layer endpoints is causing unexpected behavior(not seeing activity on second link pinging from multiple devices) or is that just me not understanding how etherchannel operates between two different layers. I seem to have the option to load balance between src/dst mac/ip but I'm not sure how that would work in this specific case.

Generally, Etherchannel provides an interface that can be used usually the same as one of its underlying interfaces.  So, if you can have L2 on one side and L3 on the other, Etherchannel would normally allow the same across it.

BTW, forgot to mention, in my prior reply, hashing choice is per side, and can differ between end-points, and sometimes should differ between end points.

Your hash algorithms are only src or dst and MAC or IP?  Often if there's a src IP and dst MAC or IP choice, that's usually a good, if not also the optimal, choice.

What your choice of hashing algorithm normally is based on what attributes of the frame or packet will change the most in the egress direction.

For example, suppose you have a L3 gateway connected to a VLAN, with multiple host, sending traffic across an Etherchannel.  I.e. one IP/MAC (the gateway's) communicating with lots of hosts on the same subnet.

If you only had a src or dst with the choice of MAC or IP, traffic from the gateway has the same src (itself) but many dst (other hosts).  So, for Etherchannel from gateway toward hosts you would want to use dst MAC or IP.

Conversely, from the hosts, they are all sending traffic to the same dst, by each has a different src.  So, now you should use src  MAC or IP.

If you have a src and dst MAC or IP, such would work for either direction.

Again, what's important, look to use whatever attribute, of the frames or packets, that changes across multiple flows.

This was the response that really put it all together, thank you.
One quirk of packet tracer is it shows all the traffic going across a certain channel, but when you check the individual packet, it will specify the other interfaces, showing proper balancing.

Cheers.

Ah, Packet Tracer, it very often doesn't match actual device operations.

Hello @shanel1 ,

what devices are you using for your tests ?

Some old switches were actually only capable of redundancy over an etherchannel like Cat 2950.

Besides this, if your test is a single IP flow then it  will use a single link based on the load balancing algorythm used at both ends.

Having one side Layer 3 and the other side Layer 2 is possible and this should not impact on what you see in tests.

A layer 2 port-channel can load balance traffic based on an hash of source IP and destination IP but again the capabilities of load balancing are platform dependent and also the default hashing algorythm used.

if one side uses a source MAC address algorythm on the L3 side just to be clear all user traffic will use a single member link because all frames have a source MAC address = source MAC address of L3 port-channel interface.

With default settings most of platforms will use an exor of last significant bits of source IP address and destination IP address to select a member link. Packets classified in a flow will use the same member link until it is operational.

Hope to help

Giuseppe

 

Review Cisco Networking for a $25 gift card