cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
5470
Views
0
Helpful
6
Replies

etherchannel fail to work after one of the port is down

donnie
Level 1
Level 1

Hi all,

I did a test to configure a etherchannel using port23 and port24 on 2 switches to connect them together. I tested connectivity between devices connected on different switch and it works fine. However if i shut down either port 23 or port24 on 1 switch, connectivity between the switches fail to work. This shldnt be the case since i have the other port in my etherchannel. Pls advise. Thks in advance. below is my config

Current configuration : 2155 bytes

!

version 12.2

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname Switch

!

!

!

interface FastEthernet0/1

switchport access vlan 2

switchport mode access

!

interface FastEthernet0/2

switchport access vlan 2

switchport mode access

!

interface FastEthernet0/3

switchport access vlan 2

switchport mode access

!

interface FastEthernet0/4

switchport access vlan 2

switchport mode access

!

interface FastEthernet0/5

switchport access vlan 2

switchport mode access

!

interface FastEthernet0/6

switchport access vlan 2

switchport mode access

!

interface FastEthernet0/7

switchport access vlan 2

switchport mode access

!

interface FastEthernet0/8

switchport access vlan 2

switchport mode access

!

interface FastEthernet0/9

switchport access vlan 2

switchport mode access

!

interface FastEthernet0/10

switchport access vlan 2

switchport mode access

!

interface FastEthernet0/11

switchport access vlan 3

switchport mode access

!

interface FastEthernet0/12

switchport access vlan 3

switchport mode access

!

interface FastEthernet0/13

switchport access vlan 3

switchport mode access

!

interface FastEthernet0/14

switchport access vlan 3

switchport mode access

!

interface FastEthernet0/15

switchport access vlan 3

switchport mode access

!

interface FastEthernet0/16

switchport access vlan 3

switchport mode access

!

interface FastEthernet0/17

switchport access vlan 3

switchport mode access

!

interface FastEthernet0/18

switchport access vlan 3

switchport mode access

!

interface FastEthernet0/19

switchport access vlan 3

switchport mode access

!

interface FastEthernet0/20

switchport access vlan 3

switchport mode access

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

channel-group 1 mode on

switchport mode trunk

!

interface FastEthernet0/24

channel-group 1 mode on

switchport mode trunk

!

interface GigabitEthernet1/1

!

interface GigabitEthernet1/2

!

interface Port-channel 1

switchport mode trunk

!

interface Vlan1

no ip address

shutdown

!

!

line con 0

!

line vty 0 4

login

line vty 5 15

login

!

!

end

6 Replies 6

JohnTylerPearce
Level 7
Level 7

What model switch is this? When the EtherChannel is functioning correctly can you post the output of 'show etherchannel summary' ?

Hi,

I am using 2960. SHow etherchannel summary as below for both switches. Thk you!

Switch#show etherchannel sum

Flags:  D - down        P - in port-channel

        I - stand-alone s - suspended

        H - Hot-standby (LACP only)

        R - Layer3      S - Layer2

        U - in use      f - failed to allocate aggregator

        u - unsuitable for bundling

        w - waiting to be aggregated

        d - default port

Number of channel-groups in use: 1

Number of aggregators:           1

Group  Port-channel  Protocol    Ports

------+-------------+-----------+----------------------------------------------

1      Po1(SU)           LACP   Fa0/23(P) Fa0/24(D)

Hi,

Just to add, i try changing channel-group mode to active, shut dwn 1 port and still it doesnt work. THere are 2 vlans running across the etherchannel and only 1 vlan could work and not the other

interface FastEthernet0/23

channel-group 1 mode on

switchport mode trunk

!

interface FastEthernet0/24

channel-group 1 mode on

switchport mode trunk

From looking at that configuration, I would assume that the default of all vlans are allowed over that trunk as far as those interfaces are concerned. Look at the configuration of each switch and verify that the appropriate vlans allowed to travel over each trunk port. Also, you have several different types of EtherChannels.

LACP - Open Standard

PAgP - Cisco Proprietary

Static - Always on

With LACP- you will need to either have 'channel-group 1 mode active' and the other side will need to be either 'active as well or passive'.

With PAgP - You will need to either have 'channel-group 1 mode desirable' and the other side will need to be auto and or desirable as well. You cannot have auto on one end and auto on the other end, the EtherChannel will not come up.

Static - You will need configured as 'channel-group 1 mode on' on both ends. This is statically set and does not dynamically setup an etherchannel.

Generally, the number used after channel-group doesn't matter, but in older switches it will need to be the same. I would make them the same anyone just for better clarification on what goes where.

Hi,

Switch#show etherchannel sum

Flags:  D - down        P - in port-channel

        I - stand-alone s - suspended

        H - Hot-standby (LACP only)

        R - Layer3      S - Layer2

        U - in use      f - failed to allocate aggregator

        u - unsuitable for bundling

        w - waiting to be aggregated

        d - default port

Number of channel-groups in use: 1

Number of aggregators:           1

Group  Port-channel  Protocol    Ports

------+-------------+-----------+----------------------------------------------

1      Po1(SU)           LACP   Fa0/23(P) Fa0/24(D)

here from the output, i can see your Po1 is UP > (SU) !
anyway, if you are experiencing problems, remove the portchannel interface which is already there. then try to explicitly configure the parameters that you need to be there on ur member interfaces. lets say;

int f0/23  & int f0/24

switchport trunk encapsulation dot1q

switchport mode trunk

switchport trunk allowed vlan .... (optional)

channel-group 1 mode on

then, shut down the po1 (newly created) on both switches and bring them back up.

see if it works fine.

plz Rate if it helped.

Soroush.

Hope it Helps!

Soroush.

   Your display shows one port being down before you even start . Do both ports show connected  when you do a show int status ?    Between cisco devices use  a negotiated etherchannel either lacp or pagp .  This is for pagp. When bringing the port channel up do a no shut on the port channel SVI so that both ports come active at the same time .

int x/23

switchport mode trunk

switchport trunk native vlan X --  must match on both sides

switchport trunk allowed vlan x

channel-group 5  mode desirable non-silent

int x/24

switchport mode trunk

switchport trunk native vlan X --  must match on both sides

switchport trunk allowed vlan x

channel-group 5  mode desirable non-silent

int port-channel 5

switchport mode trunk

switchport trunk native vlan x

switchport trunk allowed vlan x

no shut

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: