cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
6470
Views
25
Helpful
9
Replies
tylerlucas
Beginner

Etherchannel (LACP) Between Cisco and Extreme

I'm trying to get LACP working between a Cisco Switch (3750 stack) and ExtremeSummit400.

I have looked online, and I'm not seeing a whole lot of documentation on the Extreme end.  I did find this blog post: http://www.thecruftofmybrain.com/2010/12/04/cisco-and-extreme-interoperability-%E2%80%93-part-2-%E2%80%93-lacp/

I have both ends configured.  The Cisco end is configured as "active" (for LACP).

When I have a steady ping going from one switch to the other, and I disconnect one of the two cables, one packet is dropped.  This isn't huge, but it seems like there should be no drops at all.

Also, when reconnecting the cable, pings die for a long time while Spanning Tree renegotiates.  Why doesn't traffic continue to pass over the 2nd link? Is it adviseable to have STP disabled on LACP interfaces?

Thanks!

9 REPLIES 9
rassoul.ghaznavi
Beginner

It more likey looks STP is doing something and LACP is not working properly,

Can you calrify the port stats with "show spanning-tree"

and also try to debug spanning-tree events on the Cisco router and send the result when you disconnect the cable and connect it back.

Network group

Both show forwarding on all VLANs.

Try enabling port-fast on the Cisco switch and test again.

Can you try to change the LACP mode to "on" instead to force it,

There could be a negotiation problem,

Not sure if there is similar thing on Extreme switch as well!

Also, Spanning tree should not operate on LACP link, I would try "debug spanning-tree" and disconnect and connect the cable back to make sure about that.

Spanning tree should take care of the bundle (ether-channel). What about the load distribution alogorithm (Hash) on Extreme side?

When debugging spanning-tree events and unplugging the cable, then plugging it back in, it looks like it does actually go through the STP process.

I have several VLANs on this switch stack (which would be trunked to the Extreme).  When doing "sh spann", it shows that both etherchannel interfaces are forwarding, EXCEPT on Vlan1.  Why is that?

Also - I now see an interface called "St1" in the "sh spann" output.

tylerlucas
Beginner

I called Extreme and got some additional info from them.

According to them, and the Command Reference Guide, to enable LACP, the following command is used on the Extreme:

enable sharing grouping dynamic

The 'dynamic' key word is what enables LACP.  The first is to identify the master port in the grouping, and the identifies what ports will participate.

Prior to configuring this, when I would check LACP on the Cisco with 'sh etherchannel' it showed that LACP was enabled but it was not functional.  None of the 'sh lacp ' commands had any output.  After configuring the Extreme, I now see LACP traffic being passed back and forth on the Cisco, and it shows that LACP is active.  Also, instead of showing both ports in 'sh spanning-tree', it now shows po1.

Everything *looks* correct.

When I start a ping from the Cisco to the Extreme, though, and unplug the first cable, all VLANs go down and the ping dies.  After I plug the cable back in, it takes about 30 sec for the pings to begin working, while po1 goes through the standard STP process.

It appears that I need to disable STP on po1.  I'm fine with doing that, but it seems odd - I thought that Etherchannel automatically handled (disabled?) STP?

EDIT: I just attempted to disable STP on po1 and received this error:

"%Warning: portfast should only be enabled on ports connected to a single

host. Connecting hubs, concentrators, switches, bridges, etc... to this

interface  when portfast is enabled, can cause temporary bridging loops.

Use with CAUTION

%Portfast has been configured on Port-channel1 but will only"

That is not actually an error, it is just a warning and portfast still should be there,

You might need to confirm it with viewing the config.

Also, when you disconnect the cable on an LACP link, it shoulnt' go through STP process,

How if you leave the cable disconnected for a minute?

Does it come back up?

Also if you can try channel-group 1 mode passive

as well, to make sure negotiation is working correctly.

The entire error didn't copy on my previous post, but it was saying that portfast will only be enabled if the interface is NOT in trunking mode.  These links are trunking, so I guess portfast isn't even an option.

I am going to configure RSTP + LACP again and I will verify whether or not STP is occurring and how long it takes, and if the link comes back up when I plug the cable back in.