cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

270
Views
0
Helpful
1
Replies
Highlighted
Beginner

EtherChannel under Dynamic Routing Network

Hi all :

I have configured the EtherChannel in a network. This is a Dynamic Network by using switches. The problem now I have is if between two switches with Dynamic Routing and there is EtherChannel for two ports (just a minimum 2 lines port-channel), the whole connection will down even I only shut up one port.

Below is configuration of two switches with the proper port-channel setup and these two switches are running OSPF routing, they are working fine with all the two ports are on. When anyone of the port is down, the whole connection is down. This is not good as the EtherChannel should provide redundancy that with one port down, another port should cover the connection and the connection should be normal.

By just taking out the  Dynamic Routing between these two switch, the two lines are acted as redundancy to cover each other.That means if I shut up one port, another port can act as connection for the two switches.

May I know is that a way by Dynamic Routing, the EtherChannel can work as redundancy?

Many thanks!

Best regards,

TangSuan Tan

Switch1 config :

Switch#sh run
Building configuration...

Current configuration : 1863 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
no ip domain-lookup
!
!
spanning-tree mode pvst!
!
!
interface FastEthernet0/1
no switchport
channel-group 1 mode on
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/2
no switchport
channel-group 1 mode on
no ip address
duplex auto
speed auto
!
interface FastEthernet0/3
no switchport
channel-group 2 mode on
no ip address
duplex auto
speed auto
!
interface FastEthernet0/4
no switchport
channel-group 2 mode on
no ip address
duplex auto
speed auto
!
interface FastEthernet0/5
no switchport
channel-group 3 mode on
no ip address
duplex auto
speed auto
!
interface FastEthernet0/6
no switchport
channel-group 3 mode on
no ip address
duplex auto
speed auto
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Port-channel 1
no switchport
ip address 192.168.1.1 255.255.255.248
!
interface Port-channel 2
no switchport
ip address 192.168.4.1 255.255.255.248
!
interface Port-channel 3
!
interface Vlan1
no ip address
shutdown
!
router ospf 200
log-adjacency-changes
network 192.168.1.0 0.0.0.7 area 0
!
ip classless!
!
line con 0
exec-timeout 0 0
line vty 0 4
login
!
end

Switch#ping 192.168.1.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/4/8 ms

Switch#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#int fa0/1
Switch(config-if)#sh

Switch(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to administratively down

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down

Switch(config-if)#end
Switch#
%SYS-5-CONFIG_I: Configured from console by console

Switch#ping 192.168.1.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

Switch#
00:25:20: %OSPF-5-ADJCHG: Process 200, Nbr 192.168.1.2 on Port-channel 1 from FULL to DOWN, Neighbor Down: Dead timer expired

00:25:20: %OSPF-5-ADJCHG: Process 200, Nbr 192.168.1.2 on Port-channel 1 from FULL to DOWN, Neighbor Down: Interface down or detached

Switch#ping 192.168.1.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

Switch 2 config :

Switch#sh run
Building configuration...

Current configuration : 1445 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
!
interface FastEthernet0/1
no switchport
channel-group 1 mode on
no ip address
duplex auto
speed auto
!
interface FastEthernet0/2
no switchport
channel-group 1 mode on
no ip address
duplex auto
speed auto
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Port-channel 1
no switchport
ip address 192.168.1.2 255.255.255.248
!
interface Vlan1
no ip address
shutdown
!
router ospf 200
log-adjacency-changes
network 192.168.1.0 0.0.0.7 area 0
!
ip classless
!
!
line con 0
exec-timeout 0 0
logging synchronous
line vty 0 4
login
!

!
end


Switch#

1 REPLY 1
VIP Expert

EtherChannel under Dynamic Routing Network

Hi,

Can you change the mode to active on one side and passive on the other side and test again?

switch-2

interface FastEthernet0/1

no switchport

channel-group 1 mode active

no ip address

duplex auto

speed auto

switch-1

interface FastEthernet0/1

no switchport

channel-group 1 mode passive

no ip address

duplex auto

speed auto

shutdown

HTH

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards