cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
622
Views
5
Helpful
4
Replies

Etherswitch module and BVI

Hi, Im having some trouble with switching and BVIs. Im trying to setup an AP with local switching so i need a trunk port. This is my network setup.

VLAN HELL.png

 

When I plug the AP directly into the switch below the router all the vlans work however when I have it connected to the POE modules only a single vlan will pass traffic.

 

When I go to the routers config page it shows that the vlans that don't pass traffic (11 and 12) are down 

GigabitEthernet0/0         unassigned      YES NVRAM  up                    up     
GigabitEthernet0/0.10      unassigned      YES unset  up                    up     
GigabitEthernet0/0.11      unassigned      YES unset  up                    up     
GigabitEthernet0/0.12      unassigned      YES unset  up                    up     
GigabitEthernet0/1         unassigned      YES NVRAM  administratively down down   
GigabitEthernet0/1/0       unassigned      YES unset  up                    up     
GigabitEthernet0/1/1       unassigned      YES unset  up                    up     
GigabitEthernet0/1/2       unassigned      YES unset  down                  down   
GigabitEthernet0/1/3       unassigned      YES unset  down                  down   
GigabitEthernet0/1/4       unassigned      YES unset  down                  down   
GigabitEthernet0/1/5       unassigned      YES unset  down                  down   
GigabitEthernet0/1/6       unassigned      YES unset  down                  down   
GigabitEthernet0/1/7       unassigned      YES unset  down                  down   
BVI10                      10.0.0.221      YES NVRAM  up                    up     
BVI11                      10.0.1.10       YES NVRAM  up                    up     
BVI12                      10.0.2.10       YES NVRAM  up                    up     
Vlan1                      unassigned      YES unset  up                    up     
Vlan10                     unassigned      YES unset  up                    up     
Vlan11                     unassigned      YES unset  down                  down   
Vlan12                     unassigned      YES unset  down                  down

 

 

Starting from the bottom the port connecting the switch to the router is configured as follows

 

interface ethernet 1/47
 jumbo frame mtu 9014
 switchport allowed vlan add 1 untagged
 switchport mode trunk
 switchport allowed vlan add 1,10-12 tagged

The router is configured as follows 

 

interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface GigabitEthernet0/0.10
 encapsulation dot1Q 10
 bridge-group 10
!
interface GigabitEthernet0/0.11
 encapsulation dot1Q 11
 bridge-group 11
!
interface GigabitEthernet0/0.12
 encapsulation dot1Q 12
 bridge-group 12
!
 
interface Vlan1
 no ip address
!
interface Vlan10
 no ip address
 bridge-group 10
!
interface Vlan11
 no ip address
 bridge-group 11
!
interface Vlan12
 no ip address
 bridge-group 12
interface BVI10
 ip address 10.0.0.10 255.255.255.0
!
interface BVI11
 ip address 10.0.1.10 255.255.255.0
!
interface BVI12
 ip address 10.0.2.10 255.255.255.0
!
bridge 10 protocol ieee
bridge 10 route ip
bridge 11 protocol ieee
bridge 11 route ip
bridge 12 protocol ieee
bridge 12 route ip
!

 

Finally the POE module on the router is configured as follows.

interface GigabitEthernet0/1/0
 switchport trunk native vlan 10
 switchport trunk allowed vlan 1,2,10-12,1002-1005
 switchport mode trunk
 no ip address
!
interface GigabitEthernet0/1/1
 switchport trunk native vlan 10
 switchport trunk allowed vlan 1,2,10-12,1002-1005
 switchport mode trunk
 no ip address
!
interface GigabitEthernet0/1/2
 switchport trunk native vlan 10
 switchport trunk allowed vlan 1,2,10-12,1002-1005
 switchport mode trunk
 no ip address
!
interface GigabitEthernet0/1/3
 switchport trunk native vlan 10
 switchport trunk allowed vlan 1,2,10-12,1002-1005
 switchport mode trunk
 no ip address
!
interface GigabitEthernet0/1/4
 switchport trunk native vlan 10
 switchport trunk allowed vlan 1,2,10-12,1002-1005
 switchport mode trunk
 no ip address
!
interface GigabitEthernet0/1/5
 switchport trunk native vlan 10
 switchport trunk allowed vlan 1,2,10-12,1002-1005
 switchport mode trunk
 no ip address
!
interface GigabitEthernet0/1/6
 switchport trunk native vlan 10
 switchport trunk allowed vlan 1,2,10-12,1002-1005
 switchport mode trunk
 no ip address
!
interface GigabitEthernet0/1/7
 switchport trunk native vlan 10
 switchport trunk allowed vlan 1,2,10-12,1002-1005
 switchport mode trunk
 no ip address


The problem has to be from the router up as everything else on the network is working fine. I can ping the BVI IPs from the different vlans so that access is working. However when i connect the AP to the POE module only Vlan 10 pases traffic.

 

Is there something wrong with my config ?

1 Accepted Solution

Accepted Solutions

Ok. It was the vlan database.

 

When I set one of the ports to an access port I got the following.


(config-if)#switchport access vlan 11
% Access VLAN does not exist. Creating vlan 11


So I went to the vlan database

after entering

 

vlan database

vlan 11

vlan 12

 

the vlans came online so it turns out they have to be created in the vlan database and the config as an interface.

 

View solution in original post

4 Replies 4

Edwin Portillo
Collaborator
Collaborator
My friend,

It has also tried to allow trunking VLANs:

interface ethernet 1/47
switchport trunk allowed vlan add 1,10-12 tagged

The switch is not a cisco and its configured for trunking (its an edgecore). I can ping the BVI interface IP addresses from devices connected to the switch on the same vlan.

 

Here is the sh vlans output


Virtual LAN ID:  1 (IEEE 802.1Q Encapsulation)
   vLAN Trunk Interface:   GigabitEthernet0/0
 This is configured as native Vlan for the following interface(s) :
GigabitEthernet0/0    Native-vlan Tx-type: Untagged
   Protocols Configured:   Address:              Received:        Transmitted:
GigabitEthernet0/0 (1)
        Other                                           0                  53
   227 packets, 13620 bytes input
   53 packets, 6983 bytes output
Virtual LAN ID:  10 (IEEE 802.1Q Encapsulation)
   vLAN Trunk Interface:   GigabitEthernet0/0.10
   Protocols Configured:   Address:              Received:        Transmitted:
GigabitEthernet0/0.10 (10)
        Bridging        Bridge Group 10              3558                   3
        Other                                           0                 183
   10488 packets, 3624443 bytes input
   186 packets, 12780 bytes output
Virtual LAN ID:  11 (IEEE 802.1Q Encapsulation)
   vLAN Trunk Interface:   GigabitEthernet0/0.11
   Protocols Configured:   Address:              Received:        Transmitted:
GigabitEthernet0/0.11 (11)
        Bridging        Bridge Group 11                46                   0
        Other                                           0                 184
   423 packets, 42957 bytes input
   184 packets, 12512 bytes output
Virtual LAN ID:  12 (IEEE 802.1Q Encapsulation)
   vLAN Trunk Interface:   GigabitEthernet0/0.12
   Protocols Configured:   Address:              Received:        Transmitted:
GigabitEthernet0/0.12 (12)
        Bridging        Bridge Group 12                78                   0
        Other                                           0                 184
   644 packets, 76900 bytes input
   184 packets, 12512 bytes output
 

Vlan11 is down, line protocol is down
  Hardware is EtherSVI, address is b838.6123.ffab (bia b838.6123.ffab)
  MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive not supported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 1 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
CUBE#sh int vlan10
Vlan10 is up, line protocol is up
  Hardware is EtherSVI, address is b838.6123.ffab (bia b838.6123.ffab)
  MTU 1500 bytes, BW 1000000 Kbit/sec, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set

I can set the BVI11 and BVI12 interface ip address to DHCP and they do indeed get ip address's yet the vlan associated with it stays down.

Attached is the routers config.

 

Vlan.PNG

And above Vlan 11 and 12 are down even though bvi11 and bvi 12 have got DHCP IP addresses ?]

Ok. It was the vlan database.

 

When I set one of the ports to an access port I got the following.


(config-if)#switchport access vlan 11
% Access VLAN does not exist. Creating vlan 11


So I went to the vlan database

after entering

 

vlan database

vlan 11

vlan 12

 

the vlans came online so it turns out they have to be created in the vlan database and the config as an interface.

 
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: