cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
685
Views
0
Helpful
10
Replies

First Experience with Cisco Nexus UPLINK Port Issue

Dear Experts,


Facing 2 Issues.

Please read complete thread and advise

 


This is my first experience with Cisco Nexus Switch.
I have tried a lot but uplink ports are not getting up but strangely the peer device (laptop or any other device connected to uplink port) getting up.

I have already replaced SFP modules and these are GLC-T modules and even with new modules I am facing same issue.

Also I have tried to reset switch many time but once it load it seems reset but i can see some configurations are pre-configured.

Is this normal behavior of Nexus ?

Could anyone suggest on this ?

Below are the details.

NXOS image file is: bootflash:///nxos.7.0.3.I7.9.bin

cisco Nexus 3048 Chassis

switch# sh running-config interface ethernet 1/49

!Command: show running-config interface Ethernet1/49
!Running configuration last done at: Sun Feb 11 14:10:41 2024
!Time: Sun Feb 11 14:20:53 2024

version 7.0(3)I7(9) Bios:version 4.5.0

interface Ethernet1/49

switch# sh running-config interface ethernet 1/50

!Command: show running-config interface Ethernet1/50
!Running configuration last done at: Sun Feb 11 14:10:41 2024
!Time: Sun Feb 11 14:20:56 2024

version 7.0(3)I7(9) Bios:version 4.5.0

interface Ethernet1/50

switch# sh running-config interface ethernet 1/51

!Command: show running-config interface Ethernet1/51
!Running configuration last done at: Sun Feb 11 14:10:41 2024
!Time: Sun Feb 11 14:20:59 2024

version 7.0(3)I7(9) Bios:version 4.5.0

interface Ethernet1/51

switch# sh running-config interface ethernet 1/52

!Command: show running-config interface Ethernet1/52
!Running configuration last done at: Sun Feb 11 14:10:41 2024
!Time: Sun Feb 11 14:21:01 2024

version 7.0(3)I7(9) Bios:version 4.5.0

interface Ethernet1/52

 

switch# sh interface ethernet 1/49 transceiver details
Ethernet1/49
transceiver is present
type is 1000base-T
name is CISCO
part number is GLC-T
revision is B2
serial number is UT20230413192
nominal bitrate is 1300 MBit/sec
Link length supported for copper is 100 m
cisco id is 3
cisco extended id number is 4

DOM is not supported

 

 

switch# sh interface ethernet 1/50 transceiver details
Ethernet1/50
transceiver is present
type is 1000base-SX
name is CISCO
part number is GLC-T
revision is A
serial number is UT20230601171
nominal bitrate is 1300 MBit/sec
cisco id is 3
cisco extended id number is 4
cisco part number is 10-2626-01
cisco product id is SFP-GE-S
cisco vendor id is V01

SFP Detail Diagnostics Information (internal calibration)
----------------------------------------------------------------------------
Current Alarms Warnings
Measurement High Low High Low
----------------------------------------------------------------------------
Temperature 19.77 C 90.00 C -45.00 C 85.00 C -40.00 C
Voltage 3.31 V 3.63 V 2.97 V 3.47 V 3.13 V
Current 28.99 mA 90.00 mA 1.00 mA 80.00 mA 3.00 mA
Tx Power -6.02 dBm -1.00 dBm -11.02 dBm -1.99 dBm -10.00 dBm
Rx Power -4.88 dBm -1.99 dBm -30.00 dBm -3.00 dBm -26.98 dBm
Transmit Fault Count = 0
----------------------------------------------------------------------------
Note: ++ high-alarm; + high-warning; -- low-alarm; - low-warning

 

 

switch# sh interface ethernet 1/51 transceiver details
Ethernet1/51
transceiver is present
type is 1000base-SX
name is CISCO
part number is GLC-T
revision is A
serial number is UT20230601155
nominal bitrate is 1300 MBit/sec
cisco id is 3
cisco extended id number is 4
cisco part number is 10-2626-01
cisco product id is SFP-GE-S
cisco vendor id is V01

SFP Detail Diagnostics Information (internal calibration)
----------------------------------------------------------------------------
Current Alarms Warnings
Measurement High Low High Low
----------------------------------------------------------------------------
Temperature 19.77 C 90.00 C -45.00 C 85.00 C -40.00 C
Voltage 3.31 V 3.63 V 2.97 V 3.47 V 3.13 V
Current 28.99 mA 90.00 mA 1.00 mA 80.00 mA 3.00 mA
Tx Power -6.02 dBm -1.00 dBm -11.02 dBm -1.99 dBm -10.00 dBm
Rx Power -4.88 dBm -1.99 dBm -30.00 dBm -3.00 dBm -26.98 dBm
Transmit Fault Count = 0
----------------------------------------------------------------------------
Note: ++ high-alarm; + high-warning; -- low-alarm; - low-warning

 

 

switch# sh interface ethernet 1/52 transceiver details
Ethernet1/52
transceiver is present
type is 1000base-SX
name is CISCO
part number is GLC-T
revision is A
serial number is UT20230601046
nominal bitrate is 1300 MBit/sec
cisco id is 3
cisco extended id number is 4
cisco part number is 10-2626-01
cisco product id is SFP-GE-S
cisco vendor id is V01

SFP Detail Diagnostics Information (internal calibration)
----------------------------------------------------------------------------
Current Alarms Warnings
Measurement High Low High Low
----------------------------------------------------------------------------
Temperature 19.77 C 90.00 C -45.00 C 85.00 C -40.00 C
Voltage 3.31 V 3.63 V 2.97 V 3.47 V 3.13 V
Current 28.99 mA 90.00 mA 1.00 mA 80.00 mA 3.00 mA
Tx Power -6.02 dBm -1.00 dBm -11.02 dBm -1.99 dBm -10.00 dBm
Rx Power -4.88 dBm -1.99 dBm -30.00 dBm -3.00 dBm -26.98 dBm
Transmit Fault Count = 0
----------------------------------------------------------------------------
Note: ++ high-alarm; + high-warning; -- low-alarm; - low-warning

 

 

Please advise how we can solve this issue.

Peer device port is getting up but not from Nexus side

But only port Eth 1/51 port is getting up from nexus side and not 49/50/52 ports but peer device connected with these ports are getting up.

 

 

See below configuration which is pre-configured and even after reset this doesn't remove from switch.

 

 

switch# sh running-config

!Command: show running-config
!Running configuration last done at: Sun Feb 11 14:10:41 2024
!Time: Sun Feb 11 14:26:13 2024

version 7.0(3)I7(9) Bios:version 4.5.0
power redundancy-mode combined force

vdc switch id 1
limit-resource vlan minimum 16 maximum 4094
limit-resource vrf minimum 2 maximum 4096
limit-resource port-channel minimum 0 maximum 104
limit-resource u4route-mem minimum 128 maximum 128
limit-resource u6route-mem minimum 96 maximum 96
limit-resource m4route-mem minimum 58 maximum 58
limit-resource m6route-mem minimum 8 maximum 8
feature ptp
feature lldp

no password strength-check
username admin password 5 $5$ogN9AW6r$gLAxWV2rce1DRQknhYdDHBrshCLsEQhXqvfD4D95/7
7 role network-admin
ip domain-lookup
service unsupported-transceiver
ip access-list copp-system-acl-eigrp
10 permit eigrp any 224.0.0.10/32
ipv6 access-list copp-system-acl-eigrp6
10 permit eigrp any ff02::a/128
ip access-list copp-system-acl-icmp
10 permit icmp any any
ip access-list copp-system-acl-igmp
10 permit igmp any any
ip access-list copp-system-acl-ntp
10 permit udp any any eq ntp
20 permit udp any eq ntp any
ip access-list copp-system-acl-pimreg
10 permit pim any any
ip access-list copp-system-acl-ping
10 permit icmp any any echo
20 permit icmp any any echo-reply
ip access-list copp-system-acl-routingproto1
10 permit tcp any gt 1024 any eq bgp
20 permit tcp any eq bgp any gt 1024
30 permit udp any 224.0.0.0/24 eq rip
40 permit tcp any gt 1024 any eq 639
50 permit tcp any eq 639 any gt 1024
70 permit ospf any any
80 permit ospf any 224.0.0.5/32
90 permit ospf any 224.0.0.6/32
ip access-list copp-system-acl-routingproto2
10 permit udp any 224.0.0.0/24 eq 1985
20 permit 112 any 224.0.0.0/24
ip access-list copp-system-acl-snmp
10 permit udp any any eq snmp
20 permit udp any any eq snmptrap
ip access-list copp-system-acl-ssh
10 permit tcp any any eq 22
20 permit tcp any eq 22 any
ip access-list copp-system-acl-stftp
10 permit udp any any eq tftp
20 permit udp any any eq 1758
30 permit udp any eq tftp any
40 permit udp any eq 1758 any
50 permit tcp any any eq 115
60 permit tcp any eq 115 any
ip access-list copp-system-acl-tacacsradius
10 permit tcp any any eq tacacs
20 permit tcp any eq tacacs any
30 permit udp any any eq 1812
40 permit udp any any eq 1813
50 permit udp any any eq 1645
60 permit udp any any eq 1646
70 permit udp any eq 1812 any
80 permit udp any eq 1813 any
90 permit udp any eq 1645 any
100 permit udp any eq 1646 any
ip access-list copp-system-acl-telnet
10 permit tcp any any eq telnet
20 permit tcp any any eq 107
30 permit tcp any eq telnet any
40 permit tcp any eq 107 any
ipv6 access-list copp-system-acl-v6routingProto2
10 permit udp any ff02::66/128 eq 2029
20 permit udp any ff02::fb/128 eq 5353
30 permit 112 any ff02::12/128
40 permit pim any ff02::d/128
ipv6 access-list copp-system-acl-v6routingproto1
10 permit 89 any ff02::5/128
20 permit 89 any ff02::6/128
30 permit udp any ff02::9/128 eq 521
ip access-list copp-system-dhcp-relay
10 permit udp any eq bootps any eq bootps
class-map type control-plane match-any copp-icmp
match access-group name copp-system-acl-icmp
class-map type control-plane match-any copp-ntp
match access-group name copp-system-acl-ntp
class-map type control-plane match-any copp-s-arp
class-map type control-plane match-any copp-s-bfd
class-map type control-plane match-any copp-s-bpdu
class-map type control-plane match-any copp-s-dai
class-map type control-plane match-any copp-s-default
class-map type control-plane match-any copp-s-dhcpreq
class-map type control-plane match-any copp-s-dhcpresp
match access-group name copp-system-dhcp-relay
class-map type control-plane match-any copp-s-dpss
class-map type control-plane match-any copp-s-eigrp
match access-group name copp-system-acl-eigrp
match access-group name copp-system-acl-eigrp6
class-map type control-plane match-any copp-s-glean
class-map type control-plane match-any copp-s-igmp
match access-group name copp-system-acl-igmp
class-map type control-plane match-any copp-s-ipmcmiss
class-map type control-plane match-any copp-s-l2switched
class-map type control-plane match-any copp-s-l3destmiss
class-map type control-plane match-any copp-s-l3mtufail
class-map type control-plane match-any copp-s-l3slowpath
class-map type control-plane match-any copp-s-mpls
class-map type control-plane match-any copp-s-pimautorp
class-map type control-plane match-any copp-s-pimreg
match access-group name copp-system-acl-pimreg
class-map type control-plane match-any copp-s-ping
match access-group name copp-system-acl-ping
class-map type control-plane match-any copp-s-ptp
class-map type control-plane match-any copp-s-routingProto1
match access-group name copp-system-acl-routingproto1
match access-group name copp-system-acl-v6routingproto1
class-map type control-plane match-any copp-s-routingProto2
match access-group name copp-system-acl-routingproto2
class-map type control-plane match-any copp-s-selfIp
class-map type control-plane match-any copp-s-ttl1
class-map type control-plane match-any copp-s-v6routingProto2
match access-group name copp-system-acl-v6routingProto2
class-map type control-plane match-any copp-s-vxlan
class-map type control-plane match-any copp-snmp
match access-group name copp-system-acl-snmp
class-map type control-plane match-any copp-ssh
match access-group name copp-system-acl-ssh
class-map type control-plane match-any copp-stftp
match access-group name copp-system-acl-stftp
class-map type control-plane match-any copp-tacacsradius
match access-group name copp-system-acl-tacacsradius
class-map type control-plane match-any copp-telnet
match access-group name copp-system-acl-telnet
policy-map type control-plane copp-system-policy
class copp-s-default
police pps 400
class copp-s-l2switched
police pps 200
class copp-s-ping
police pps 100
class copp-s-l3destmiss
police pps 100
class copp-s-glean
police pps 500
class copp-s-selfIp
police pps 500
class copp-s-l3mtufail
police pps 100
class copp-s-ttl1
police pps 100
class copp-s-ipmcmiss
police pps 400
class copp-s-l3slowpath
police pps 100
class copp-s-dhcpreq
police pps 300
class copp-s-dhcpresp
police pps 300
class copp-s-dai
police pps 300
class copp-s-igmp
police pps 400
class copp-s-eigrp
police pps 200
class copp-s-pimreg
police pps 200
class copp-s-pimautorp
police pps 200
class copp-s-routingProto2
police pps 1300
class copp-s-v6routingProto2
police pps 1300
class copp-s-routingProto1
police pps 1000
class copp-s-arp
police pps 200
class copp-s-ptp
police pps 1000
class copp-s-vxlan
police pps 1000
class copp-s-bfd
police pps 350
class copp-s-bpdu
police pps 12000
class copp-s-dpss
police pps 1000
class copp-s-mpls
police pps 100
class copp-icmp
police pps 200
class copp-telnet
police pps 500
class copp-ssh
police pps 500
class copp-snmp
police pps 500
class copp-ntp
police pps 100
class copp-tacacsradius
police pps 400
class copp-stftp
police pps 400
control-plane
service-policy input copp-system-policy
snmp-server user admin network-admin auth md5 0x1524b6667cbaecb503d6dc5050bb9a5e
priv 0x1524b6667cbaecb503d6dc5050bb9a5e localizedkey
rmon event 1 log trap public description FATAL(1) owner PMON@FATAL
rmon event 2 log trap public description CRITICAL(2) owner PMON@CRITICAL
rmon event 3 log trap public description ERROR(3) owner PMON@ERROR
rmon event 4 log trap public description WARNING(4) owner PMON@WARNING
rmon event 5 log trap public description INFORMATION(5) owner PMON@INFO

vlan 1
vrf context management
no port-channel load-balance resilient

no hardware profile ecmp resilient


interface Ethernet1/1

interface Ethernet1/2

interface Ethernet1/3

interface Ethernet1/4

interface Ethernet1/5

interface Ethernet1/6

interface Ethernet1/7

interface Ethernet1/8

interface Ethernet1/9

interface Ethernet1/10

interface Ethernet1/11

interface Ethernet1/12

interface Ethernet1/13

interface Ethernet1/14

interface Ethernet1/15

interface Ethernet1/16

interface Ethernet1/17

interface Ethernet1/18

interface Ethernet1/19

interface Ethernet1/20

interface Ethernet1/21

interface Ethernet1/22

interface Ethernet1/23

interface Ethernet1/24

interface Ethernet1/25

interface Ethernet1/26

interface Ethernet1/27

interface Ethernet1/28

interface Ethernet1/29

interface Ethernet1/30

interface Ethernet1/31

interface Ethernet1/32

interface Ethernet1/33

interface Ethernet1/34

interface Ethernet1/35

interface Ethernet1/36

interface Ethernet1/37

interface Ethernet1/38

interface Ethernet1/39

interface Ethernet1/40

interface Ethernet1/41

interface Ethernet1/42

interface Ethernet1/43

interface Ethernet1/44

interface Ethernet1/45

interface Ethernet1/46

interface Ethernet1/47

interface Ethernet1/48

interface Ethernet1/49

interface Ethernet1/50

interface Ethernet1/51

interface Ethernet1/52

interface mgmt0
vrf member management
line console
line vty

 

switch#

 

10 Replies 10

balaji.bandi
Hall of Fame
Hall of Fame

Can you post 

# sh interface ethernet 1/51

# sh interface ethernet 1/50

49-52 are uplink fixed ports right ?

they support 1/10G - Remove the SFP from any of the ports not working. try speed 1000 adding command and inset the SFP and test it ?

what is other side connected to these ports ? how far they are ? hope they are in the Cat 5 Limitation distance ?

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Hi @balaji.bandi 

Yes Ports from 49-52 are fixed ports.

Please find below output.

Nexus-AJK# sh int ethernet 1/50
Ethernet1/50 is down (Link not connected)
admin state is up, Dedicated Interface
Hardware: 1000/10000 Ethernet, address: 1c6a.7a6c.12d9 (bia 1c6a.7a6c.12d9)
MTU 1500 bytes, BW 10000000 Kbit, DLY 10 usec
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, medium is broadcast
Port mode is access
auto-duplex, auto-speed, media type is 1G
Beacon is turned off
Auto-Negotiation is turned on FEC mode is Auto
Input flow-control is off, output flow-control is off
Auto-mdix is turned off
Rate mode is dedicated
Switchport monitor is off
EtherType is 0x8100
EEE (efficient-ethernet) : n/a
admin fec state is auto, oper fec state is off
Last link flapped never
Last clearing of "show interface" counters never
0 interface resets
Load-Interval #1: 30 seconds
30 seconds input rate 0 bits/sec, 0 packets/sec
30 seconds output rate 0 bits/sec, 0 packets/sec
input rate 0 bps, 0 pps; output rate 0 bps, 0 pps
Load-Interval #2: 5 minute (300 seconds)
300 seconds input rate 0 bits/sec, 0 packets/sec
300 seconds output rate 0 bits/sec, 0 packets/sec
input rate 0 bps, 0 pps; output rate 0 bps, 0 pps
RX
0 unicast packets 0 multicast packets 0 broadcast packets
0 input packets 0 bytes
0 jumbo packets 0 storm suppression packets
0 runts 0 giants 0 CRC 0 no buffer
0 input error 0 short frame 0 overrun 0 underrun 0 ignored
0 watchdog 0 bad etype drop 0 bad proto drop 0 if down drop
0 input with dribble 0 input discard
0 Rx pause
TX
0 unicast packets 0 multicast packets 0 broadcast packets
0 output packets 0 bytes
0 jumbo packets
0 output error 0 collision 0 deferred 0 late collision
0 lost carrier 0 no carrier 0 babble 0 output discard
0 Tx pause

 

Nexus-AJK# sh int ethernet 1/51
Ethernet1/51 is down (Link not connected)
admin state is up, Dedicated Interface
Hardware: 1000/10000 Ethernet, address: 1c6a.7a6c.12da (bia 1c6a.7a6c.12da)
MTU 1500 bytes, BW 10000000 Kbit, DLY 10 usec
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, medium is broadcast
Port mode is access
auto-duplex, auto-speed, media type is 1G
Beacon is turned off
Auto-Negotiation is turned on FEC mode is Auto
Input flow-control is off, output flow-control is off
Auto-mdix is turned off
Rate mode is dedicated
Switchport monitor is off
EtherType is 0x8100
EEE (efficient-ethernet) : n/a
admin fec state is auto, oper fec state is off
Last link flapped never
Last clearing of "show interface" counters never
0 interface resets
Load-Interval #1: 30 seconds
30 seconds input rate 0 bits/sec, 0 packets/sec
30 seconds output rate 0 bits/sec, 0 packets/sec
input rate 0 bps, 0 pps; output rate 0 bps, 0 pps
Load-Interval #2: 5 minute (300 seconds)
300 seconds input rate 0 bits/sec, 0 packets/sec
300 seconds output rate 0 bits/sec, 0 packets/sec
input rate 0 bps, 0 pps; output rate 0 bps, 0 pps
RX
0 unicast packets 0 multicast packets 0 broadcast packets
0 input packets 0 bytes
0 jumbo packets 0 storm suppression packets
0 runts 0 giants 0 CRC 0 no buffer
0 input error 0 short frame 0 overrun 0 underrun 0 ignored
0 watchdog 0 bad etype drop 0 bad proto drop 0 if down drop
0 input with dribble 0 input discard
0 Rx pause
TX
0 unicast packets 0 multicast packets 0 broadcast packets
0 output packets 0 bytes
0 jumbo packets
0 output error 0 collision 0 deferred 0 late collision
0 lost carrier 0 no carrier 0 babble 0 output discard
0 Tx pause

Nexus-AJK#

 

 

 

Nexus-AJK# sh running-config interface ethernet 1/52

!Command: show running-config interface Ethernet1/52
!Running configuration last done at: Mon Feb 12 13:02:46 2024
!Time: Mon Feb 12 13:02:55 2024

version 7.0(3)I7(9) Bios:version 4.5.0

interface Ethernet1/52
switchport mode trunk
switchport trunk allowed vlan 253
speed 1000


After setting up the speed 1000 port is still not up but peer side port is up as before.

See below status

Nexus-AJK# ^C
Nexus-AJK# sh int et 1/52 statu

--------------------------------------------------------------------------------
Port Name Status Vlan Duplex Speed Type
--------------------------------------------------------------------------------
Eth1/52 -- notconnec trunk auto 1000 1000base-SX

 

 

 

Please advise further.

 

where is ther device ? what device is that ?

is that cable going via different MDF/IDF ?

If the Port working when you connect Laptop - i suspect other end,

even if you remove the Cable and other end shows up, then that need investigation Physical layer.

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

No There is nothing between Nexus and my Laptop
and not only the Laptop, i have tried many devices like Hub, Laptop, Access Point, and another switch too.

 

It shows up at peer side but Nexus side it's not getting up.

I tried changing many cables too and if I disconnect LAN cable then peer device shows link-down (as normal status).

 

 

ok even if your Laptop connected directly to that port and shows Laptop side up and switch side down.

could be some faulty and bug i suspect ?

 

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Yes Balaji,
Even Laptop directly connected to switch shows Laptop interface up but switch side down.
Thanks so advise if we can conclude this switch uplink ports are faulty or bugs with OS ?

Because this is first time I am using Nexus and even Interface vlan was not creating then I read that we need to enable interface vlan feature in this.
Same I was suspecting may be there is any feature we need to enable or not.

What about second issue as even after reset there is some configurations pre-configured as I have posted in this post.

Is this default config of Nexus or it's not resetting the switch ?
If it's not default configuration then how come it's still on running-config even switch reset done and it was asking initial steps which normally we see after switch reset.

 

Thanks

Joseph W. Doherty
Hall of Fame
Hall of Fame

Just wondering for a Nexus uplink port whether auto MDI is supported.

Hi Joseph,
How do I check this ?
what is the purpose of auto MDI ?
Thanks

MDI and MDI-X apply to copper Ethernet, which pins are Tx and Rx.  One side's Tx connects to the other sides Rx.  If RJ-45 ports use same pins for Tx and Rx you need a cross over cable.  If the two RJ-45 ports use opposite pins you need a straight through cable.  If either side supports auto MDI, either cable kind can be used.

Hello
Check your fibre cabling you should be using MM OM3 for 1000SX, Also try swaping the poliarity around to see if you have a mismatch.


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card