11-03-2011 03:38 PM - edited 03-07-2019 03:12 AM
Hi All,
I have 2 routers back-to-back in my lab. I'm trying to configure Frame Relay. For now I'm just trying to ping from 12.1 to 12.2 but it's not working. The serial interfaces on both routers are up and up. And prior to implementting Frame Relay my pings were successful.
Any ideas???
ROUTER 1:
interface Serial1
ip address 192.168.12.1 255.255.255.0
ip nat inside
encapsulation frame-relay
no keepalive
frame-relay map ip 192.168.12.2 63
ROUTER 2:
interface Serial0
ip address 192.168.12.2 255.255.255.0
no ip directed-broadcast
encapsulation frame-relay
no keepalive
clockrate 56000
frame-relay map ip 192.168.12.1 65
Solved! Go to Solution.
11-03-2011 04:48 PM
Hi,
One of your routers needs to be a frame relay DCE the other DTE (default)
As router 2 is the DCE end of the back to back we will make it the DCE for frame relay too.
ROUTER 2:
!
interface Serial0
frame-relay intf-type dce
!
As this is point to point with no frame relay switch cloud in the middle we need to use the same DLCI at both ends
ROUTER 1:
interface Serial1
ip address 192.168.12.1 255.255.255.0
ip nat inside
encapsulation frame-relay
no keepalive
frame-relay map ip 192.168.12.2 101 broadcast
bandwidth 56
ROUTER 2:
interface Serial0
ip address 192.168.12.2 255.255.255.0
no ip directed-broadcast
encapsulation frame-relay
no keepalive
clockrate 56000
frame-relay intf-type dce
frame-relay map ip 192.168.12.1 101 broadcast
bandwidth 56
!
Hopefully now it will work
show frame pvc
show frame lmi
you should see that the DLCI is active in both routers
yoiu should see LMI stats incrementing
Ping accroos the network
HTH
Alex
Please rate useful posts
11-03-2011 04:48 PM
Hi,
One of your routers needs to be a frame relay DCE the other DTE (default)
As router 2 is the DCE end of the back to back we will make it the DCE for frame relay too.
ROUTER 2:
!
interface Serial0
frame-relay intf-type dce
!
As this is point to point with no frame relay switch cloud in the middle we need to use the same DLCI at both ends
ROUTER 1:
interface Serial1
ip address 192.168.12.1 255.255.255.0
ip nat inside
encapsulation frame-relay
no keepalive
frame-relay map ip 192.168.12.2 101 broadcast
bandwidth 56
ROUTER 2:
interface Serial0
ip address 192.168.12.2 255.255.255.0
no ip directed-broadcast
encapsulation frame-relay
no keepalive
clockrate 56000
frame-relay intf-type dce
frame-relay map ip 192.168.12.1 101 broadcast
bandwidth 56
!
Hopefully now it will work
show frame pvc
show frame lmi
you should see that the DLCI is active in both routers
yoiu should see LMI stats incrementing
Ping accroos the network
HTH
Alex
Please rate useful posts
11-03-2011 05:20 PM
It's working now. 12.1 can ping 12.2. The only thing I changed was the DLCI.
ROUTER 1:
interface Serial1
ip address 192.168.12.1 255.255.255.0
ip nat inside
encapsulation frame-relay
no keepalive
frame-relay map ip 192.168.12.2 101 broadcast
ROUTER 2:
interface Serial0
ip address 192.168.12.2 255.255.255.0
no ip directed-broadcast
encapsulation frame-relay
no keepalive
clockrate 56000
frame-relay map ip 192.168.12.1 101 broadcast
11-03-2011 05:04 PM
You need to clock the site that is DCE. If you do a "sh contr inter s0" and s1, it will tell you which side is DCE.
in your case you clock r2. Is this the DCE site?
HTH
11-03-2011 05:09 PM
ACCMPBELL - I will now implement the suggestions and let you know
REZA - I think clocking is OK. At least prior to configuring Frame Relay everything was working fine. I also configured PPP and that worked fine. HDLC works fine. This tells me the clocking is working. Do you agree?
11-03-2011 05:17 PM
I have 2 routers back-to-back in my lab. I'm trying to configure Frame Relay. For now I'm just trying to ping from 12.1 to 12.2 but it's not working. The serial interfaces on both routers are up and up. And prior to implementting Frame Relay my pings were successful.Any ideas???
ROUTER 1:
interface Serial1
ip address 192.168.12.1 255.255.255.0
ip nat inside
encapsulation frame-relay
no keepalive
frame-relay map ip 192.168.12.2 63
ROUTER 2:
interface Serial0
ip address 192.168.12.2 255.255.255.0
no ip directed-broadcast
encapsulation frame-relay
no keepalive
clockrate 56000
frame-relay map ip 192.168.12.1 65
What is the ip nat inside doing? Maybe remove it and try
HTH
Kishore
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide