cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
822
Views
0
Helpful
2
Replies
Highlighted
Beginner

FTP upload issue after new PPPoE router connection

I have bought a new 1921 router (IOS :C1900-UNIVERSALK9-M), Version 15.1(4)M4) and connect my ADSL link to it. After router connection i am facing frequent disconnection during uploading any file through coreFTP though i haven't face any problem in downloading any file from FTP server .

if i connect back the ADSL link directly to the PC there is no problem in uploading or downloading.

I have checked the MTU configuration on router and PC (Windows XP) still the same problem arises.

Please find my Router dialer and inside lan interface configuration.

interface Dialer0                  

description ++++ Dialer PPPoE interface_OUTSIDE ++++

ip address negotiated
no ip redirects

mtu 1492

ip tcp adjust-mss 1452
no ip unreachables
no ip proxy-arp
no ip mroute-cache
ip nat outside
encapsulation ppp
dialer pool 1

dialer-group 1
  ppp pap sent-username xxxxx password yyyyyyy
ppp ipcp dns request
ppp ipcp address accept

ppp ipcp route default

interface FastEthernet0/0/0

description ++++ Internet ADSL Link ++++     

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

duplex auto

speed auto

pppoe enable group global

pppoe-client dial-pool-number 1

!

!
interface GigabitEthernet0/0
description ++++ Connected to LAN ++++
dampening
ip address 172.y.x.1 255.255.255.0
ip access-group filter in
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
ip virtual-reassembly

ip tcp adjust-mss 1452
load-interval 30
carrier-delay msec 0
duplex auto
speed auto
!

Kindly suggest any work around. your prompt reply will be appreciated

2 REPLIES 2
Highlighted
Hall of Fame Cisco Employee

Hello,

I do not see any obvious issue with your configuration. This must be something quite minuscule. A couple of suggestions:

  • You are using the mtu 1492 command on Dialer0. Try replacing it with ip mtu 1492 command.
  • On your Dialer0 interface, remove the ip tcp adjust-mss command - it is already present in the Gi0/0 configuration.
  • In the ACL named "filter", make sure that all ICMP protocol messages are permitted.

Best regards,

Peter

Highlighted

Thanks a lot for you prompt reply.

I will do the changes and post the result

Content for Community-Ad