01-13-2021 03:34 PM
Hello
My Network is as such... GigabitEthernet 1/0/1 - 1/0/10 are vlan 10 and are essentially more Interfaces to plug into for my Wireless Router 1 and us use just as a L2 switch
GigabitEthernet 1/0/11 - 1/0/20 are vlan 11 and are for same purpose but for my Wiresless Router 2(VPN) also as a L2.
I want, internally, any device connected to vlan 10 to be able to access vlan 11's NAS so I created vlan 12 and vlan 13 for GigabitInterface 1/0/21 and 1/0/22 for the sole purpose of internal access. Now, this works just fine on my 891f but for some reason, same setup, this is not working on the L3 Switch.
I am at a loss.
I will try to explain this as best as I can but this is the errors I get;
00:09:29: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on GigabitEthernet1/0/21 (12), with Switch GigabitEthernet1/0/1 (10).
00:09:29: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on GigabitEthernet1/0/22 (13), with Switch GigabitEthernet1/0/11 (11).
00:09:29: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on GigabitEthernet1/0/1 (10), with Switch GigabitEthernet1/0/21 (12).
00:09:29: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on GigabitEthernet1/0/11 (11), with Switch GigabitEthernet1/0/22 (13).
00:10:29: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on GigabitEthernet1/0/21 (12), with Switch GigabitEthernet1/0/1 (10).
00:10:29: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on GigabitEthernet1/0/22 (13), with Switch GigabitEthernet1/0/11 (11).
00:10:29: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on GigabitEthernet1/0/1 (10), with Switch GigabitEthernet1/0/21 (12).
00:10:29: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on GigabitEthernet1/0/11 (11), with Switch GigabitEthernet1/0/22 (13).
This is my Configuration;
Current configuration : 2782 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch
!
!
switch 1 provision ws-c3750g-24ps
ip subnet-zero
!
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
!
!
!
interface GigabitEthernet1/0/1
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet1/0/2
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet1/0/3
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet1/0/4
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet1/0/5
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet1/0/6
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet1/0/7
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet1/0/8
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet1/0/9
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet1/0/10
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet1/0/11
switchport access vlan 11
switchport mode access
!
interface GigabitEthernet1/0/12
switchport access vlan 12
switchport mode access
!
interface GigabitEthernet1/0/13
switchport access vlan 11
switchport mode access
!
interface GigabitEthernet1/0/14
switchport access vlan 11
switchport mode access
!
interface GigabitEthernet1/0/15
switchport access vlan 11
switchport mode access
!
interface GigabitEthernet1/0/16
switchport access vlan 11
switchport mode access
!
interface GigabitEthernet1/0/17
switchport access vlan 11
switchport mode access
!
interface GigabitEthernet1/0/18
switchport access vlan 11
switchport mode access
!
interface GigabitEthernet1/0/19
switchport access vlan 11
switchport mode access
!
interface GigabitEthernet1/0/20
switchport access vlan 11
switchport mode access
!
interface GigabitEthernet1/0/21
description TPLink
switchport access vlan 12
!
interface GigabitEthernet1/0/22
description VPN
switchport access vlan 13
!
interface GigabitEthernet1/0/23
!
interface GigabitEthernet1/0/24
!
interface GigabitEthernet1/0/25
!
interface GigabitEthernet1/0/26
!
interface GigabitEthernet1/0/27
!
interface GigabitEthernet1/0/28
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
description Home Lan
no ip address
!
interface Vlan11
description Home VPN
no ip address
!
interface Vlan12
description TPLink
ip address 10.0.1.115 255.255.255.0
!
interface Vlan13
description VPN
ip address 10.0.2.115 255.255.255.0
!
ip classless
ip http server
!
!
!
control-plane
!
!
line con 0
line vty 0 4
no login
line vty 5 15
no login
!
end
01-13-2021 11:41 PM - edited 01-13-2021 11:42 PM
Hello,
the 'Switch' is layer 2 ? You can only have one active layer 3 interface on a layer 2 switch. Post the configuration of the device that is generating the errors (the device connected to 'Switch') as well. Also, if possible, post a diagram showing your topology, as it is not clear from your description what is connected to what.
01-14-2021 08:03 AM
Well this Switch being mentioned is a C3750G-24 Layer 3.
GigabitEthernet 1/0/1 - 1/0/10 are L2 VLAN 10 (purpose to add Interfaces from my WifiRouter to make a bigger LAN)
GigabitEthernet 1/0/11 - 1/0/20 are L2 VLAN 11(purpose to add Interfaces from my VPNRouter to make a bigger LAN)
GigabitEthernet 1/0/21 is enabled as L3 with an IP 10.0.1.115, VLAN 12 (Purpose for any IP on 10.0.2.X to access Network)
GigabitEthernet 1/0/22 is enabled as L3 with an IP 10.0.2.115, VLAN 13 (Purpose for any IP on 10.0.1.X to access Network)
The 'show running-config' is of the Switch in question.
There are no other devices connected aside from WifiRouter connected to GigabitEthernet 1/0/1 as an extension of its LAN for more ports, VPNRouter connected to GigabitEthernet 1/0/11 as an extension of its LAN for more Ports. 1/0/1 - 1/0/20 in general are nothing other than L2 interfaces. GigabitEthernet 1/0/21, as L3 is connected to an Interface on WifiRouter and GigabitEthernet 1/0/22, as L3 is connected to an interface VPNRouter. Both 1/0/21 and 1/0/22 are L3 as to allow WifiRouter and VPNRouter to route between each other Internally.
I know I can not connected 2 separate wireless routers to the same LAN as they are different subnets and vlans in their own right so this is why I did the 2 L3 Interfaces to route between.
But then I am getting the VLAN Mismatch...
I am not home to gather further information but am also going to enable, or disable I should say, the cdp option.
01-14-2021 08:13 AM
Hello,
through which interface is the layer 3 switch connected to the layer 2 switch ? Make sure both these interfaces are configured as trunks, and configured exactly the same.
From the output in your original post, it looks like there are several interfaces connecting both switches ?
01-14-2021 08:25 AM - edited 01-14-2021 08:27 AM
I do not have any Layer 2 Switches. What my intent was was to get a Layer 3 Switch that I can configure 10 Interfaces as a L2 to connect to one of my Wifi Routers (L3?) for more connections as my Wifi Router has 3 ethernet ports and then another 10 interfaces as a L2 to connect to my other Wireless VPN Router (L3?) for more connections. I made ports 1-10 vlan 10 as L2 so I can just plug into any of the associated Interfaces and that device will grab its IP from the Wifi Router (10.0.1.x) and so with the ports 11-20 to do the same from its Wifi VPN Router (10.0.2.x). Interfaces GigabitEthernet 1/0/1 - 1/0/20 are essentially Plug N Play Interfaces for their respective Routers. WifiRouter connects to GigabitEthernet 1/0/1 to give access to 1/0/2 - 1/0/10 and VPN Router connects to 1/0/11 to give access to 1/0/12 - 1/0/20.
With that being said, I wanted, internally (meaning no Internet, just access to the LAN in general) my 10.0.1.x LAN to communicate with my 10.0.2.x LAN but know that cant happen as they are different networks. So I dedicated 1/0/21 as a L3 Interface associated with vlan 12 with an IP Address of 10.0.1.115 and set up an IP Route and then dedicated 1/0/22 as a L3 Interface associated with vlan 13 with an IP Address of 10.0.2.115 and set up an IP Route so both L3 interfaces could then communicate.
And yes, both Wifi Routers do connect to the Switch 2 diff ways. Each with 1 connecting to the Layer 2 Interfaces and then each 1 connecting to a L3 Interface for routing across the network.
01-14-2021 08:47 AM
Hello,
the configuration of the switch you have posted does not show 'ip routing' enabled. Maybe it is the default. Either way, a topology diagram would help, so we can see what (which interfaces) are connected to what.
01-14-2021 08:51 AM
When I get home I get get you further details but would ip routing give me a native vlan mismatch?
01-14-2021 04:46 PM - edited 01-14-2021 04:47 PM
01-14-2021 01:31 AM - edited 01-14-2021 01:33 AM
Hello
Disable CDP on the switch or on the interfaces
conf t
no cdp run
or
int x/x
no cdp enable
01-14-2021 08:04 AM
I will try this when I get home and let you know, thank you.
01-14-2021 04:16 PM
Well I got home and inputted the command 'no cdp run' and it did indeed remove the Native VLAN Mismatch error but I can not for the life of me ping the Interface GigabitEthernet 1/0/21 with a vlan 12 with an ip address of 10.0.1.115 FROM the 10.0.1.1 network connected to it. I am clearly missing something. You would think I would be able to PING the interface on the same network.
01-14-2021 05:28 PM
So that is the L3 Switch it is NOT working on but this is the 891f it IS working on.
interface GigabitEthernet4
switchport access vlan 10
no ip address
!
interface GigabitEthernet5
switchport access vlan 11
no ip address
interface Vlan10
ip address 10.0.1.115 255.255.255.0
!
interface Vlan11
ip address 10.0.2.115 255.255.255.0
I have done without CDP and with ip routing as well, I can not get them to work
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide