cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

1361
Views
5
Helpful
20
Replies
VIP Mentor

Re: GNS 3 iosvl2 Switch not Forwarding DHCP reply packets to the requesting vlan

Hello,

 

post the current configs of both routers...

Highlighted
Beginner

Re: GNS 3 iosvl2 Switch not Forwarding DHCP reply packets to the requesting vlan

Main-Router Configuration Dump

MainRouter#sh run
Building configuration...

Current configuration : 994 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname MainRouter
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
!
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex full
!
interface FastEthernet0/0.2
 encapsulation dot1Q 2 native
 ip address 192.168.2.1 255.255.255.0
 ip helper-address 192.168.2.2
!
interface FastEthernet0/0.3
 encapsulation dot1Q 3
 ip address 192.168.3.1 255.255.255.0
 ip helper-address 192.168.2.2
!
!
router eigrp 1
 network 0.0.0.0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
!
!
end

 DHCP-Server Configuration Dump

Building configuration...

Current configuration : 1036 bytes
!
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname DHCP-Server
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
no ip icmp rate-limit unreachable
ip cef
!
!
!
ip dhcp excluded-address 192.168.2.0 192.168.2.10
ip dhcp excluded-address 192.168.3.0 192.168.3.10
!
ip dhcp pool IT
 network 192.168.2.0 255.255.255.0
 default-router 192.168.2.1
!
ip dhcp pool Clients
 network 192.168.3.0 255.255.255.0
 default-router 192.168.3.1
!
!
!
no ip domain lookup
no ipv6 cef
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 192.168.2.2 255.255.255.0
 duplex full
!
!
router eigrp 1
 network 0.0.0.0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
 stopbits 1
line vty 0 4
 login
!
!
end
Rising star

Re: GNS 3 iosvl2 Switch not Forwarding DHCP reply packets to the requesting vlan

DHCP-Server#sh ip route
VIP Mentor

Re: GNS 3 iosvl2 Switch not Forwarding DHCP reply packets to the requesting vlan

Hello,

 

on the main router, change the vlan 2 subinterface back to what it was (no native):

 

interface FastEthernet0/0.2
encapsulation dot1Q 2 
ip address 192.168.2.1 255.255.255.0
!
interface FastEthernet0/0.3
encapsulation dot1Q 3
ip address 192.168.3.1 255.255.255.0
ip helper-address 192.168.2.2

 

Also, make sure that the switchport connected to your DHCP-Server router is configured as an access port in vlan 2.

 

You need to be able to reach 192.168.3.1 from the DHCP server.

View solution in original post

Beginner

Re: GNS 3 iosvl2 Switch not Forwarding DHCP reply packets to the requesting vlan

Thank you very much
The DHCP lab is finally Functional

I can't thank you enough for assisting me

VIP Mentor

Re: GNS 3 iosvl2 Switch not Forwarding DHCP reply packets to the requesting vlan

Glad that you got it resolved !

CreatePlease to create content
Content for Community-Ad