cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1004
Views
0
Helpful
1
Replies

[GNS3] router to internet lab : NAT encapsulation error

I'm trying to get connected to internet from my lab setup.

 

My design is pretty simply.

 

A Cisco router (3k series) ---> Net (cloud0)

 

My Cisco router (3k series) config:

-----------------------------

ROUTER#sh run
Building configuration...

Current configuration : 950 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ROUTER
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
memory-size iomem 5
clock timezone IST 5 30
ip cef
multilink bundle-name authenticated

archive
log config
hidekeys
!
!
!
!
interface FastEthernet0/0
ip address 192.168.2.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.1.1 255.255.255.0
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 FastEthernet0/1
!
!
ip http server
no ip http secure-server
ip nat inside source static 192.168.2.1 192.168.1.1
!
access-list 1 permit any log
!
!
!
control-plane

!
!
line con 0
line aux 0
line vty 0 4
login
!
!
end

 


ROUTER#sh ip rout
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

C 192.168.1.0/24 is directly connected, FastEthernet0/1
C 192.168.2.0/24 is directly connected, FastEthernet0/0
S* 0.0.0.0/0 is directly connected, FastEthernet0/1
ROUTER#

 


ROUTER#sh ip nat translations
Pro Inside global Inside local Outside local Outside global
--- 192.168.1.1 192.168.2.1 --- ---
ROUTER#

 

 

Here is the Debug error message:

------------------------------
*Mar 1 00:17:43.359: IP: tableid=0, s=192.168.1.1 (local), d=8.8.8.8 (FastEthernet0/1), routed via RIB
*Mar 1 00:17:43.359: IP: s=192.168.1.1 (local), d=8.8.8.8 (FastEthernet0/1), len 100, sending
*Mar 1 00:17:43.363: IP: s=192.168.1.1 (local), d=8.8.8.8 (FastEthernet0/1), len 100, encapsulation failed.
*Mar 1 00:17:45.355: IP: tableid=0, s=192.168.1.1 (local), d=8.8.8.8 (FastEthernet0/1), routed via RIB

 

 

Please help me to find the root cause.

 

1 Reply 1

Mark Malone
VIP Alumni
VIP Alumni
that usualy means it doesnt know the next hop so i would say its an emulator issue as its virtual
something i would try ,change default route to point to the ip rather than the interface and maybe staticlly add the arps macs tgo the router so it doenst have to dynamically have to learn them