cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
7070
Views
0
Helpful
5
Replies

Help with OSPF configuration (Multi-layer switch)

haydenirvin
Level 1
Level 1

Capture.PNG

 

I seem to be configuring OSPF wrong. Need some help. Can one of you assist me?

 

Here are my configs 

 

Router 1 Config

en
config t

int g0/0
ip add 192.168.0.254 255.255.255.0
no shut

int g0/1
ip add 172.16.0.2 255.255.255.252
no shut

int g0/2
ip add 172.16.0.6 255.255.255.252
no shut

 

router ospf 1
network 192.168.0.0 0.0.0.255 area 0
network 172.16.0.0 0.0.0.3 area 0
network 172.16.0.4 0.0.0.3 area 0

 
Multilayer switch 1 (Left side)

en
config t

vlan 5

vlan 10

vlan 15

int vlan 5
ip add 10.0.0.126 255.255.255.128
no shut
ip helper-address 192.168.0.1

int vlan 10
ip add 10.0.0.190 255.255.255.192
no shut
ip helper-address 192.168.0.1

int vlan 15
ip add 10.0.0.254 255.255.255.192
no shut
ip helper-address 192.168.0.1

int g1/0/24
switchport mode acc
switchport mode trunk
no shut

exit
ip routing

 

router ospf 1
network 10.0.0.0 0.0.0.127 area 0
network 10.0.0.128 0.0.0.63 area 0
network 10.0.0.192 0.0.0.63 area 0
network 172.16.0.0 0.0.0.3 area 0

 

Multilayer switch 2 (right side)

en
config t

vlan 5

vlan 10

vlan 15

int vlan 5
ip add 10.0.1.126 255.255.255.128
no shut
ip helper-address 192.168.0.1

int vlan 10
ip add 10.0.1.190 255.255.255.192
no shut
ip helper-address 192.168.0.1

int vlan 15
ip add 10.0.1.254 255.255.255.192
no shut
ip helper-address 192.168.0.1

int g1/0/24
switchport mode acc
switchport mode trunk

exit
ip routing

 

router ospf 1

network 10.0.1.0 0.0.0.127 area 0
network 10.0.1.128 0.0.0.63 area 0
network 10.0.1.192 0.0.0.63 area 0
network 172.16.0.4 0.0.0.3 area 0

2 Accepted Solutions

Accepted Solutions

kapilsoni21
Level 1
Level 1
Remove interface configuration of port gi1/0/24 from both the multilayer switch, and configure the IP addresses from the same subnet which is used by you to connect to router 1, Hope below-mentioned configuration will help you On right side Multilayer switch conf t int g1/0/24 ip add 172.16.0.1 255.255.255.252 no sh exit On Left side Multilayer switch conf t int g1/0/24 ip add 172.16.0.5 255.255.255.252 no sh exit

View solution in original post

Jaderson Pessoa
VIP Alumni
VIP Alumni

@haydenirvin Hello,

 

Do below changes

 

Router 1 Config

en
config t

int g0/0
ip add 192.168.0.254 255.255.255.0
no shut

int g0/1
ip add 172.16.0.2 255.255.255.252
no shut

int g0/2
ip add 172.16.0.6 255.255.255.252
no shut

 

router ospf 1
network 192.168.0.0 0.0.0.255 area 0
network 172.16.0.0 0.0.0.3 area 0
network 172.16.0.4 0.0.0.3 area 0

 
Multilayer switch 1 (Left side)

en
config t

vlan 5

vlan 10

vlan 15

int vlan 5
ip add 10.0.0.126 255.255.255.128
no shut
ip helper-address 192.168.0.1

int vlan 10
ip add 10.0.0.190 255.255.255.192
no shut
ip helper-address 192.168.0.1

int vlan 15
ip add 10.0.0.254 255.255.255.192
no shut
ip helper-address 192.168.0.1

int g1/0/24
no switchport mode acc
no switchport mode trunk

ip address 192.168.0.253 255.255.255.0

ip ospf 1 area 0

 

exit
ip routing

 

router ospf 1
network 10.0.0.0 0.0.0.127 area 0
network 10.0.0.128 0.0.0.63 area 0
network 10.0.0.192 0.0.0.63 area 0
network 172.16.0.0 0.0.0.3 area 0

 

Multilayer switch 2 (right side)

en
config t

vlan 5

vlan 10

vlan 15

int vlan 5
ip add 10.0.1.126 255.255.255.128
no shut
ip helper-address 192.168.0.1

int vlan 10
ip add 10.0.1.190 255.255.255.192
no shut
ip helper-address 192.168.0.1

int vlan 15
ip add 10.0.1.254 255.255.255.192
no shut
ip helper-address 192.168.0.1

int g1/0/24
no switchport mode acc
no switchport mode trunk

ip address 172.16.0.5 255.255.255.252

ip ospf 1 area 0

 

 

exit
ip routing

router ospf 1

network 10.0.1.0 0.0.0.127 area 0
network 10.0.1.128 0.0.0.63 area 0
network 10.0.1.192 0.0.0.63 area 0
network 172.16.0.4 0.0.0.3 area 0

Jaderson Pessoa
*** Rate All Helpful Responses ***

View solution in original post

5 Replies 5

kapilsoni21
Level 1
Level 1
Remove interface configuration of port gi1/0/24 from both the multilayer switch, and configure the IP addresses from the same subnet which is used by you to connect to router 1, Hope below-mentioned configuration will help you On right side Multilayer switch conf t int g1/0/24 ip add 172.16.0.1 255.255.255.252 no sh exit On Left side Multilayer switch conf t int g1/0/24 ip add 172.16.0.5 255.255.255.252 no sh exit

Thank you

 

Jaderson Pessoa
VIP Alumni
VIP Alumni

@haydenirvin Hello,

 

Do below changes

 

Router 1 Config

en
config t

int g0/0
ip add 192.168.0.254 255.255.255.0
no shut

int g0/1
ip add 172.16.0.2 255.255.255.252
no shut

int g0/2
ip add 172.16.0.6 255.255.255.252
no shut

 

router ospf 1
network 192.168.0.0 0.0.0.255 area 0
network 172.16.0.0 0.0.0.3 area 0
network 172.16.0.4 0.0.0.3 area 0

 
Multilayer switch 1 (Left side)

en
config t

vlan 5

vlan 10

vlan 15

int vlan 5
ip add 10.0.0.126 255.255.255.128
no shut
ip helper-address 192.168.0.1

int vlan 10
ip add 10.0.0.190 255.255.255.192
no shut
ip helper-address 192.168.0.1

int vlan 15
ip add 10.0.0.254 255.255.255.192
no shut
ip helper-address 192.168.0.1

int g1/0/24
no switchport mode acc
no switchport mode trunk

ip address 192.168.0.253 255.255.255.0

ip ospf 1 area 0

 

exit
ip routing

 

router ospf 1
network 10.0.0.0 0.0.0.127 area 0
network 10.0.0.128 0.0.0.63 area 0
network 10.0.0.192 0.0.0.63 area 0
network 172.16.0.0 0.0.0.3 area 0

 

Multilayer switch 2 (right side)

en
config t

vlan 5

vlan 10

vlan 15

int vlan 5
ip add 10.0.1.126 255.255.255.128
no shut
ip helper-address 192.168.0.1

int vlan 10
ip add 10.0.1.190 255.255.255.192
no shut
ip helper-address 192.168.0.1

int vlan 15
ip add 10.0.1.254 255.255.255.192
no shut
ip helper-address 192.168.0.1

int g1/0/24
no switchport mode acc
no switchport mode trunk

ip address 172.16.0.5 255.255.255.252

ip ospf 1 area 0

 

 

exit
ip routing

router ospf 1

network 10.0.1.0 0.0.0.127 area 0
network 10.0.1.128 0.0.0.63 area 0
network 10.0.1.192 0.0.0.63 area 0
network 172.16.0.4 0.0.0.3 area 0

Jaderson Pessoa
*** Rate All Helpful Responses ***

haydenirvin
Level 1
Level 1

I needed to do the no switchport command. Thank you

 

glad to help :)
Jaderson Pessoa
*** Rate All Helpful Responses ***
Review Cisco Networking for a $25 gift card