cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Cisco Community Designated VIP Class of 2020

1282
Views
0
Helpful
2
Replies
Highlighted
Beginner

Hostflapping with BVI interface

Hi,

I have a strange problem with hostflapping between directly connected local port and port-channel to other switch where the same router is conneted via second interface.

Setup is as follows:

SW1 (Catalyst 4506) <--> Router 2851 <--> SW2 (Catalyst 4506)

     |______________________________________________|

Related configs:

1. Router 2851 - (C2800NM-SPSERVICESK9-M), Version 15.0(1)M3

bridge irb

interface GigabitEthernet0/0

no ip address

duplex auto

speed auto

bridge-group 1

!

interface GigabitEthernet0/1

no ip address

duplex auto

speed auto

bridge-group 1

interface BVI1

ip address xxx.xxx.xxx.xxx 255.255.255.0

bridge 1 protocol ieee

bridge 1 route ip

2. SW1 port config

interface GigabitEthernet4/9

description R2851-Gi0-1

switchport access vlan 100

switchport mode access

service-policy output autoqos-voip-policy

qos trust dscp

auto qos voip trust

tx-queue 3

   priority high

   shape percent 33

end

2. SW2 port config

interface GigabitEthernet4/9

description R2851-Gi0-0

switchport access vlan 100

switchport mode access

auto qos voip trust

service-policy input AutoQos-VoIP-Input-Cos-Policy

service-policy output AutoQos-VoIP-Output-Policy

end

On SW1 every 30 seconds I see this:

%C4K_EBM-4-HOSTFLAPPING: Host 18:EF:63:xx:xx:xx in vlan 100 is flapping between port Po3 and port Gi4/9

On  router, this is output of "sh spanning-tree":

Bridge group 1 is executing the ieee compatible Spanning Tree protocol

  Bridge Identifier has priority 32768, address 18ef.6363.4d00

  Configured hello time 2, max age 20, forward delay 15

  Current root has priority 24676, address 000f.232c.4c00

  Root port is 4 (GigabitEthernet0/1), cost of root path is 4

  Topology change flag not set, detected flag not set

  Number of topology changes 1 last change occurred 05:25:19 ago

          from GigabitEthernet0/0

  Times:  hold 1, topology change 35, notification 2

          hello 2, max age 20, forward delay 15

  Timers: hello 0, topology change 0, notification 0, aging 300

Port 3 (GigabitEthernet0/0) of Bridge group 1 is blocking

   Port path cost 4, Port priority 128, Port Identifier 128.3.

   Designated root has priority 24676, address 000f.232c.4c00

   Designated bridge has priority 28772, address 2894.0f29.fa40

   Designated port id is 128.201, designated path cost 3

   Timers: message age 3, forward delay 0, hold 0

   Number of transitions to forwarding state: 0

   BPDU: sent 9, received 8123

Port 4 (GigabitEthernet0/1) of Bridge group 1 is forwarding

   Port path cost 4, Port priority 128, Port Identifier 128.4.

   Designated root has priority 24676, address 000f.232c.4c00

   Designated bridge has priority 24676, address 000f.232c.4c00

   Designated port id is 128.201, designated path cost 0

   Timers: message age 1, forward delay 0, hold 0

   Number of transitions to forwarding state: 1

   BPDU: sent 2, received 9757

I have 2 more routers with identical setup, and they are just fine, no hostflapping occures (however, they have 12.4(3i) and 15.1(4)M4 IOS)

It seams that even if router port is in blocking state, SW2 is receiveing its MAC address.

Is this some bug in 15.0(1)M3 IOS or I am missing something?

Thanks,

S.

2 REPLIES 2

Re: Hostflapping with BVI interface

Hello

apart from spanning-tree whi you have considered, you might want to check the presence of:

- a hub, linked to both catalysts

- a cluster of any kind (firewall/server), where each element of the cluster is connected to

a different catalyst

Regards

Francesco

Beginner

Re: Hostflapping with BVI interface

This is resolved by inserting unique MAC address to BVI interface on router.

CreatePlease to create content
Content for Community-Ad